Recommended Posts

Online Update and Manual Update not possible.

Unknown Error 21 comes on 65%.

 

No Problems after that try.

 

/var/log/messages:

Jul  1 22:22:55 XPE_5-2 entry.cgi_SYNO.Core.Upgrade[1].start[15759]: Upgrade.cpp:297 Executing [//upd@te/updater -v -x ]
Jul  1 22:22:55 XPE_5-2 updater: updater.c:5483 Start of the updater...
Jul  1 22:22:55 XPE_5-2 updater: updater.c:2822 orgBuildNumber = 5565, newBuildNumber=5592
Jul  1 22:22:55 XPE_5-2 updater: updater.c:5615 ==== Start flash update ====
Jul  1 22:22:55 XPE_5-2 updater: updater.c:5619 This is X86 platform
Jul  1 22:22:55 XPE_5-2 updater: updater.c:5633 The SynoBoot partitions exist.
Jul  1 22:22:55 XPE_5-2 updater: updater.c:3594 SYNORedBootUpdCheckAndApply(3594): Skip bootloader update, no uboot_do_upd.sh exists
Jul  1 22:22:55 XPE_5-2 updater: updater.c:551 checksum generated by [/bin/grep -i zImage checksum.syno >> /tmp/checksum.syno.tmp]
Jul  1 22:22:55 XPE_5-2 updater: updater.c:570 file [zImage] is being copied to [/tmp/bootmnt]
Jul  1 22:22:55 XPE_5-2 updater: updater.c:578 file [/tmp/bootmnt/zImage] process done.
Jul  1 22:22:55 XPE_5-2 updater: updater.c:551 checksum generated by [/bin/grep -i rd.gz checksum.syno >> /tmp/checksum.syno.tmp]
Jul  1 22:22:55 XPE_5-2 updater: updater.c:570 file [rd.gz] is being copied to [/tmp/bootmnt]
Jul  1 22:22:55 XPE_5-2 updater: updater.c:578 file [/tmp/bootmnt/rd.gz] process done.
Jul  1 22:22:55 XPE_5-2 updater: updater.c:551 checksum generated by [/bin/grep -i grub_cksum.syno checksum.syno >> /tmp/checksum.syno.tmp]
Jul  1 22:22:55 XPE_5-2 updater: updater.c:570 file [grub_cksum.syno] is being copied to [/tmp/bootmnt]
Jul  1 22:22:55 XPE_5-2 updater: updater.c:578 file [/tmp/bootmnt/grub_cksum.syno] process done.
Jul  1 22:22:55 XPE_5-2 updater: updater.c:565 file [/tmp/bootmnt/hda1.tgz] is being removed
Jul  1 22:22:55 XPE_5-2 updater: updater.c:578 file [/tmp/bootmnt/hda1.tgz] process done.
Jul  1 22:22:55 XPE_5-2 updater: updater.c:565 file [/tmp/bootmnt/updater] is being removed
Jul  1 22:22:55 XPE_5-2 updater: updater.c:578 file [/tmp/bootmnt/updater] process done.
Jul  1 22:22:55 XPE_5-2 updater: updater.c:565 file [/tmp/bootmnt/VERSION] is being removed
Jul  1 22:22:55 XPE_5-2 updater: updater.c:578 file [/tmp/bootmnt/VERSION] process done.
Jul  1 22:22:55 XPE_5-2 updater: updater.c:588 checksum file updated by [/bin/cp -f /tmp/checksum.syno.tmp /tmp/bootmnt/checksum.syno]
Jul  1 22:23:02 XPE_5-2 updater: boot/boot_lock.c(225): failed to mount boot device /dev/synoboot1 /tmp/bootmnt (errno:2)
Jul  1 22:23:02 XPE_5-2 updater: updater.c:1319 Failed to mount factory partition
Jul  1 22:23:02 XPE_5-2 updater: boot/boot_lock.c(225): failed to mount boot device /dev/synoboot1 /tmp/bootmnt (errno:2)
Jul  1 22:23:02 XPE_5-2 updater: updater.c:1319 Failed to mount factory partition
Jul  1 22:23:02 XPE_5-2 updater: boot/boot_lock.c(225): failed to mount boot device /dev/synoboot1 /tmp/bootmnt (errno:2)
Jul  1 22:23:02 XPE_5-2 updater: updater.c:1319 Failed to mount factory partition
Jul  1 22:23:02 XPE_5-2 updater: boot/boot_lock.c(225): failed to mount boot device /dev/synoboot1 /tmp/bootmnt (errno:2)
Jul  1 22:23:02 XPE_5-2 updater: updater.c:1319 Failed to mount factory partition
Jul  1 22:23:02 XPE_5-2 updater: boot/boot_lock.c(225): failed to mount boot device /dev/synoboot1 /tmp/bootmnt (errno:2)
Jul  1 22:23:02 XPE_5-2 updater: updater.c:1319 Failed to mount factory partition
Jul  1 22:23:02 XPE_5-2 updater: updater.c:5851 fail to upgrade factory partition
Jul  1 22:23:02 XPE_5-2 updater: updater.c:676 Restoring [zImage]
Jul  1 22:23:02 XPE_5-2 updater: updater.c:687 Copying file [//synob@ckup/zImage] as [/tmp/bootmnt/zImage], result[0]
Jul  1 22:23:02 XPE_5-2 updater: updater.c:676 Restoring [rd.gz]
Jul  1 22:23:02 XPE_5-2 updater: updater.c:687 Copying file [//synob@ckup/rd.gz] as [/tmp/bootmnt/rd.gz], result[0]
Jul  1 22:23:02 XPE_5-2 updater: updater.c:673 Skip restoring [vendor]
Jul  1 22:23:02 XPE_5-2 updater: updater.c:676 Restoring [grub_cksum.syno]
Jul  1 22:23:02 XPE_5-2 updater: updater.c:687 Copying file [//synob@ckup/grub_cksum.syno] as [/tmp/bootmnt/grub_cksum.syno], result[0]
Jul  1 22:23:02 XPE_5-2 updater: updater.c:676 Restoring [hda1.tgz]
Jul  1 22:23:02 XPE_5-2 updater: updater.c:690 Removing file [/tmp/bootmnt/hda1.tgz], result[-1]
Jul  1 22:23:02 XPE_5-2 updater: updater.c:694 Restore [hda1.tgz] fail, remove it from synoboot
Jul  1 22:23:02 XPE_5-2 updater: updater.c:676 Restoring [updater]
Jul  1 22:23:02 XPE_5-2 updater: updater.c:690 Removing file [/tmp/bootmnt/updater], result[-1]
Jul  1 22:23:02 XPE_5-2 updater: updater.c:694 Restore [updater] fail, remove it from synoboot
Jul  1 22:23:02 XPE_5-2 updater: updater.c:676 Restoring [VERSION]
Jul  1 22:23:02 XPE_5-2 updater: updater.c:690 Removing file [/tmp/bootmnt/VERSION], result[-1]
Jul  1 22:23:02 XPE_5-2 updater: updater.c:694 Restore [VERSION] fail, remove it from synoboot
Jul  1 22:23:02 XPE_5-2 updater: updater.c:676 Restoring [checksum.syno]
Jul  1 22:23:02 XPE_5-2 updater: updater.c:687 Copying file [//synob@ckup/checksum.syno] as [/tmp/bootmnt/checksum.syno], result[0]
Jul  1 22:23:02 XPE_5-2 updater: updater.c:6183 fail to rollback flash (restore)
Jul  1 22:23:02 XPE_5-2 updater: updater.c:6219 Failed to accomplish the update! (errno = 21)
Jul  1 22:23:02 XPE_5-2 entry.cgi_SYNO.Core.Upgrade[1].start[15759]: Upgrade.cpp:300 failed to execute updater, r=-2498164
Jul  1 22:23:02 XPE_5-2 synoservicecfg: servicecfg_root_object_get.c:115 service config for service [] is not exist
Jul  1 22:23:17 XPE_5-2 entry.cgi_SYNO.Core.Upgrade[1].start[15759]: update_cpputil.cpp:806 synoservice: start all packages ...
Jul  1 22:23:21 XPE_5-2 entry.cgi_SYNO.Core.Upgrade[1].start[15759]: update_cpputil.cpp:859 synoservice: finish started all packages
Jul  1 22:23:21 XPE_5-2 entry.cgi_SYNO.Core.Upgrade[1].start[15759]: Upgrade.cpp:530 Failed to unpack firmware.

Link to post
Share on other sites
Online Update and Manual Update not possible.

Unknown Error 21 comes on 65%.

 

No Problems after that try.

 

/var/log/messages:

Jul  1 22:22:55 XPE_5-2 entry.cgi_SYNO.Core.Upgrade[1].start[15759]: Upgrade.cpp:297 Executing [//upd@te/updater -v -x ]
Jul  1 22:22:55 XPE_5-2 updater: updater.c:5483 Start of the updater...
Jul  1 22:22:55 XPE_5-2 updater: updater.c:2822 orgBuildNumber = 5565, newBuildNumber=5592
Jul  1 22:22:55 XPE_5-2 updater: updater.c:5615 ==== Start flash update ====
Jul  1 22:22:55 XPE_5-2 updater: updater.c:5619 This is X86 platform
Jul  1 22:22:55 XPE_5-2 updater: updater.c:5633 The SynoBoot partitions exist.
Jul  1 22:22:55 XPE_5-2 updater: updater.c:3594 SYNORedBootUpdCheckAndApply(3594): Skip bootloader update, no uboot_do_upd.sh exists
Jul  1 22:22:55 XPE_5-2 updater: updater.c:551 checksum generated by [/bin/grep -i zImage checksum.syno >> /tmp/checksum.syno.tmp]
Jul  1 22:22:55 XPE_5-2 updater: updater.c:570 file [zImage] is being copied to [/tmp/bootmnt]
Jul  1 22:22:55 XPE_5-2 updater: updater.c:578 file [/tmp/bootmnt/zImage] process done.
Jul  1 22:22:55 XPE_5-2 updater: updater.c:551 checksum generated by [/bin/grep -i rd.gz checksum.syno >> /tmp/checksum.syno.tmp]
Jul  1 22:22:55 XPE_5-2 updater: updater.c:570 file [rd.gz] is being copied to [/tmp/bootmnt]
Jul  1 22:22:55 XPE_5-2 updater: updater.c:578 file [/tmp/bootmnt/rd.gz] process done.
Jul  1 22:22:55 XPE_5-2 updater: updater.c:551 checksum generated by [/bin/grep -i grub_cksum.syno checksum.syno >> /tmp/checksum.syno.tmp]
Jul  1 22:22:55 XPE_5-2 updater: updater.c:570 file [grub_cksum.syno] is being copied to [/tmp/bootmnt]
Jul  1 22:22:55 XPE_5-2 updater: updater.c:578 file [/tmp/bootmnt/grub_cksum.syno] process done.
Jul  1 22:22:55 XPE_5-2 updater: updater.c:565 file [/tmp/bootmnt/hda1.tgz] is being removed
Jul  1 22:22:55 XPE_5-2 updater: updater.c:578 file [/tmp/bootmnt/hda1.tgz] process done.
Jul  1 22:22:55 XPE_5-2 updater: updater.c:565 file [/tmp/bootmnt/updater] is being removed
Jul  1 22:22:55 XPE_5-2 updater: updater.c:578 file [/tmp/bootmnt/updater] process done.
Jul  1 22:22:55 XPE_5-2 updater: updater.c:565 file [/tmp/bootmnt/VERSION] is being removed
Jul  1 22:22:55 XPE_5-2 updater: updater.c:578 file [/tmp/bootmnt/VERSION] process done.
Jul  1 22:22:55 XPE_5-2 updater: updater.c:588 checksum file updated by [/bin/cp -f /tmp/checksum.syno.tmp /tmp/bootmnt/checksum.syno]
Jul  1 22:23:02 XPE_5-2 updater: boot/boot_lock.c(225): failed to mount boot device /dev/synoboot1 /tmp/bootmnt (errno:2)
Jul  1 22:23:02 XPE_5-2 updater: updater.c:1319 Failed to mount factory partition
Jul  1 22:23:02 XPE_5-2 updater: boot/boot_lock.c(225): failed to mount boot device /dev/synoboot1 /tmp/bootmnt (errno:2)
Jul  1 22:23:02 XPE_5-2 updater: updater.c:1319 Failed to mount factory partition
Jul  1 22:23:02 XPE_5-2 updater: boot/boot_lock.c(225): failed to mount boot device /dev/synoboot1 /tmp/bootmnt (errno:2)
Jul  1 22:23:02 XPE_5-2 updater: updater.c:1319 Failed to mount factory partition
Jul  1 22:23:02 XPE_5-2 updater: boot/boot_lock.c(225): failed to mount boot device /dev/synoboot1 /tmp/bootmnt (errno:2)
Jul  1 22:23:02 XPE_5-2 updater: updater.c:1319 Failed to mount factory partition
Jul  1 22:23:02 XPE_5-2 updater: boot/boot_lock.c(225): failed to mount boot device /dev/synoboot1 /tmp/bootmnt (errno:2)
Jul  1 22:23:02 XPE_5-2 updater: updater.c:1319 Failed to mount factory partition
Jul  1 22:23:02 XPE_5-2 updater: updater.c:5851 fail to upgrade factory partition
Jul  1 22:23:02 XPE_5-2 updater: updater.c:676 Restoring [zImage]
Jul  1 22:23:02 XPE_5-2 updater: updater.c:687 Copying file [//synob@ckup/zImage] as [/tmp/bootmnt/zImage], result[0]
Jul  1 22:23:02 XPE_5-2 updater: updater.c:676 Restoring [rd.gz]
Jul  1 22:23:02 XPE_5-2 updater: updater.c:687 Copying file [//synob@ckup/rd.gz] as [/tmp/bootmnt/rd.gz], result[0]
Jul  1 22:23:02 XPE_5-2 updater: updater.c:673 Skip restoring [vendor]
Jul  1 22:23:02 XPE_5-2 updater: updater.c:676 Restoring [grub_cksum.syno]
Jul  1 22:23:02 XPE_5-2 updater: updater.c:687 Copying file [//synob@ckup/grub_cksum.syno] as [/tmp/bootmnt/grub_cksum.syno], result[0]
Jul  1 22:23:02 XPE_5-2 updater: updater.c:676 Restoring [hda1.tgz]
Jul  1 22:23:02 XPE_5-2 updater: updater.c:690 Removing file [/tmp/bootmnt/hda1.tgz], result[-1]
Jul  1 22:23:02 XPE_5-2 updater: updater.c:694 Restore [hda1.tgz] fail, remove it from synoboot
Jul  1 22:23:02 XPE_5-2 updater: updater.c:676 Restoring [updater]
Jul  1 22:23:02 XPE_5-2 updater: updater.c:690 Removing file [/tmp/bootmnt/updater], result[-1]
Jul  1 22:23:02 XPE_5-2 updater: updater.c:694 Restore [updater] fail, remove it from synoboot
Jul  1 22:23:02 XPE_5-2 updater: updater.c:676 Restoring [VERSION]
Jul  1 22:23:02 XPE_5-2 updater: updater.c:690 Removing file [/tmp/bootmnt/VERSION], result[-1]
Jul  1 22:23:02 XPE_5-2 updater: updater.c:694 Restore [VERSION] fail, remove it from synoboot
Jul  1 22:23:02 XPE_5-2 updater: updater.c:676 Restoring [checksum.syno]
Jul  1 22:23:02 XPE_5-2 updater: updater.c:687 Copying file [//synob@ckup/checksum.syno] as [/tmp/bootmnt/checksum.syno], result[0]
Jul  1 22:23:02 XPE_5-2 updater: updater.c:6183 fail to rollback flash (restore)
Jul  1 22:23:02 XPE_5-2 updater: updater.c:6219 Failed to accomplish the update! (errno = 21)
Jul  1 22:23:02 XPE_5-2 entry.cgi_SYNO.Core.Upgrade[1].start[15759]: Upgrade.cpp:300 failed to execute updater, r=-2498164
Jul  1 22:23:02 XPE_5-2 synoservicecfg: servicecfg_root_object_get.c:115 service config for service [] is not exist
Jul  1 22:23:17 XPE_5-2 entry.cgi_SYNO.Core.Upgrade[1].start[15759]: update_cpputil.cpp:806 synoservice: start all packages ...
Jul  1 22:23:21 XPE_5-2 entry.cgi_SYNO.Core.Upgrade[1].start[15759]: update_cpputil.cpp:859 synoservice: finish started all packages
Jul  1 22:23:21 XPE_5-2 entry.cgi_SYNO.Core.Upgrade[1].start[15759]: Upgrade.cpp:530 Failed to unpack firmware.

You see that last line?

Upgrade.cpp:530 Failed to unpack firmware.

Can you confirm that 5592 is installed?

 

My first try the VM didn't upgrade, now trying for the 2nd time via manual update.

edit: Nope it didn't upgrade, i guess we have to wait for a new bootloader.

Link to post
Share on other sites

Can confirm that 5592 will not install without new bootloader. Tried on 3 different machines. Fails at 63% after reboot old system is up and running with no problems or loss of data. Tried both manual and automatic installs on all 3 machines. All 3 booted up to old systems with the only change being a warning that it did not install. No loss of functionality or data.

Link to post
Share on other sites

Hi to all above, as far as i'am aware off, updating to a new release number 5.2-XXXX always needs a new boot image.

Only updates with the same release number are working with the same boot-image.

So please be patient - this is my personal advice.

 

Also i would recommend setting your update params to "only important updates" and no automatic update schedule.

This will probably cut the postings on this forum to half :wink:

Link to post
Share on other sites
I know this

I mean complete deactivate that there is no message for en update in this case that DSM not check if there is a newe Version.

Is this possbile ?

ty

Michael

You can disable the *check for update* task.

Link to post
Share on other sites
  • 2 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.