Recommended Posts

Hi all.

 

I have an intel socket 478 nas based on the 3615xs. I ran it at 5.2 for very long. then upgraded to 6.x and 6.17.

Runs great. Its all onboard, well supported hardware.

Now i want to upgrade to 6.22 to make better use of letsencrypt.

As letsencrypt didnt work on 6.17. Nothing happened when making a certificate. I found some hack to copy the letsencrypt from 6.2. An it created a working certificate.

But now there is still no renew button, so I cant renew the certificate. Maybe once its expired. which wil be tomorrow. But anyway I would like to upgrade.

 

Last time I did the upgrades, I first tried it out on a siimilair pc. The whole proecess from 5.2 to 6.17. With a hd and some data I made in the original pc I wanted to upgrade.

To verify if I would not loose my data. If that data would survive. All my data would.

It all worked fine till 6.17.

I tried 6.22 too. It all installed perfectly. And got found after booting. But the migrate process didnt work.  Only option would be to empty the drive and loose the data.

So I stuck to 6.17.

 

Is there already a way to get this update done? Or get letsencrypt updated?

 

Just read some more about updating that its not worth it. Well thats ok with me.. I just want letsencrypt to work.

it there a way to get it working like in 6.2?

 

 

Thanks!

Edited by kaneelschep
Link to post
Share on other sites
  • kaneelschep changed the title to migrate letsencrypt options 6.17 to 6.22?

Hi.

 

I just tried it again. Dont know why I got hung up about 6.2.2.. Maybe 6.2.3 didnt exist yet when I tried it then.

 

So yesterday I made a quick test nas with ds3617 1.03 loader and 6.2.3 dsm. That worked fine.

Put an exra hd in my own 6.1.7 nas. made a volume and copied some stuff on it. Turned it off.

Put that hd in the new nas pc with the 6.2.3. As the only hd.

It showed on find.synology.com. And gave option to migrate.

I chose migrate. chose the 6.2.3 pat file and after 5 minutes it booted as my original nas. Working fine.

And LEtsencrypt has the option to renew in 6.2.3

I will now put another extra hd in my original nas, make volume and put files on it.

And also put that in the 6.2.3 test nas. To see how the migrate goes then.

 

So I guess I solved my own issue.

If that all works. I will do the same on my own nas. With all my hds detached. To see if that pc supports 6.2.3.

And then attach my hds again.

Then I will have the ds3617 instead of 3615 and 6.2.3 instead of 6.1.7

 

As soon as I am brave enough :P

Edited by kaneelschep
Link to post
Share on other sites

So i was brave yesterday ;)

I unplugged all my hds. Took the HD from the test nas. Which was now basicly my original nas in a new pc ;)

Since I previously migrated that for the test ey ;)  Are we keeping up?

And put this in my original nas.

Changed the mac on the test usb stick to the original nas mac. And booted my original nas pc with it.

It worked the same as with the test nas. It showed on find.syn... It gave option to migrate. Which worked fine. And after 6 minutes the nas was up again.

But then as a 6.2.3 ds3617.

I then connected one of my drives thats not that important. Now it booted into the nas and gave the option for system partition repair.

This took only a few seconds and then all was good.

I added the rest of the drives in once, did the same system repair. And done.

Just had to reinstall most packages. And configure some.

Which is a bit annoying.  Thought it would just keep the settings.

But ey.

 

Did suddenly had a drive that registered as only 1tb instead of 2. But this had nothing to do with the nas software. HPA issue. Probably because of the bios making a wrong hidden file record. Fixed that with HDAT2. It shows correcty again. And it even still had my data.

 

All in all very painless, so worth it. Since letsencrypt now auto renews the certificat.

 

 

 

Link to post
Share on other sites

First, congratulations on a successful upgrade.

 

Regarding your packages and settings comment: It's a bit hard to follow the sequence of drive migration from prod to test and back to prod.  But in the end, it sounds like you added a drive with no volume on it, updated the System Partition (which is an obfuscation of the Linux OS partition and the swap partition), then used that for test, and then back to the prod hardware WITHOUT the other drives.

 

When you boot DSM with no volume, packages are invalidated, because they require the volume in order to function.

 

Normally a migration install preserves virtually everything about the previous system.  I believe that the approach to omit your volume was the cause of your config loss.

Link to post
Share on other sites

I added an extra drive to the original nas. ds3615 1.02 6.1.7. Made a raid group. made a volume. copied some files on it.

Put that drive in another pc with ds3617 1.03. Migrated that drive to 6.2.3. And did that again with another drive to see how it added to the first. Both worked fine.

So we now had my original nas config migrated and updated in the test pc. But without the drive that had all the packages on it.
 

Then I first put one of the test drives in the original pc to migrate. Then added an original drive. And only then the rest, with the volume the packages are installed on.

I guess thats the problem.

Normally you would probably migrate all your disks at the same time. Which makes it possible for all the packages to be able to access their files.

I guess if I would have just started with the drive with package volume, it would have also worked.

 

A lot of packages had to repair/recover or reinstall.

But after closer look, it was only the photo station that needed to be configured again. and indexed again.

Dockers configs for instance where still there.

 

It doesnt matter. I think filewise, this was the safest way to check if the files would still work after the update.

Even if no package at all would have worked. I rather have that than loose files ;)

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.