• 0

DSM non responsive after changes to certificate AND network - Plex still good


Question

I think I've clobbered my XPenology NAS running on an N54L.

 

After years running on an old 5.x DSM, last week I updated to 6.1.  The upgrade went flawlessly. Things were going so great, I decided to finally install a certificate and also replaced my router with a Ubiquiti Dream Machine, which involved me powering down the NAS and moving it to a new room. I only noticed the issue after I had disconnected/reconnected and tried to access from the new UDM powered network.

 

I'm not sure which of these two things messed things up, but I'm 99% it was the certificate with the problem only manifesting after a reboot..

 

So...here's the current status.

 

The good:

 

  • It still sits on it's old IP - 192.x.x.30
  • I can ping it
  • Plex still works fine playing movies from the NAS
  • Home Assistant in a docker container running on the NAS works fine on 192.x.x.30:8123

 

The bad

 

  • I can't get at DSM through a browser
  • Attempted connections to DSM from Edge on IP address:5001 result in Error Connection Refused
  • Surveillance Station on port 5000 won't load
  • SSH isn't working - Connection refused
  • I can't telnet either
  • SMB and AFP don't work any more
  • DSFile doesn't work

 

Any thoughts on how I might be able to rescue it? Thanks HEAPS in advance.

 

Cheers.

Link to post
Share on other sites

9 answers to this question

Recommended Posts

  • 0
24 minutes ago, jensmander said:

I don’t think that this is related to SSL only. Did you change something else within DSM? Firewall, ports, etc.?


Not that I recall.  I did have to open some ports on the old router and forward them to the NAS for Let’s Encrypt to do the initial setup. I haven’t done that on the new one. That would t be it would it?

Link to post
Share on other sites
  • 0
1 hour ago, jensmander said:

Does your PC from where you connect have a static ip or DHCP lease which didn’t change? Maybe DSM blocks your client ip. Can you try to connect from a different IP?

 

I’ve tried DSM from 4 different devices - a Mac, a PC, iPhone and iPad... same result. 

Link to post
Share on other sites
  • 0
On 12/21/2020 at 2:13 AM, jensmander said:

Hmm... do you have a possibility to connect to your N54 by RS232? Afaik this box has no iLo module. 

I don’t unfortunately.  No serial ports - just USB. Pretty confident it doesn’t have iLO, either. 

Link to post
Share on other sites
  • 0

With no output to the serial console it will be more than difficult to solve this 😕

 

Otherwise booting a live linux system would be the last ressort. If it’s „only“ SSL related you could try to mount the  disks and exchange the certificate back to the original one located in

 

/usr/syno/etc/certificate/system/default

Link to post
Share on other sites
  • 0

Thanks.  If there is any other way of restoring DSM to an earlier/clean version I can afford to do that, so long as I can preserve the data on the disks in my file shares.  I don't mind if I lose access to some of the configured apps like Surveillance Station, Plex etc and need to re-configure them from scratch.  The docker containers I already have backed up, too.

 

Is something like that possible/easier to do?

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.