Jump to content
XPEnology Community

ESXi DSM starting disk 2, how can I change to disk 1 + also using multiple vNIC show out of order in DSM?


Recommended Posts



Is there a way to force DSM do detect my VMDK #2 as disk 1?

Also is there a way to map my virtual HW virtual NIC in the same order?


VM HW map grub mac1 DSM LAN #
vNIC #1 mac1 LAN 2
vNIC #2 mac2 LAN 3
vNIC #3 mac3 LAN 4
vNIC #4 mac4 LAN 1



ESXi 7.0U1 / Jun 1.03b DS3617xs / DSM 6.2.3-25426 / FixSynoboot.sh


  • VMDK #1 is Synoboot SATA
  • VMDK #2 is for DSM on PVSCIS (also tried SAS) show has disk 2

Will later add LSI3008 SAS Passthru






Edited by vgeek79
Link to comment
Share on other sites

Do you have any other customizations to the loader?  Can you print your loader options?  I do note that you are using the "Other 5.x Linux 64-bit" profile when the installation directions require "Other 3.x Linux 64-bit" profile.  We would think that it shouldn't matter but it does change the way devices are presented to the VM.  No idea if it has any bearing on this issue.


Here's a fully functioning VM definition with two SATA controllers. 



Link to comment
Share on other sites

Ah, My VMDK2 was on SATA 0:1 fixed now @ SATA 1:0


vNIC Ordering well I'll have to tame my OCD 😅


One last thing if I go beyond 4 NIC, I cant force DSM to use my VM HW MAC, @ 00:50:56:XX:XX:XX but 00:00:7F or similar, any ideas, tried grub




set mac1=005054000001
set mac2=005054000002
set mac3=005054000003
set mac4=005054000004
set mac5=005054000005
set mac6=005054000006
set mac7=005054000007
set mac8=005054000008


Link to comment
Share on other sites

  • 3 weeks later...


On 12/17/2020 at 6:19 AM, flyride said:

DiskIdxMap=0C00 ought to fix your drive numbering problem then.  You should use a SATA controller for disk #2, not PVSCSI.


So I did this and it hid the drive as expected but attempting to update to the latest DSM 6.2.3-25426 update 3 causes the pat file to not verify; no matter what I do I cannot update a new installation of DSM to update 3... The only one that will is the bog standard ESXi install approach that leaves drive 1 of the 12 occupied by the 50MB boot drive.


Any way around this?

Link to comment
Share on other sites

15 minutes ago, flyride said:


When you say "not verify" can you be specific as to what the error message is?  Are you familiar with FixSynoboot?

haha oops, I forgot to install this!  I'm looking at moving from my baremetal install to esxi hosted for reasons and haven't played with the esxi hosted version for years... the working test had the fix installed but didn't have changes to the sata args... Thank you for reminding me all working now :-)

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...