Recommended Posts

History so far I built and had running for five years an expenology system when I had a  double hard drive failure...losing all my data in the process.( I did however still have the hard drives with data that I put on the server 5 years ago....So in reality I have only lost the last 5 years....[there is a lesson here somewhere])..

I then bought another matching two drives and tried to set it up again....and then the motherboard curled up her toes and died....so....long story made short ...  I have a replacement older but functioning i7 computer...I set up the four drives from the crashed machine into this newer one... and have also rebuilt the USB for the new machine....it was found straight away and told me it would try to repair the setup..at the end of this repair it now tells me that no hard discs have been found

so... is there a way to fix this Or would it be best to reformat those hard drives and reload the old data back onto the system

Peter.b3780

Link to post
Share on other sites

further info:

I have an additional set of hard drives...all new "Seagate Baracuda green - all 2TB - all formatted " ... I swapped with the other hard drives and started again ... during the post all the drives were present yet when the Usb activates the system  it shows up on the PC client that there are no hard drives present,,, so I go to "synology assistant"  which connects ok and gives the option to install the 'pat' file ...  I tried using the 6.1 DSM 'pat' file and I am told that its not compatible with my system and I find that the only pat file it will accept is the 6.2 version (which I had downloaded back in october) the next setting which is ... this makes no sense but I went ahead with it  and now have the following error message which popped up after applying network settings and moved on to  "formatting system partition" ... Please wait and do not turn off the power during this procedure

(Then  up pops the error message)

Server error code 38

If you are performing this procedure through a wireless network  connection please switch to Applying System Settings:

It takes about 10 minutes or longer depending on the size of your hard drives .

ethernet cable connection for both your disk station and PC Client and try again

(I am already connected via cat 5 cable!!)

It goes on to say;

An error occurred during installation. The telnet service of the disk station is turned on for error determination please configure your router to forward port 23 to disk station and contact sinology online support … 

Needless to say I havnt done that, however the procedure appears to have stalled at this point … (No traffic thru the switch) so I am stuck again

Peter.b3780

Link to post
Share on other sites

and yet another update...

so ... an old adage says "go back to basics"...so I did I ... I took out another  USB and set it up...I went through checking of all cables and LOL  I found one of the Hard drive power cables had been knocked from its plug and was not connected thus not presenting a full raid 5 setup   I continued checking then started up and ....It has properly set up and is currently accepting data

so thanks to anyone that would have replied...and I will now crawl off to my 'shame" corner

 

 

thanks again

 

peter.b3780

  • Like 1
Link to post
Share on other sites
2 hours ago, peter.b3780 said:

thus not presenting a full raid 5 setup

 

Just out of curiosity, did you set it up as HW raid?

Even if 1 drive had no power, DSM should have seen the other drives during install if set up as single drives (ACHI)🤔

Link to post
Share on other sites
On 12/8/2020 at 12:02 PM, peter.b3780 said:

I have an additional set of hard drives...all new "Seagate Baracuda green - all 2TB - all formatted " .

if wanting to start a new setup without any data its best remove all partitions before install, formatted usually implies one partition that has a file system

also i found it better to use synology assistant and leave the IP setting DHCP for the install process

 

if you run into raid problems with dsm keep in mind its a software raid based on mdadm and there are manually usable reapair options dsm does not offer and also hardware raid does not offer

the disks in a raid set have a event number it it does not match the disks with lower are not used because they are to old, missed data

often the difference is not that big and the amount of lost data would be small, so forcing a disk with lower event number is possible to access the data again (thats when more then the planed redundancy disks (1 for raid5 2 for raid2)  are lost, if its only the redundancy thats out of sync or missing then the normal raid repair can be used (thats what dsm would offer in the gui as rebuild)

 

lesson leard would be to have a backup, it does not need to be all data, often just 1-2 TB are the most important and can easily copied to a cheap usb hdd and even a full backup does not has to be a raid system, as long as its checked to be working a pool of disk as jbod mode can be enough (or big single disk with 16TB)

even cloud backup (like backblaze) can be a option

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.