Starthilfe benötigt Asrock J4105M 2x 4-fach SATA Controller Karten werden vom Bios/System nicht erkannt


Recommended Posts

Moin,

 

ich benötige Starthilfe.

 

Mein Asrock J4105-ITX hat das zeitliche gesegnet. Der Speicherplatz wurde zu dem knapp. Der Händler konnte mir das J4105M als Ersatz liefern. Nach Anfangsschwierigkeiten wegen einem nicht kompatiblen Speicher fährt die Kiste zwar jetzt hoch, aber erkennt nicht die SATA-Karten.

 

Rivo Karte PCIe 3.0 X1 Marvell 88SE9215

Syba SI-PEX40064 PCIe 2.0 X1 Marvell 88SE9215

 

Die internen 2 SATA Anschlüsse werden erkannt sind aber zuwenig für ein SHR aus 4 HDD's. Der Speicherpool wird zwar so oder so geändert, aber ohne funktionierende SATA Karten wird das nichts.

 

Jemand Ideen?

 

@IG-88

Du hattest hier auch das Board empfohlen. Kannst Du dich an bestimmte Einstellungen oder ähnliches erinnern? Muss ich extra's benutzen?

 

Sind BIOS Einstellungen vorzunehmen?

Ich stehe momentan auf den Schlauch und komme nicht vorwärts.

 

Jun Loader 1.04b mit 6.2.2

Link to post
Share on other sites

Moin,

 

ich benötige Starthilfe.

 

Mein Asrock J4105-ITX hat das zeitliche gesegnet. Der Speicherplatz wurde zu dem knapp. Der Händler konnte mir das J4105M als Ersatz liefern. Nach Anfangsschwierigkeiten wegen einem nicht kompatiblen Speicher fährt die Kiste zwar jetzt hoch, aber erkennt nicht die SATA-Karten.

 

Rivo Karte PCIe 3.0 X1 Marvell 88SE9215

Syba SI-PEX40064 PCIe 2.0 X1 Marvell 88SE9215

 

Die internen 2 SATA Anschlüsse werden erkannt sind aber zuwenig für ein SHR aus 4 HDD's. Der Speicherpool wird zwar so oder so geändert, aber ohne funktionierende SATA Karten wird das nichts.

 

Jemand Ideen?

 

@IG-88

Du hattest hier auch das Board empfohlen. Kannst Du dich an bestimmte Einstellungen oder ähnliches erinnern? Muss ich extra's benutzen?

 

Sind BIOS Einstellungen vorzunehmen?

Ich stehe momentan auf den Schlauch und komme nicht vorwärts.

 

Jun Loader 1.04b mit 6.2.2

Link to post
Share on other sites

ist ein wenig eigenartig wenn die karten in dem gleichen board vorher liefen, müsste ja dann was mit bios version und einstellungen sein

 

einen alterantive pcie auf sata chipsatz nutzen?

 

jmb582 basierte karte

https://www.amazon.de/KALEA-INFORMATIQUE-Controller-Express-Chipsatz-Slotblende/dp/B078871BY7/

 

oder

ams1061 basiert

https://www.amazon.de/dp/B07GKX5BS4/

 

alternativ geht so ziemlich jede größere karte wie jmb585 basiert und die dann über einen adapter pcie 1x stecker -> flachbandkabel -> pcie 16x/8x/4x/1xbuchse

https://www.amazon.de/Express-Adapter-Extender-Flexible-Extension/

https://www.amazon.de/KALEA-INFORMATIQUE-Flexible-Premium-Abgeschirmte-Twinax-Technologie-Magnetschild/

aber es geht auch ein adapter mit 1x slot wenn der hinten offen ist so das größere karten mechanisch passen

https://www.amazon.de/Cikuso-Steckplatz-Converter-Verl%EF%BC%9FNgerungskabel-BTC-Bergbau-Schwarz/dp/B07V9KS5W1

selbst eine lsi sas pcie 8x karte würde so laufen - natürlich nur mit einer pcie 2.0 lane, also 500MB/s

 

 

ich babe zumindest schon mal von 1-2 fällen hier gelesen wo so eine marvell 9215 kare nicht richtig erkannt wurde aber normalerweise gehen die eigentlich

 

Link to post
Share on other sites

Im gleichen Board leider nicht. Das J4105-ITX hatte zwar einen PCIe Slot übrig, der war aber frei.

 

Sollte mal einer der Karten rein, aber das Board machte vorher die Schlapp.

 

2 Karten waren noch gar nicht im Einsatz bei mir. 2 Stück gekauft. Eine als "falls die andere nicht klappt".

Laut einer Amazon-Rezession ist die eine im Xpenology im Einsatz. Das machte Hoffnung.

 

Umso mehr freute ich mich über das J4105M Board. Noch mal 8 SATA Ports mehr durch die insgesamt 3 PCIe Slots. PUSTEKUCHEN.

 

Probiere gerade mit 1.04b 6.2.2 und deiner 0.8 extra syno und std. NIX. Nicht mal Syno oder Web Assist findet das unfertige NAS. Merkwürdig.

 

Danke für deine Hilfe

Link to post
Share on other sites
1 hour ago, apejovic said:

Probiere gerade mit 1.04b 6.2.2 und deiner 0.8 extra syno und std. NIX.

da deine problem beim ahci liegen wird das nichts bringen das ist fest in den kernel eincompiliert (hat also nichts mit den extra treiber zu tun) und synology verwendet immer den gleichen kernel innerhalb der main line (6.2) da wird sich also nichts ändern mit 6.2.2

wenn kannst du 3615/17 von 6.2 versuchen die haben einen wesentlich älteren kernel als 918+

 

"empfohlen" habe ich nichts, nur aufgezeigt das es andere boars mit apollo-/geminilake gibt die mehr features haben (wenn es nicht mini-itx sein muss)

ich verwende B360/B365 chipsätze auf micro-atx (mit geringer tiefe), da hat man deutlich mehr otpionen (pcie lanes und pcie 3.0, 6 x sata onboard)

ich habe zumindest auch eine marvell 9215 karte in meinem hauptsystem an der eine platte hängt (6+5+4 ports)

hab mal nachgeschaut, ist eine Syba SI-PEX40064, also genau das was du da auch hast, was dann wohl auf das board als problem ursache hindeutet

ich hatte hier auch schon einen marvell 9125 karte mit 2 ports (pce2sat-m01), die wurde in fast keinem system erkannt, und ist dann im müll gelandet

wenn du noch was probieren willst dann versuch wie oben beschrieben etwas mit einem anderen chip

 

Link to post
Share on other sites

Wenn die Karte(n) bzw. die Platten daran schon im BIOS nicht erkannt und gezeigt werden, dann brauchen wir doch über das OS gar nicht reden.
Oder sehe ich das komplett falsch?
Ob der Zugriff dann das AHCI Protokoll benutzt oder nicht, die Frage stellt sich erst danach.

Edited by Chili
Link to post
Share on other sites

Hi,

 

18 hours ago, IG-88 said:

"empfohlen" habe ich nichts, nur aufgezeigt das es andere boars mit apollo-/geminilake gibt die mehr features haben

Habe es auch so verstanden, alles gut.

 

bin jetzt erst mal wieder 2 Wochen nicht zu Hause. So lange muß das ganze warten bis ich wieder damit spielen kann.

Link to post
Share on other sites

Naja, ich weiß zwar nicht mehr genau welche Komponenten das waren, aber früher (Win95/ME) hat man ein paar Sachen nur im OS gesehen. Das BIOS hatte nichts angezeigt. Wie das heute ist kan ich gar nicht sagen.

 

Ist halt blöd, wenn man sich extra ein vermeintlich "gutes" board besorgt und es einem nichts bringt. Hätte nicht gedacht, daß generell ein Unterschied zwischen dem J4105-ITX und dem J4105M besteht, also im Bezug auf 918+ oder 3617 System.

 

Na ja,....notfalls verkaufen mit Garantie. Mein Arbeitsspeicher (1x16GB, erkannt vom Bios/keine Probleme mit DSM) vom J4105-ITX passt auch nicht im J4105M.

Der neu bestellte RAM musste auch bereits getauscht werden, weil das Board dann gar nicht gestartet hat.

Link to post
Share on other sites
  • 2 weeks later...

Habe jetzt eine 6-fach SATA Karte mit ASM1166 ausprobiert.

 

Nichts. (als 918 mit 1.04)

 

Die Angeschlossenen HDDs werden nicht erkannt.

 

Habe im Moment keine Idee mehr.

 

@IG-88
sind in deinen Extra Paketen noch andere ASM Treiber enthalten?

 

CSM/Legacy kann ich leider nicht nutzen.

 

 

Link to post
Share on other sites
50 minutes ago, apejovic said:

sind in deinen Extra Paketen noch andere ASM Treiber enthalten?

kein extra treiber, die karte ist ahci (wie die onboard sata anschlüsse) und ahci ist fest im dsm kernel drin

die einzige besonderheit der asm1166 karte die ich zum testen gekauft hatte war das sie hinten den 4 bz.w 6 onboard sata's 32 anschlüsse für dsm hatte von denen nur 6 wirklich da waren aber so lange man da nichts dahinter (6+6) haben will ist das erstmal kein problem, im live system habe ich eine jmb585 karte ("nur" 5 sata ports) und eine 2 oder 4 port marvell karte (von der ich nur einen port nutze)

aber das die asm1166 mit dsm keine zusätzliche platte anzeigt ist eigenartig

kannst du mir mal die /var/log/dmesg schicke?

wenn die karte funktioniert sollte man zumindest im log was von der platte sehen, auch wenn dsm sie aus irgendwelchen grüden nicht anzeigt (z.b. wenn sie sdq oder höher wäre (>16 disks würde 918+ nicht in der gui anzeigen)

 

du kannst auch mal testweise ein live linux strten uns sehen wie das die disk erkennt (sdX)

Edited by IG-88
Link to post
Share on other sites
On 12/23/2020 at 12:39 AM, IG-88 said:

kannst du mir mal die /var/log/dmesg schicke?

Kannst Du mir das erklären, wie das gemacht werden muss? Danke

 

Habe testweise den 1.02 genommen mit einem 3615xs .pat file und noch im BIOS rum gespielt.

 

Kannst Du mir erklären was bei ASPM die jeweiligen Einstellungen bedeuten?

Die Namen sollten ungefähr so sein (schon spät, schaue gerne morgen erneut nach)

 

- L1

- LOsL1

- Auto

- LOs

 

Auf L1 scheinen die Karten dann zu funktionieren (Vermutung) bei den anderen Einstellungen passierte nichts.

 

Alle 3 Karten werden erkannt.

On 12/7/2020 at 8:54 PM, apejovic said:

Rivo Karte PCIe 3.0 X1 Marvell 88SE9215

Syba SI-PEX40064 PCIe 2.0 X1 Marvell 88SE9215

6fach SATA mit ASM1166

 

 

Habe dann das 1.04 mit 918 .pat file ausprobiert. Funktioniert auch alles.

 

Allerdings eröffnet sich ein anderes Problem bzw. die Hauptursache für das Problem.

 

Ich habe das J4105M in einem Chenbro SR112 Gehäuse eingebaut. Die HDD's laufen im Backplane zwar hoch werden aber nicht an den SATA-Daten-Anschlüssen erkannt, weder an einem der 3 Sata Karten noch an den Mainboard.

 

Das Backplane ist die Version von Mini-SAS auf SATA (Chenbro 4Port Mini-SAS Backplane 80H10211203A0).

Gibt es da noch irgendeinen Jumper oder ähnliches zu "stellen" damit die SATA-Daten-Anschlüsse funktionieren?

 

Die Lüfter, die am HDD-Backplane angeschlossen werden können sind nicht vorhanden. (hier das Problem?)

Die SATA Karten verfügen nicht über Anschlüsse für die 8-Pin HDD-LED's Stecker (sollte egal sein, denke ich)

 

Immerhin schon mal einen Schritt näher.

 

Vielen Dank erneut für Deine Hilfe.

 

Gute Nacht

Edited by apejovic
Link to post
Share on other sites
30 minutes ago, apejovic said:

Kannst Du mir das erklären, wie das gemacht werden muss?

mehrere möglichkeiten

- die datei /var/log/dmesg auf einen share kopieren den man von windows erreichen kann

- mit putty zu dsm und den befehel "dmesg" aufrufen, dann scrolled die datei durch und du kannst in der console alles markieren und über die zwischenablage ein eine neue dtei kopieren

- in putty die log funktion aktivieren und dann wie vorher dmesg aufrufen, danach kann man im logfile den kram rauskopieren

 

die neue datein mit zip packen um sie an eine nachricht hier im forum zu hängen

 

46 minutes ago, apejovic said:

ch habe das J4105M in einem Chenbro SR112 Gehäuse eingebaut. Die HDD's laufen im Backplane zwar hoch werden aber nicht an den SATA-Daten-Anschlüssen erkannt, weder an einem der 3 Sata Karten noch an den Mainboard.

 

Das Backplane ist die Version von Mini-SAS auf SATA (Chenbro 4Port Mini-SAS Backplane 80H10211203A0).

 

wenn du mini-sas auf der backplane hast und auf sata "zurück" verbinden willst ist wohl ein anderes kabel fällig als wenn man vom sas controller auf sata geht

das wird vermutlich das kabel sein das du brauchst

https://www.delock.de/produkte/G_83318/merkmale.html?setLanguage=de

 

 

46 minutes ago, apejovic said:

Kannst Du mir erklären was bei ASPM die jeweiligen Einstellungen bedeuten?

Die Namen sollten ungefähr so sein (schon spät, schaue gerne morgen erneut nach)

 

- L1

- LOsL1

- Auto

- LOs

 

https://en.wikipedia.org/wiki/Active_State_Power_Management

 

kann mich aber nicht erinneren sowas mal im bios selbst eingestellt zu haben

 

 

49 minutes ago, apejovic said:

Die Lüfter, die am HDD-Backplane angeschlossen werden können sind nicht vorhanden. (hier das Problem?)

 

müsste eigentlich in der duku der backplane stahen aber damit das irgendiwe gesteuert werden kann müsste es einen controlelr geben und eine connection zu mainboard, ich würde aber erwarten das dies optinal ist und ohne die lüfter geht

 

 

49 minutes ago, apejovic said:

Die SATA Karten verfügen nicht über Anschlüsse für die 8-Pin HDD-LED's Stecker (sollte egal sein, denke ich)

 

auch das sollte optinal sein, sata an sich kennt keine led anschlüsse

 

habe aber kene erfahrung mit diesen selbsbau backplanes, zu hause nutze ich das nicht und auf arbeit haben wir "fertige" server (hpe und konsorten), das letzte mal das ich sowas auf dem tisch hatte ist >10 jahre her

 

 

 

 

 

Link to post
Share on other sites

Guten Morgen,

 

6 hours ago, IG-88 said:

mehrere möglichkeiten

- die datei /var/log/dmesg auf einen share kopieren den man von windows erreichen kann

- mit putty zu dsm und den befehel "dmesg" aufrufen, dann scrolled die datei durch und du kannst in der console alles markieren und über die zwischenablage ein eine neue dtei kopieren

- in putty die log funktion aktivieren und dann wie vorher dmesg aufrufen, danach kann man im logfile den kram rauskopieren

 

die neue datein mit zip packen um sie an eine nachricht hier im forum zu hängen

 

Danke, das werde ich bei Gelegenheit mal testen.

 

6 hours ago, IG-88 said:

wenn du mini-sas auf der backplane hast und auf sata "zurück" verbinden willst ist wohl ein anderes kabel fällig als wenn man vom sas controller auf sata geht

das wird vermutlich das kabel sein das du brauchst

https://www.delock.de/produkte/G_83318/merkmale.html?setLanguage=de

Davon habe ich 2 Kabel. Die sind angeschlossen.

 

6 hours ago, IG-88 said:

habe aber kene erfahrung mit diesen selbsbau backplanes

"Selbstbau"-Backplanes:?:  Sind original von Chenbro.

 

 

 

Anbei die Doku. Vielleicht fällt Dir etwas auf.

 

Danke

Manual_6Gbps 4-port 3.5 mini-SAS backplane(80H10220918A0)_V1.0.pdf

Link to post
Share on other sites
12 hours ago, apejovic said:

"Selbstbau"-Backplanes:?:  Sind original von Chenbro.

ich bezog das eher auf selbstbau server, im heim bereich setzt ich eher auf günstige leise desktop hardware ohne backplanes und im job wird nicht mehr gebastelt, das sind es eher hpe server mit 5 jahre carepack, gibt da genug andere sachen, da ist keine zeit mehr für schrauben und rumprobieren

 

Link to post
Share on other sites

Ach so,.....😄

 

Ja, die Bequemlichkeit wie mit einem N54L sucht seines gleichen.

 

Vielleicht wird der nächste Server wieder ein "Fertig"-Gerät von HP. Mal schauen was die Preise so machen und wie weit das Projekt jetzt geht und vor allem ob meine Ansprüche sich ändern.

 

Ich denke es wird erst einmal eine Pause kommen, wie damals von DSM 4 > DSM 5. Abwarten.

Link to post
Share on other sites
8 hours ago, apejovic said:

Ja, die Bequemlichkeit wie mit einem N54L sucht seines gleichen.

der gen10 (plus) microserver ist auf den ersteb blick interessant aber zu teuer wenn man es mit den vorherigen modellen wie gen7/gen8 vergleicht (vor allem wenn man iLO mit dabei haben will)

außerdem ist durch das bios der weg zur intel gpu verschlossen, sebst wenn die cpu eine gpu hat kommt man nicht dran und muss auf hardware transcoding verzichten

und das unnötigerweise nur ein pcie slot vorhanden ist ..., den iLO hätte man besser onboard verbaut und einen 2. pcie slot gelassen

in summe kommt da eher ein no go raus

hätten die beim schrumpfen für das plus modell 6 disk slots draus gemacht, 2 x pcie und iLO onboard wäre der extrem interessant (and vieleicht 1-2x 10G statt 4x1G ?)

dafür würde man eher >500€ einwerfen und die bittere pille mit der gpu schlucken

 

9 hours ago, apejovic said:

Ich denke es wird erst einmal eine Pause kommen, wie damals von DSM 4 > DSM 5. Abwarten.

wenn es zeitnah einen loader gibt ist das nicht unbedingt so (nic treiber kann man vermutlich auch aus einem kernel von kernel.org erzeugen wenn es von synology keinen source gibt) aber die inkompatibilität bei den spk's kann für einige ein showstopper sein

im grunde haben wir schon recht lange eine pause, der 6.2 loader kom vor >2 jahren raus

Link to post
Share on other sites

Frohes Neues Jahr erst mal.

 

Meine "Reverse" Kabel sind gestern morgen noch angekommen.

 

Die Backplanes funktionieren jetzt (Nur schnell getestet).

 

Die nächsten Tage wird dann alles neu eingerichtet.

 

Muss jetzt nur überlegen, wie ich die Verteilung der SATA Anschlüsse machen soll.

 

8-Bays im Gehäuse

 

2 SATA auf dem Mainboard

2 PCIe Karten mit je 4 SATA

1 PCIe Karte mit 6 SATA

 

Tipps sind herzlich willkommen, wie immer.

On 12/30/2020 at 7:33 PM, IG-88 said:

im grunde haben wir schon recht lange eine pause, der 6.2 loader kom vor >2 jahren raus

Schon wieder so lange her? Wie Die Zeit vergeht.

 

Ich hoffe,daß Ich lange bei dem Gehäuse bleibe, dann brauche ich mir über zukünftige Boards keine Gedanken machen.

 

Link to post
Share on other sites
5 minutes ago, apejovic said:

2 SATA auf dem Mainboard

2 PCIe Karten mit je 4 SATA

1 PCIe Karte mit 6 SATA

 

kannst du mir mal ein dmesg davon schicken, würde mich mal interessieren bei dir auch 32 hdaX devices vom asm1166 produziert werden (so lange die karte "hinten" ist macht das nichts aber wenn sie zwischen drin sitzt und 32 statt 6 hadX belegt rutschen die anderen sogar hinter die 24er grenze und dann hilft vermutlich nicht mal manuelles anpassen der synoinfo.conf)

wäre auch gut zu wissen welche karte mit asm1166 du genau hast, auf der plaine meienr karte gibts zumindest etwas (die karte gibts von verschiedenen chinesischen vertreibern, meist sind es nur 2-3 wirklich verschiedene karte die verkauft werden)

PCE6SAT-A01

VER006S

 

außerdem frage ich mich grade wir du drei pcie karten in das Asrock J4105M bekommst das ja nur 2 pcie slots hat, hast du den M.2 key E mit einem adapter zu einem pcie slot gemacht?

Link to post
Share on other sites

Entweder morgen oder vielleicht nachher kann ich gerne ein Bild davon machen.

 

2 hours ago, IG-88 said:

außerdem frage ich mich grade wir du drei pcie karten in das Asrock J4105M bekommst das ja nur 2 pcie slots hat, hast du den M.2 key E mit einem adapter zu einem pcie slot gemacht?

Also es hat ja 2x 2.0 X 1 und 1x 2.0 X 16.

 

In dem X16 Slot steckt die ASM Karte. In den anderen beiden die anderen halt.

 

Mainboard SATA sind Laufwerk 1 und 2.

Die erste 4-fach Karte wird 3-6

Die ASM 6-fach wird 7-12

Die letzte 4-fach Karte bekommt 39-42 zugeordnet.

 

Ich hatte schon mit einer alten HDD probiert, um zu schauen ob alle SATA-Anschlüsse der Karten funktionieren. Dabei ist mir die Port-Adressierung aufgefallen. DSM hat im Speichermanager immer schön die Zuordnung angezeigt.

 

Ich kann gerne noch etwas testen bevor ich mit der Neueinrichtung starte.

 

Wie gesagt, vielleicht schaffe ich es noch heute. Ansonsten morgen.

Link to post
Share on other sites
5 minutes ago, apejovic said:

Also es hat ja 2x 2.0 X 1 und 1x 2.0 X 16.

na sowas, da hat sich auf dem bild auf der homepage beim hersteller ein slot getarnt :-)

 

8 minutes ago, apejovic said:

Mainboard SATA sind Laufwerk 1 und 2.

Die erste 4-fach Karte wird 3-6

Die ASM 6-fach wird 7-12

Die letzte 4-fach Karte bekommt 39-42 zugeordnet.

ok ,dann brauche ich kein dmesg, da passiert offensichtlich der gleich murx wie bei mir

 

9 minutes ago, apejovic said:

Ich kann gerne noch etwas testen bevor ich mit der Neueinrichtung starte.

 

wenn die platten auf 39-42 funktionieren und in ein raid eingebunden sind läuft es scheinbar,  da hatte ich angenommen das dsm da schwierigkeiten macht

bei bedarf müsste ich das eigentlich nachbilden können, genug verschiedene controller habe ich ja rumliegen (in kürze auch einen mit jmb582 als pcie 1x karte)

wäre also noch zu sehen was das deine asm1166 karte ist, ein link mit foto wo du sie online estanden hast sollte auch reichen, der aufdruck ist bei mit auf der vorderseite in der nähe des slotblechs neben dem kühlkörper, eigentlich nicht zu übersehen

Link to post
Share on other sites

hier mal die asm1166 die es zu geben scheint

 

1. die karte die ich habe pcie 4x karte (der chip kann aber nur 2 lanes pcie 3.0)

image.png.eb6f4decec74aa8f020e822b82279c1d.png

 

2. die gleiche karte aber als pcie 1x karte (A02 statt A01 im Aufdruck auf der Platine) - ich glaube das wäre im moment die pcie 1x karte mt den meisten ports ohne sata multiplexer

image.png.5d81f92aa3e1d34056ca59e999cc5caa.png

 

3. die "alternative" Karte pcie 4x

image.png.715a3f8b7df4359d12239aa22d5102b8.png

 

 

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.