Sign in to follow this  
red1234

HELP - Cant log in to DSM via browser after upgrade

Recommended Posts

Hi all,

 

Ive recently upgraded the DSM software installed on an N54L via the built in update function within DSM. Since then I have been unable to login via my browser, however all other services (Plex, Sab, Sonarr, etc) seem to be working fine. I also setup Cloud Station around the same time and cant be sure which caused this problem. I also cant login remotely via DS File app. Rebooting doesnt help.

 

I have tried to restart apache with the the following ssh command:

 

/usr/syno/etc/rc.d/S97apache-user.sh restart

and

/usr/syno/etc.defaults/rc.d/S97apache-user.sh restart

 

but receive a "no such file or directory" error. When looking at the /etc/ and /etc.defaults folder via winscp, I can not find the S97apache-user script anywhere.

 

Ive also tried to update to the latest DSM version as per the Xpenology DSM software page manually via ssh ("synoupdate" command). It installed fine and rebooted but still no dice.

 

I'd like to try to figure out a solution without reinstalling DSM and rebuilding the system from scratch. Is there a way to reinstall the apache package somehow?

 

Any help is appreciated.

Share this post


Link to post
Share on other sites

What did you update from, and to?

 

This is the expected symptom if you upgrade from 5.1.x to 5.2 without changing your XPEnoboot image.

Share this post


Link to post
Share on other sites
What did you update from, and to?

 

This is the expected symptom if you upgrade from 5.1.x to 5.2 without changing your XPEnoboot image.

 

I cant remember what I originally updated to but it was the latest version as per official updates pushed to DSM.

 

I then manually updated to DSM 5.2-5565 Update 1 as per the latest update on the Xpenology site.

 

I think a mistake was to not update the boot image as you said. Ill try to follow elmuzikos suggestion to downgrade and redo following correct procedure. Fingers crossed.

 

Cheers for the help guys.

Share this post


Link to post
Share on other sites
Sign in to follow this