• 0

Installing Python 3.7 or better under DSM 6.0.2


Question

Hello,

 

happy owner of a Synology running on AMD for +/- 5 years, I'm stuck with my DSM 6.0.2 and I need to update my Python to 3.7 minimum to use Medusa (a fork of Sickbeard)

 

How to install Python 3.7 under DSM 6.0.2, I found spk on repo but they require mini DSM 6.1...

 

Thanks

Akhlan

Link to post
Share on other sites

5 answers to this question

Recommended Posts

  • 0

in theory you cpu should even work with 918+ loader 1.04b

https://xpenology.com/forum/topic/13333-tutorialreference-6x-loaders-and-platforms/

piledriver seems to be min. for 918+ and your A10 seems to fit that category

but it doesn not has to be 918+, 3615/17 is fine as long as you switch csm on and boot from non uefi boot device

 

your board seems to have 7xsata and that for sure are ahci ports, as you have 8 disks there has to be a extra controller thats not listed in your footnote

i'd suggest migration to the min, dsm version like 6.1

that version (and later versions) has no support for sata_*.ko and pata_*.ko drivers, you can check with lspci -k what drivers are used , if its just ahci then there should be no problem with loader 1.02b and dsm 6.1

 

you can perpare a new usb,m boot from it install to a single empty hdd (disconnect all other drives) if that checks out you can use that usb to boot with your normal drives and then migrate to the new dsm version

when going to 6.1 there is a lower possibility that plugins have problems (and you would stay within the dsm type like 3615)

depending on the outcome you could use the refreshed knowledge to check out dsm 6.2 as this is the recent line that gets updates

 

Link to post
Share on other sites
  • 0

I have make a "lspci -k", but it doesn't help me too much :D

lspci -k

0000:00:00.0 Class 0600: Device 1022:1410

Subsystem: Device 1849:1410

0000:00:01.0 Class 0300: Device 1002:990c

Subsystem: Device 1849:9901

0000:00:01.1 Class 0403: Device 1002:9902

Subsystem: Device 1849:9902

0000:00:10.0 Class 0c03: Device 1022:7812 (rev 03)

Subsystem: Device 1022:7812

Kernel driver in use: xhci_hcd

0000:00:10.1 Class 0c03: Device 1022:7812 (rev 03)

Subsystem: Device 1022:7812

Kernel driver in use: xhci_hcd

0000:00:11.0 Class 0106: Device 1022:7801 (rev 40)

Subsystem: Device 1849:7801

Kernel driver in use: ahci

0000:00:12.0 Class 0c03: Device 1022:7807 (rev 11)

Subsystem: Device 1849:7807

0000:00:12.2 Class 0c03: Device 1022:7808 (rev 11)

Subsystem: Device 1849:7808

Kernel driver in use: ehci-pci

0000:00:13.0 Class 0c03: Device 1022:7807 (rev 11)

Subsystem: Device 1849:7807

0000:00:13.2 Class 0c03: Device 1022:7808 (rev 11)

Subsystem: Device 1849:7808

Kernel driver in use: ehci-pci

0000:00:14.0 Class 0c05: Device 1022:780b (rev 14)

Subsystem: Device 1849:780b

0000:00:14.2 Class 0403: Device 1022:780d (rev 01)

Subsystem: Device 1849:8892

0000:00:14.3 Class 0601: Device 1022:780e (rev 11)

Subsystem: Device 1849:780e

0000:00:14.4 Class 0604: Device 1022:780f (rev 40)

0000:00:14.5 Class 0c03: Device 1022:7809 (rev 11)

Subsystem: Device 1849:7809

0000:00:15.0 Class 0604: Device 1022:43a0

Kernel driver in use: pcieport

0000:00:18.0 Class 0600: Device 1022:1400

0000:00:18.1 Class 0600: Device 1022:1401

0000:00:18.2 Class 0600: Device 1022:1402

0000:00:18.3 Class 0600: Device 1022:1403

0000:00:18.4 Class 0600: Device 1022:1404

0000:00:18.5 Class 0600: Device 1022:1405

0000:02:00.0 Class 0200: Device 10ec:8168 (rev 06)

Subsystem: Device 1849:8168

Kernel driver in use: r8168

0001:07:00.0 Class 0000: Device 1b4b:9235 (rev ff)

0001:08:00.0 Class 0000: Device 1b4b:9235 (rev ff)

0001:09:00.0 Class 0000: Device 1b4b:9235 (rev ff)

0001:0a:00.0 Class 0000: Device 1b4b:9235 (rev ff)

 

I could update to 918+ loader 1.02b or 1.04b to launch dsm 6.1 ?

 

Rgds

 

Link to post
Share on other sites
  • 0
1 hour ago, Akhlan said:

I have make a "lspci -k", but it doesn't help me too much

not sata_* or pata_* driver in use, all ahci so there should be no problem with storage drivers in 6.1/6.2

network drivers are usually no problem

 

1 hour ago, Akhlan said:

I could update to 918+ loader 1.02b or 1.04b to launch dsm 6.1 ?

there  is no 6.1 918+ loader

1.03b/1.04b are 6.2 loaders, 1.02b are 6.1 loaders

20 hours ago, IG-88 said:

in theory you cpu should even work with 918+ loader 1.04b

https://xpenology.com/forum/topic/13333-tutorialreference-6x-loaders-and-platforms/

you should really read whats in that link, it lists laoders and dsm versions

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.