nick w

HP Gen7 n54L - Anyone successful in updating to 5.2?

Recommended Posts

Has anyone successfully updated to 5.2 on an HP Gen7 Micro Server

 

The process -

Write Image to new USB

Power Down Server

Take out old usb and insert new one

Power On

Select Update/install/downgrade

wait for it to boot

synology assistant - connect to server

Migrate

= Done

 

DSM 5.2-5565 PAT download c50385e13495fef366fbd590bbe376fb

I wont go to update 1 just yet

Is that correct?

 

Thanks

N

Share this post


Link to post
Share on other sites

HackerJac,

Did you update to Update1 on 5.2?

There are 2 options for me to update

 

DSM 5.2-5565

or

DSM 5.2-5565 update 1

 

Im not sure which is safer

 

Thanks

N

Share this post


Link to post
Share on other sites

i did DSM 5.2-5565 first, them downloaded the update 1 and made a manuel install within dsm 5.2

had to hard reboot the server after the u1 install to get it working

Share this post


Link to post
Share on other sites
i did DSM 5.2-5565 first, them downloaded the update 1 and made a manuel install within dsm 5.2

had to hard reboot the server after the u1 install to get it working

Same here.

Share this post


Link to post
Share on other sites

The process I used to update my G7 N54L Server (going from 5.1-5055 Update 5 to 5.2-5565 Update 1)

 

Power Down Server

Take out usb boot drive and update with latest boot image / re-insert usb drive

Power On

Select XPEnology DSM 5.2-5565 top boot option NOT debug or install/upgrade option

wait for it to boot

log in via web browser

Download DSM 5.2-5565.pat from http://www.xpenology.nl/xpenology-software/

update and let it reboot

log back in via web browser

go to control panel - update and restore, check for updates, let it download and install update 1

wait for it to reboot

Done

Share this post


Link to post
Share on other sites

Yea, that's what I did,.... now mine is inaccessible... and won't show up in Synology Assistant... not sure how I'm going to resolve.

 

Always make sure you back up your data!

Share this post


Link to post
Share on other sites

have you tried this

 

For those who made th Update to 5.2-5565 Update 1 and can't access the dsm:

 

1. First to get access

 

crowpet wrote:Think i got it on my n54l with Monitor and keyboard localy atached!

 

1. Login as root

2. type su

3. ifconfig eth0

- I only had a ip v6 adress -> so no connection

4. type ifconfig eth0 #IPofNAS# netmask 255.255.255.0 up -> now you can connect via browser on the given ip

5. Login in DSM in Browser

6. Goto "Controlcenter" -> "Network"

- Check the settings on your NIC "LAN1" and tourn off ipv6

- I have set the ip to static

 

Don't reboot!!!

 

 

 

2. Now you can Trry to downgrade (migration install) - to keep your app's and configs

 

- Ive done the steps here "http://xpenology.me/how-to-downgrade-from-dsm-5-2/" but ive installed the "DSM 5.2-5565" from here "http://xpenology.me/downloads/"

 

- After the migration install iam up an running and everthing seems fin now :smile:

 

Dont update again or the dsm will got the same errors!!!!

 

 

Hope this is a help

 

3. Think about a clean install / test system

Share this post


Link to post
Share on other sites

Yes, first thing I tried. System is still not accessible after having entered those at the CLI

Share this post


Link to post
Share on other sites
The process I used to update my G7 N54L Server (going from 5.1-5055 Update 5 to 5.2-5565 Update 1)

 

Power Down Server

Take out usb boot drive and update with latest boot image / re-insert usb drive

Power On

Select XPEnology DSM 5.2-5565 top boot option NOT debug or install/upgrade option

wait for it to boot

log in via web browser

Download DSM 5.2-5565.pat from http://www.xpenology.nl/xpenology-software/

update and let it reboot

log back in via web browser

go to control panel - update and restore, check for updates, let it download and install update 1

wait for it to reboot

Done

So why not upgrade? Thats what I normally do during upgrades. If I don't select update do i lose my apps?

Thanks. N

Share this post


Link to post
Share on other sites
have you tried this

 

For those who made th Update to 5.2-5565 Update 1 and can't access the dsm:

 

1. First to get access

 

crowpet wrote:Think i got it on my n54l with Monitor and keyboard localy atached!

 

1. Login as root

2. type su

3. ifconfig eth0

- I only had a ip v6 adress -> so no connection

4. type ifconfig eth0 #IPofNAS# netmask 255.255.255.0 up -> now you can connect via browser on the given ip

5. Login in DSM in Browser

6. Goto "Controlcenter" -> "Network"

- Check the settings on your NIC "LAN1" and tourn off ipv6

- I have set the ip to static

 

Don't reboot!!!

 

 

 

2. Now you can Trry to downgrade (migration install) - to keep your app's and configs

 

- Ive done the steps here "http://xpenology.me/how-to-downgrade-from-dsm-5-2/" but ive installed the "DSM 5.2-5565" from here "http://xpenology.me/downloads/"

 

- After the migration install iam up an running and everthing seems fin now :smile:

 

Dont update again or the dsm will got the same errors!!!!

 

 

Hope this is a help

 

3. Think about a clean install / test system

Would you suggest not going to update 1?

 

Shall I avoid it now when i got to 5.2

 

Thanks. N

Share this post


Link to post
Share on other sites

Ok, so update...

After several reboots and attempts at different fixes, I was able to use the "ifconfig eth0 netmask up" command, along with setting the Version# back, along with Install/Upgrade boot... finally Synology Assistant sees the nas, and attempts to write 5.2.5665 to it... even so it Still doesn't come up with an IP by itself, so once again I manually set it using the ifconfig command... and Im now finally able to log into the DSM.

 

Now, Im looking at doing a Clean Install to fix this mess... I thought I read someone mentioning an ability to perform a clean install while maintaining the Data on the drives, but I can't find that information now. I'm cleaning out my data to prepare for a full backup if Im told that a clean backup is Going to be destructive.... but let me know if Im wrong.

 

Thanks for the help and suggestions ya'll (especially hackerjac and crowpet)

Share this post


Link to post
Share on other sites

Warning!

downgrade from 5.2-5565 to 5.1< without lost data, possible via Nanoboot install/upgrade

After install/upgrade Nanoboot turn off NAS, flash Xpenoboot 5.1 and make migration

Share this post


Link to post
Share on other sites

There must be one bug with out HP machines

i can ping my server but webservices are offline

 

only this helps:

. Login as root

2. type su

3. ifconfig eth0

4. type ifconfig eth0 #IPofNAS# netmask 255.255.255.0 up -> now you can connect via browser on the given ip

5. Login in DSM in Browser

 

then the Webinterface is reachable,

and shows a error "Dienst [Web Station service] konnte nicht gestartet werden. Bitte kontaktieren Sie den Synology Kundendienst, um Unterstützung zu erhalten."

 

whats wrong with our machines?

Share this post


Link to post
Share on other sites
Has anyone successfully updated to 5.2 on an HP Gen7 Micro Server

 

Yes, I updated my N54L (with modified bios) to 5.2-5565 Update 1 without any problems.

Share this post


Link to post
Share on other sites

Are all apps in example Audio Statio, Video Station working correctly?

Bacuse on mine HP N40L XPeno, all apps are disabled and I can't start them.

 

 

EDIT: Resource monitor doesn't work anymore. :sad:

Share this post


Link to post
Share on other sites
Are all apps in example Audio Statio, Video Station working correctly?

Bacuse on mine HP N40L XPeno, all apps are disabled and I can't start them.

 

 

EDIT: Resource monitor doesn't work anymore. :sad:

 

For previous updates I needed to reboot 2-3 times before all things were back to normal. The disabled apps was one of the things that was resolved in this way.

 

Hope it helps.

Share this post


Link to post
Share on other sites

I solved mine "no-eth-connection problem" only by following these steps:

1. Login as root

2. type su

3. ifconfig eth0

4. type ifconfig eth0 IPofNAS netmask 255.255.255.0 up -> now you can connect via browser on the given ip

5. Login in DSM in Browser

Share this post


Link to post
Share on other sites

i have the same problem of pm1982.

n40L no detect with Synology assistant, video sation, audiosatiton, ressource monitor, and few apps dosent work !

Share this post


Link to post
Share on other sites

We need a solution that works even after rebooting.

Ipconfig Command works only until reboot.

Share this post


Link to post
Share on other sites

Indeed, Each to restart the same problem .

With the new version 5.2 to 5565.2 IT does not correct the problem ?

Share this post


Link to post
Share on other sites

My n54l updated without any issues to 5.2

 

Sent from my Nexus 6 using Tapatalk

Share this post


Link to post
Share on other sites
I solved mine "no-eth-connection problem" only by following these steps:

1. Login as root

2. type su

3. ifconfig eth0

4. type ifconfig eth0 IPofNAS netmask 255.255.255.0 up -> now you can connect via browser on the given ip

5. Login in DSM in Browser

 

 

Yes this works, but not after a reboot (for me anyway)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now