Festplatten stürzen gelegentlich ab - performance gefühlt schlecht


Recommended Posts

Hallo,

mir sind jetzt mehrfach Festplatten abgestürzt , woran kann das liegen ?

die platten werden als "normal" angezeigt und SMART sieht für mich auch unauffällig aus.

nach reboot des DSM kann ich die platten wieder hinzufügen und den Speicherpool reparieren.

 

 

DSM: 6.2.2U4

ESXi 6.0

LSI 9217 als passthrouh mit 8 festplatten in ICY BOX, IB-2281MSK (Backplane für 8x 2,5" HDD/SSD)

1 pool mit raid6

 

zur anderen: die performance ist insgesamt recht wechselhaft.

oft geht das volume auf 100% last obwohl die einzelnen platten geringe last haben.

ich bin mir nicht sicher ob ein hardware Raid das nicht doch besser könnte.

Link to post
Share on other sites

Da Fallen mir zwei mögliche Ursachen ein: Unterversorgung der Platten mit Strom oder defekte Kabel

 

Im Storage Manager im Bereich HDD/SSD, lohnt es sich bei jeder Platte mal "Health Info" anzusehen und dort den "Drive Reconnection Count". Sobald da bei auch nur einem Laufwerk die Zahl  > 0 ist (und sich evtl. auch noch weiter erhöht) würde ich dringend die Verkabelung wechseln und/oder ein größerees Netzteil einbauen. Achte darauf das die Sata-Stromkabel von unterschiedlichen "Hauptsträngen" vom Netzteil abgehen. Minderwertige Verlängerungskabel können zu Problemen führen. Defekte MiniSAS Kabel können hier ebenfalls ihren Anteil tun.

 

Ich hab bei mir zwichen 400-500mb/s Transferrate zwischen zwei SHR1 Volumes an einem LSI-9211 mit Direct-IO auf ESXi6.7

Edited by haydibe
  • Thanks 1
Link to post
Share on other sites

generell lohnt auch ein blick in die logs um zu sehen was dort an meldugen steht

wenn es schon mehrfach vor kam dann lohnt auch eine statistische betrachtung

die strom und sas versorgung ist in 2 x 4 geteilt, wenn das problem immer auf einer 4er seite ist dann sind es ziemlich sicher kabel probleme, wenn es sich verteilt dann kann man aber leider nicht viel sagen, es könnte dann auch noch an den kabeln liegen oder am netzteil (selbst unverträglichkeiten platte/controller sind nicht auszuschließen)

ganz allgemein ziehen 2.5" platten nicht so viel strom aber es kann trotzdem am netzteil liegen

das log könnte auch aufschluss geben ob die platten im laufenden betrieb ausfallen oder evtl. nur beim hochfahren probleme machen

 

auf grund von alten threads würde ich 1.04b 918+ vermuten und da drängt sich auch das disk hibernation problem auf das erst bei 6.2.3 aufgefallen ist aber schon immer existiert, also nachsehen ob die aktiv ist und abschalten, evtl. auf neue extra.lzma mit 6.2.3 umstellen (keine temp und smart infos) oder auf 3617 wechseln

https://xpenology.com/forum/topic/28321-driver-extension-jun-103b104b-for-dsm623-for-918-3615xs-3617xs/

 

erste priotität (nach disk hibernation abstellen) sollte aber ein backup haben, wenn man hier weiter rumspielt können auch schnell mal mehr als 2 platten aus dem raid fallen

Edited by IG-88
  • Thanks 1
Link to post
Share on other sites
On 11/21/2020 at 11:57 AM, IG-88 said:

 (nach disk hibernation abstellen)....

Das war mein erster Gedanke.
Die Symptome sprechen eine deutliche Sprache. Das Aufwachen der Platten aus dem Ruhezustand dürfte hier das Problem sein.
Ich hatte meinen Dell H310 (auch LSI) genau deswegen verkauft und bin auf die JMB585 umgestiegen.

Link to post
Share on other sites
6 minutes ago, Chili said:

Die Symptome sprechen eine deutliche Sprache. Das Aufwachen der Platten aus dem Ruhezustand dürfte hier das Problem sein.
Ich hatte meinen Dell H310 (auch LSI) genau deswegen verkauft und bin auf die JMB585 umgestiegen.

bei einer (gehackte) appliance wie xpenologie ist es manchmal einfacher die probleme durch angepasste hardware zu umgehen, ist zwar nicht der "viel feind viel ehr" weg aber in sachen zeit versenken der effektivere weg

 

mit 3617 ist lsi sas sicher zu betreiben, mit der 918+ geht das im moment nicht so wirklich, ich rätsel ja immer noch warum das erst so spät aufgefallen ist aber vermutlich haben viele mit lsi eher ältere cpu's und xeon's benutzt und da ist 3615/17 der normale weg, 918+ kommt erst jetzt in den fokus da modernere xeon's auch qsv haben und m.2 nvme ein thema wird (imho eigentlich nur nützlich bei 10G netzwerk)

 

ich habe auch lsi sas rausgeworfen, mit pcie 3.0 und dem jmb585 kommt man bei normalen nas größen ganz gut hin, nur bei vielen ssd's im system muss man nachrechnen aber die kann man in der regel einfach an die internen sata's hängen um die volle leistung zu bekommen

Link to post
Share on other sites

LSI und ruhemodus ist ein guter tip.

kann das ganze evtl mit dem wechsel der plattform zu tun haben ?

wechsel von xeon e3-1225v3 ( HP z230 )  ---> zu xeon e5-2660v2 (HP z420)

 

macht der wechsel von 3615 zu 3617 auf e5-2660v2 sinn ? 

3617 ist ja für xeon v4

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.