Sign in to follow this  
MMD

The "portcfg mod"

Recommended Posts

Hi everyone,

 

Through a search i ended up here because i have a "problem" with a DS414.

It`s a 4 bay NAS and i`m trying to accomplish the "portcfg mod"

 

I have a mobile rack in the 1st bay and 3x HDD in bay 2-4.

The mobile rack contains 2x SSD in a RAID1.

http://www.enermax.com/home.php?fn=eng/product_a1_1_2&lv0=3&lv1=81&no=278

 

I`ve marked bay 1 as internal and bay 2-4 as esata, so far this works ok.

The 3 HDD`s show up as being External Sata Disks and also behave that way.

The problem is that as soon as i add the 3rd HDD, the system doesn`t go to sleep.

With 2 HDD`s it does sleep.

 

When adding the 3rd disk i`m getting these entries every 30 sec`s in scemd.log which i think is the cause for keeping the system awake:

scemd: check_removable_disk.c:440 The machine eSATA ports exceed defined value(MAX_CDISK_SATA)

 

Playing with maxdisks="4" seems to have no effect.

 

Anyone having some idea?

 

Thanks

Share this post


Link to post
Share on other sites

Trying to search with this error always ends up on this forum :smile:

Share this post


Link to post
Share on other sites

Hallo Brantje :smile:

 

Thx for your replay...

 

I`m aware of the topics you mention but maybe i was not clear enough.

 

I did the modding and it`s working as i want it to work except for this "problem".

The problem is that when i add the 3rd HDD in a slot marked as Esata, the DS doesn`t go to sleep.

So with 2 HDD`s it sleep`s but not with three.

 

When adding the third i get the mentioned warning, scemd: check_removable_disk.c:440 The machine eSATA ports exceed defined value(MAX_CDISK_SATA)

 

It looks like the maximum Esata ports is coded into firmware/kernel or a file. So flipping bits around in synoinfo.conf won`t help here, because that`s already working :smile:

I did find scemd file last week that throws the Warning but cannot find the file where maximum of 2 Esata is defined (exceed defined value)

If i could find it then it could be a matter of editing value from 2 to 3.

 

If you/someone has a clue where to look

Share this post


Link to post
Share on other sites

Hi everyone,

 

i have a Intel SS4200-E with 4 internal SATA ports, 2 eSATA ports and 4 USB ports. The 4 internal sata-ports show up as disk 1-4, the esata ports show up as 5-6, the USB ports show up as external devices.

 

Now i want the esataports to use as external device and not as internal device.

 

I tried following config:

 

internalportcfg="0xf"

esataportcfg="0x30"

usbportcfg="0xf00000" (standard value)

maxdisks="12" (standard value)

 

But when i try this config the drives attached to the esata ports don't show up in DSM. They don't show up in the device manager nor the external devices. Can you give me a hint what i am doing wrong?

 

Greetings holybabel

Share this post


Link to post
Share on other sites
Hi everyone,

 

i have a Intel SS4200-E with 4 internal SATA ports, 2 eSATA ports and 4 USB ports. The 4 internal sata-ports show up as disk 1-4, the esata ports show up as 5-6, the USB ports show up as external devices.

 

Now i want the esataports to use as external device and not as internal device.

 

I tried following config:

 

internalportcfg="0xf"

esataportcfg="0x30"

usbportcfg="0xf00000" (standard value)

maxdisks="12" (standard value)

 

But when i try this config the drives attached to the esata ports don't show up in DSM. They don't show up in the device manager nor the external devices. Can you give me a hint what i am doing wrong?

 

Greetings holybabel

 

You can't just truncate the values like that. You need to leave all the zeros and the exact number of places. You only want to change bits.

 

Stock settings:

esataportcfg="0xff000"
usbportcfg="0xf00000"
internalportcfg="0xfff"

 

you'd want:

esataportcfg="0xff0f0"
usbportcfg="0xf00000"
internalportcfg="0xf0f"

 

Think of it this way, all hardrive types = 0xffffff

each line, usb, internal, sata, takes from that pool.

each value (hex) equal 4 bits = 4 drives.

0xffffff <--- represents 24 disks total, the most right value = drives 1-4, next one, 5-8, ect, ect.

Share this post


Link to post
Share on other sites

Thx, now it works when the disk is attached at startup, no hotplug. Do i have to change something in bios?

Share this post


Link to post
Share on other sites
Thx, now it works when the disk is attached at startup, no hotplug. Do i have to change something in bios?

 

There's nothing to set in DSM - I have similar mod to make one drive as esata, and it works fine hotswapping. Sounds like it's related to your system (motherboard or bios setting, ect).

Share this post


Link to post
Share on other sites
Sign in to follow this