HP Microserver G7 (N36L) will not use 1Gb/s


Recommended Posts

After playing around with iSCSI on an old server I "found" around,

doing a clean install with Jun's 1.03b and DSM 6.2.3-25426 Update 2, I noticed the filetransfers was too slow.

 

And sure enough, the nic was only getting 100Mb/s, and not the 1Gb/s it is supporting.

image.png.7dbf0cdd64f8f9c7fc7ef33cb054e796.png

 

Tried all the "usual stuff", replacing the cable and using a different port on the switch it is connected to,

even swapped both cabel and port with a known working setup. The problem stayed with this N36L,

and the other (N40L) works great at 1Gb/s with the cable and port I started with.

 

Using SSH, I verified that 1Gb/s should be available, but it's not...

 

 

admin@N36L:/$ lspci -k |grep 0200
0000:02:00.0 Class 0200: Device 14e4:165b (rev 10)

 

admin@N36L:/$ ethtool eth0
Settings for eth0:
        Supported ports: [ TP ]
        Supported link modes:   10baseT/Half 10baseT/Full
                                100baseT/Half 100baseT/Full
                                1000baseT/Half 1000baseT/Full
        Supported pause frame use: No
        Supports auto-negotiation: Yes
        Advertised link modes:  10baseT/Half 10baseT/Full
                                100baseT/Half 100baseT/Full
                                1000baseT/Half 1000baseT/Full
        Advertised pause frame use: Symmetric
        Advertised auto-negotiation: Yes
        Link partner advertised link modes:  10baseT/Half 10baseT/Full
                                             100baseT/Half 100baseT/Full
        Link partner advertised pause frame use: Symmetric
        Link partner advertised auto-negotiation: Yes
        Speed: 100Mb/s
        Duplex: Full
        Port: Twisted Pair
        PHYAD: 1
        Transceiver: internal
        Auto-negotiation: on
        MDI-X: off
Cannot get wake-on-lan settings: Operation not permitted
        Current message level: 0x000000ff (255)
                               drv probe link timer ifdown ifup rx_err tx_err
        Link detected: yes

 

Anyone have a tip?

 

Link to post
Share on other sites

I have no idea what I am talking about (and I don't know how the modes are advertised) but I see that it thinks that the switch only does 100baseT

 

Link partner advertised link modes:  10baseT/Half 10baseT/Full
                                             100baseT/Half 100baseT/Full
        Link partner advertised pause frame use: Symmetric
        Link partner advertised auto-negotiation: Yes

  • Like 1
Link to post
Share on other sites
1 hour ago, billat29 said:

I see that it thinks that the switch only does 100baseT

 

You know what, I overlooked that "minor" detail. Thanks :-)

 

I have seen some people trying to force 1G with ethtool, but just like them,

it crashes out my system...and I must do a power off/on.

 

Link to post
Share on other sites

Update: I first verified the problem, booting from a ElementaryOS USB stick, it linked up at 100Mb, but I could "force" it to 1Gb.

Looked in my cabinet, and found a small managed switch, planned to config it to use 1Gb/Fdx/no autonegotiaton.

But as soon as I plugged in the cable, 1Gb link LED was on, and I verified it in DSM controlpanel.

 

So, the other switch (unmanaged Cisco) was not playing ball with my N36L, but both a N40L and a N54L was having no problem with it on any of the ports.

Verified with reflashing the latest original BIOS on the N36L, same problem. Returned it to "Thebay" as my other G7's are running, same results.

 

 

So, what can you expect of a old N36L, with 4GB RAM, running 2 Travelstar Z7K500 in Raid-1, Btrfs ?

This is a constant read/write verification of an iSCSI target, not bad for such old HW?

 

image.thumb.png.d03b339a24b58bb39a75d7864a1358a5.png

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.