Recommended Posts

Hello,

I am trying to connect a UPS to my system via USB.

 

When I boot the DSM and connect the UPS I am able to see it in the control panel. 

I am able to see device properties and everything.

1.png2.png

When I "Enable UPS" and hit "apply" thinks for a while and then I get an error "Cannot connect to the network UPS server"

3.png

After that error the DSM says "Device Information: No UPS connected" even though It is connected.

4.png

When I disconnect and reconnect the UPS I get a notice in the notification center.

5.png

I have attached images of all the different states of the NAS. 

 

Any ideas as to what could be causing this odd behavior? 

 

Edited by Earthian E90
reorder images
Link to post
Share on other sites

Synology uses an open source package called "NUT" to provide this service.  NUT can talk to a UPS directly, provide a TCP/IP socket to bridge UPS services to another device, or consume UPS services from a device that is providing the NUT service.

 

The error you are getting is saying that NUT cannot connect to another NUT instance with a live TCP/IP socket.  That is not what should be happening - you should only be connecting to your USB device via USB.  Be sure you aren't checking any network boxes in your Control Panel to keep this simple.

 

It is also possible that the UPS you are using isn't correctly supported by the NUT version Synology supplies. Is your UPS make and model on the Synology QVL?

Link to post
Share on other sites

Look at the bottom of the screen "No UPS is connected" so it does not recognize your UPS reliably.  I realize in the original post you show at least one screen shot where it is connected, but it is not connected now.

 

It's offering to connect you to a network-based UPS information source, which you do not have.

 

Some UPS's will time out if they are not polled on a fairly frequent basis (and more frequently than the default NUT value).  I run an external NUT in Docker so I have more control over it, and there are options to reduce the polling time which solved a similar problem for my CyberPower UPS.  I would guess you can edit some config files to do the same with Synology, but you'll have to dig into it and see where that might be defined.

  • Like 1
Link to post
Share on other sites
On 11/11/2020 at 5:44 PM, flyride said:

I run an external NUT in Docker

I am having some issues getting this setup. 

 

Do you have any good resources that might help me get this up and running? 

 

I am trying to run the container using instantlinux/nut-upsd:latest.

My logs show 

Quote

 

No matching HID UPS found

Driver failed to start (exit status=1)

 

 

Any chance you encountered such an issue? 

 

Sorry if this is a noob question :P 

 

Link to post
Share on other sites

The two issues I have run into with NUT are 1) mapping the correct PCI port into the ups.conf, and 2) making sure the UPS doesn't timeout (as previously described)

 

I stand corrected; I did run NUT on docker for awhile, but switched to a native Linux VM install in order to get more flexibility on ports.  Here's the ups.conf from my install, and you can see the critical configuration items:

 

[ups]
driver = usbhid-ups
port = /dev/bus/usb/001/003
pollinterval = 12
 

The port mapping will need to be correct for your system (the USB bus and port that the UPS is connected to - this seems well documented in the docker README), and the 12s interval is what worked for my CyberPower.  If the timeouts are a problem, you may need to remove and replug the UPS into the USB port for it to be recognized.  Also you may have to run the docker container as privileged in order to get direct access to the USB port.

 

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.