Die_Quelle

NAS Eigenbau

Recommended Posts

Hallo Zusammen,

 

ich möchte mir selbst ein NAS bauen..

 

Könnt ihr mir bessere Hardware vorschlagen als diese:

 

 

1 x Intel Core i3-4150, 2x 3.50GHz, boxed (BX80646I34150)

1 x Kingston ValueRAM DIMM 4GB, DDR3-1600, CL11 (KVR16N11S8/4)

1 x ASRock B85M-ITX (90-MXGPM0-A0UAYZ)

1 x Fractal Design Node 304 schwarz, Mini-DTX/Mini-ITX (FD-CA-NODE-304-BL)

1 x be quiet! Pure Power L8 300W ATX 2.4 (BN220)

 

Benötige ich AES NI (wird dies unterstützt)?

 

Diese HDDS werde ich verwenden:

 

Western Digital WD Red 3TB, 3.5", SATA 6Gb/s (WD30EFRX)

Share this post


Link to post
Share on other sites

Hallo,

 

Schaut ganz gut aus soweit, brauchst du denn AES, sprich willst du deine Daten verschlüsseln?

Funktionieren sollte es jedenfalls.

Falls du die Daten nicht verschlüsseln willst, ist der Prozessor bisschen fett für ein NAS.

 

Falls du jemals vor hast 6 Platten in das NAS zu bauen (um den Platz im Gehäuse voll auszunutzen) würde sich das Mainboard noch anbieten: http://geizhals.de/gigabyte-ga-h97n-wifi-a1107987.html?hloc=de

Share this post


Link to post
Share on other sites

Eigentlich möchte ich schon verschlüsseln, die Frage ist leider, wie komfortabel ist das mit xpenology.

 

Im besten fall stell ich mir das so vor: ich habe ein Stick verbunden und dieser legitimiert den Festplatten zugriff bzw. entschlüsselung beim boot.

 

Das Mainboard hab ich schon im Blick gehabt, allerdings würde ich kostengünstiger fahren wenn ich dann ein SATA Controller nachträglich einbaue wenn ich die weiteren 2 Platten besitze...

 

Wie verhält sich eigentlich das OS mit Festplatten erweiterung ? sprich von 3 auf 4.

 

Kann ich ein SHR erstellen mit 2 Festplatten daten der 3. drauf kopieren und dan die 3. Festplatte mit ins Raid einbinden? (ohne datenverlust ;D?)

 

Also aktuelle Konfigurationen:

 

A: https://geizhals.de/?cat=WL-547944

B: http://geizhals.de/?cat=WL-548111

 

Als Systemplatte möchte ich eine Crucial 128gb nehmen, die momentan ungenutzt ist.

Share this post


Link to post
Share on other sites

Ich hab als Board das ASRock E3C226D2I, unterstützt 6x Sata3 und ECC RAM und hat IPMI an Board. Spielt allerdings preislich auch in einer etwas anderen Liga. Als Case hab ich das Lian Li PC-Q08B, da hab ich alles inkl. 6HDDs unterbringen können. Ansonsten hab ich ne recht ähnliche Konfig. Die NAS langweilt sich mit den Specs die meiste Zeit ziemlich.

Hab am Wochenende mein Raid 5 von 4 auf 6 Platten erweitert, das ging ganz ohne Probleme, ich vermute, dass es sich mit dem SHR gleich verhält, wobei ich mich da bewusst dagegen entschieden habe.

Share this post


Link to post
Share on other sites

Ich hab gelesen das bei RAID 5 jeder immer dagegen warnt ohne Backup sowas vorzunehmen...nur ich hab mein NAS ja dafür das dort die Daten sind :/ wohin soll ich da sichern?!

 

Ging das ohne Probleme ? - Wielange hast du gebraucht?

 

IPMI und ECC kann ich eigentlich verzichten. ECC wäre eine nette Sache aber, naja....dafür das doppelte ins MB stecken, och nö...

 

Ist das eigentlich Mainboard abhängig ob ECC unterstützt wird oder nur CPU (wenn ja könnte ich ECC Ram doch in Lösung B verwenden oder?)

Share this post


Link to post
Share on other sites

Es ist vom Mainboard UND der CPU abhängig.

Ich hab meine Daten nicht gesichert, weil ich genau den selben Gedanken hatte und es hat völlig problemlos funktioniert. Hat insgesamt ziemlich genau 24h gedauert.

Mein Problem mit SHR (vllt irre ich mich aber auch) ist folgendes. Angenommen ich habe gravierende Probleme mit dem System und will an meine Daten kommen, dann kann ich Platten im Raid 5 Verbund einfach in ein beliebiges Linux System einhängen und die Daten sichern. Bei einem SHR geht das wohl nicht.

Share this post


Link to post
Share on other sites

SHR....ist meines Wissens nach nur ein Raid mit oben drübergelegten LVM...sollte! auch in anderen Systemen wiederherstellbar sein...

Share this post


Link to post
Share on other sites
SHR....ist meines Wissens nach nur ein Raid mit oben drübergelegten LVM...sollte! auch in anderen Systemen wiederherstellbar sein...

richtig.

 

Die SSD würde ich in nen usb 3.0 gehäuse bauen und fürs OS nehmen, benötige ich dann trotzdem einen Stick zum booten?

Share this post


Link to post
Share on other sites
benötige ich dann trotzdem einen Stick zum booten?

ja

 

Die SSD würde ich in nen usb 3.0 gehäuse bauen und fürs OS nehmen

 

falsch

das DSM wird bei der Installation auf alle Festplatten installiert (und zwar als RAID1).

Vorteile:

  • Datenredundanz bzw. Ausfallsicherheit gegenüber einem einzelnen Medium.
  • jede Platte einzeln gebootet werden kann - soweit der RAID Typ des Volumes mit macht

Edited by Guest

Share this post


Link to post
Share on other sites
benötige ich dann trotzdem einen Stick zum booten?

ja

 

Die SSD würde ich in nen usb 3.0 gehäuse bauen und fürs OS nehmen

 

falsch

das DSM wird bei der Installation auf alle Festplatten installiert (und zwar als RAID1).

Vorteile:

  • Datenredundanz bzw. Ausfallsicherheit gegenüber einem einzelnen Medium.
  • jede Platte einzeln gebootet werden kann - soweit der RAID Typ des Volumes mit macht

 

Das weiß ich, allerdings möchte ich nicht das die Platten gelöscht werden...deswegen hänge ich nur die ssd ran und dann hat das os doch keine andere wahl oder :wink:?

Share this post


Link to post
Share on other sites

Bitte Berichte ob der zusatz Sata Controller funktioniert.

Da leider meine Adaptek AAR-1430SA nicht aufXPenoboot funktionieren.

Share this post


Link to post
Share on other sites
Bitte Berichte ob der zusatz Sata Controller funktioniert.

Da leider meine Adaptek AAR-1430SA nicht aufXPenoboot funktionieren.

 

ich hoffe doch, ansonsten geht das MB zurück :/

Share this post


Link to post
Share on other sites
Bitte Berichte ob der zusatz Sata Controller funktioniert.

Da leider meine Adaptek AAR-1430SA nicht aufXPenoboot funktionieren.

Mein Controller funktioniert auf der aktuellen 5.2er

 

 

MUC-NAS> dmesg | grep SATA
[    1.212805] ahci 0000:01:00.0: AHCI 0001.0000 32 slots 4 ports 6 Gbps 0xf impl SATA mode
[    1.231675] ata1: SATA max UDMA/133 abar m2048@0xd0810000 port 0xd0810100 irq 103
[    1.231682] ata2: SATA max UDMA/133 abar m2048@0xd0810000 port 0xd0810180 irq 103
[    1.231686] ata3: SATA max UDMA/133 abar m2048@0xd0810000 port 0xd0810200 irq 103
[    1.231689] ata4: SATA max UDMA/133 abar m2048@0xd0810000 port 0xd0810280 irq 103
[    1.231962] ahci 0000:04:00.0: AHCI 0001.0200 32 slots 2 ports 6 Gbps 0x3 impl SATA mode
[    1.243444] ata5: SATA max UDMA/133 abar m512@0xd0600000 port 0xd0600100 irq 104
[    1.243452] ata6: SATA max UDMA/133 abar m512@0xd0600000 port 0xd0600180 irq 104
[    1.536773] ata1: SATA link down (SStatus 0 SControl 300)
[    1.536814] ata2: SATA link down (SStatus 0 SControl 300)
[    1.536848] ata4: SATA link down (SStatus 0 SControl 300)
[    1.547761] ata5: SATA link down (SStatus 0 SControl 300)
[    1.691753] ata3: SATA link up 6.0 Gbps (SStatus 133 SControl 300)
[    2.155755] ata6: SATA link up 6.0 Gbps (SStatus 133 SControl 300)
[    3.408459] aic94xx: Adaptec aic94xx SAS/SATA driver version 1.0.3 loaded
[    3.481715] LSI 3ware SAS/SATA-RAID Controller device driver for Linux v3.26.02.000.

 

MUC-NAS> lspci
00:00.0 Class 0600: Device 8086:0f00 (rev 0e)
00:02.0 Class 0300: Device 8086:0f31 (rev 0e)
00:14.0 Class 0c03: Device 8086:0f35 (rev 0e)
00:1a.0 Class 1080: Device 8086:0f18 (rev 0e)
00:1b.0 Class 0403: Device 8086:0f04 (rev 0e)
00:1c.0 Class 0604: Device 8086:0f48 (rev 0e)
00:1c.1 Class 0604: Device 8086:0f4a (rev 0e)
00:1c.2 Class 0604: Device 8086:0f4c (rev 0e)
00:1c.3 Class 0604: Device 8086:0f4e (rev 0e)
00:1f.0 Class 0601: Device 8086:0f1c (rev 0e)
00:1f.3 Class 0c05: Device 8086:0f12 (rev 0e)
01:00.0 Class 0106: Device 1b4b:9215 (rev 11)
03:00.0 Class 0200: Device 10ec:8168 (rev 11)
04:00.0 Class 0106: Device 1b21:0612 (rev 02)

 

Amazon Link (Lieferant Okluge) http://www.amazon.de/gp/product/B00R3QY ... ge_o00_s00

Share this post


Link to post
Share on other sites

Hallo

 

Ja und nein habe ein ASUS p5bv-c/4l mit 4 LAN anschlüssen die super gehen.

Auch das Bord von einen Freund ein ASUS P5M2-M mit 2 Lan anschlüssen geht super.

 

Habe aber auf einer anderen testmaschiene mal eine alte INTEL PRO/1000T dazugesteckt und die ging auch obwol Karte eine PCI-X in einen normalen PCI Steckplatz.

 

Bei billigen Netzwerkkarten mit RTL Chip hate ich mal Probleme auf nen Atom system.

 

Habe auf meiner Maschiene 2 lans im Bond als LACP an einen TP-LINK TL-SG2008 (Web Managmant) Switsch am Laufen und die anderen 2 abgeschaltet im BIOS ,

da ich jetzt schon am limit meiner HDD´s bin und nicht das LAN bremst.

Die neuen Bound einstelungen der DSM 5.2 habe ich noch nicht Probiert da ich noch auf 5.1 fahre bis der Spin down der neuen 5.2 gefixt wird.

 

Hoffe es hat Dir ein wennig geholfen.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now