Adding an 2.5/5 gb Net Adapter on Xpenology Nas


Recommended Posts

5 hours ago, Mary Andrea said:

thk so much bearcat , I found some interesting tips there.

as far as i'm aware for usb 3.0/3.1 and 2.5G/5GBase-T its always Aquantia AQtion AQC111U

and if its "only" up to 2.5GBase-T then its Realtek RTL8156

we have drivers for both adapters in the additional extra.lzma already

 

edit: btw, you really expect anyone to just identify a product by the picture? you should write the name of the product to have at least a few people giving you an decent answer (my guess its qnap)

Edited by IG-88
  • Like 1
Link to post
Share on other sites
1 minute ago, IG-88 said:

as far as i'm aware for usb 3.0/3.1 and 2.5G/5GBase-T its always Aquantia AQtion AQC111U

and if its "only" up to 2.5GBase-T then its Realtek RTL8156

we have drivers for both adapters in the additional extra.lzma already

So, IG-88, meaning that I've to edit/upgrade extra.lzma? or are inclouded into my loader/DSM 6.2.x ?

Link to post
Share on other sites
1 minute ago, Mary Andrea said:

So, IG-88, meaning that I've to edit/upgrade extra.lzma? or are inclouded into my loader/DSM 6.2.x ?

yes,  the recent extra.lzma's have the aqc111.ko driver for the Aquantia AQtion AQC111U

after using the extra.lzma and plug in the hardware you could check with lsusb if its detected (bearcats link shows some of that)

  • Thanks 1
Link to post
Share on other sites

Here I found drivers prepared by "bbqq" to instal through Manual Packages Instaler

https://github.com/bb-qq/r8152/releases

for Xpenology DSM 6.2, emulation 3617xs , drivers 2.12.0-3, Works in my case.

BUT I can't INCREASE SPEED, I've modified MTU to Jumbo 3000, but nothing change. I thk i cant find a good configuration, only can do DSM detect USB and Net . Works, but more slow than 100intel net card .

 

So Could someone help me to reach speed? >>> ( I've to say that extra.lzma I cant instal yet (i afraid do it, I¡m so newbie).

 

thk. ¡¡¡ Gurus!


 

usb-cablecreation2-5gb.jpg

driver-instaled2.jpg

Driver USB instaled.jpg

Edited by Mary Andrea
Link to post
Share on other sites

imho you should not need that spk when using my extra.lzma

also the most common reason seems to be wrong usb port or speed degradation of a 3.0/3.1 gen 1 or 3.1 gen2 port

use "lsusb" to see how fast the device is connected with usb

 

ash-4.3# lsusb
|__usb1          1d6b:0002:0310 09  2.00  480MBit/s 0mA 1IF  (xhci_hcd 0000:00:14.0) hub
  |__1-5         051d:0002:0106 00  1.10   12MBit/s 24mA 1IF  (American Power Conversion Back-UPS XS 800CI  FW:920.T2 .I USB FW:T3  3B1409X17540  )
  |__1-7         f400:f400:0100 00  2.10  480MBit/s 224mA 1IF  (SanDisk Ultra Fit 4C531001641217111165)
|__usb2          1d6b:0003:0310 09  3.00 5000MBit/s 0mA 1IF  (xhci_hcd 0000:00:14.0) hub

 

to use higher network speed you need a 5000MBit  connection to your usb network adapter

your description fits a 480MBit (usb 2.0) connection that might result in 30-45MB/s speeds

 

edit: see this for more information and about problems/solutions

https://xpenology.com/forum/topic/17690-drivers-for-usb-30-to-ethernet-255-gbit/

 

Edited by IG-88
  • Like 1
Link to post
Share on other sites

Ok, certainly 

1) The port where the usb 2.5 is connected is the 3.1 gen1 of the mother gigabyte b365M. I tested in all ports (usb2 too) of this mother, result is the same..
2) Indeed, it does not exceed the speed of 30-45mbs

--

thanks, i will try to edit yours extra lzma 

I've looked for your extra.lzma, but I can't find where to download it?

I should record it in the grub right? With the miniTools and OfMount?

 

thks a lot

 

Link to post
Share on other sites

this its mine usb test, may be its placed into wrong usb?

root@SYNOLOGY:~# lsusb
|__usb1          1d6b:0002:0310 09  2.00  480MBit/s 0mA 1IF  (xhci_hcd 0000:00:14.0) hub
  |__1-6         0bda:8156:3000 00  2.10  480MBit/s 500mA 1IF  (Realtek USB 10/100/1G/2.5G LAN 000000001)
  |__1-8         1a2c:0021:0110 00  1.10  1.5MBit/s 98mA 2IFs (USB USB Keykoard ffffffd0ffffffa2ffffffc3ffffffac)
|__usb2          1d6b:0003:0310 09  3.00 5000MBit/s 0mA 1IF  (xhci_hcd 0000:00:14.0) hub
  |__2-6         f400:f400:0100 00  3.00 5000MBit/s 896mA 1IF  (SanDisk Cruzer Glide 3.0 4C530000010310217470)

Link to post
Share on other sites

I moved Device to other USB, better, but I'm not sure if will arrive to theoretical 2.5gb speed. From Mac (1gb net) connected to Xpenaology only arrive 110mb/s, same of 1gb. ethernet Intel card.

 

|__usb1          1d6b:0002:0310 09  2.00  480MBit/s 0mA 1IF  (xhci_hcd 0000:00:14.0) hub
  |__1-8         1a2c:0021:0110 00  1.10  1.5MBit/s 98mA 2IFs (USB USB Keykoard ffffffd0ffffffa2ffffffc3ffffffac)
|__usb2          1d6b:0003:0310 09  3.00 5000MBit/s 0mA 1IF  (xhci_hcd 0000:00:14.0) hub
  |__2-5         f400:f400:0100 00  3.00 5000MBit/s 896mA 1IF  (SanDisk Cruzer Glide 3.0 4C530000010310217470)
  |__2-6         0bda:8156:3000 00  3.20 5000MBit/s 512mA 1IF  (Realtek USB 10/100/1G/2.5G LAN 000000001)

Edited by Mary Andrea
Link to post
Share on other sites
12 minutes ago, Mary Andrea said:

From Mac (1gb net) connected to Xpenaology only arrive 110mb/s, same of 1gb. ethernet Intel card.

you would need a 2.5G capable nic on/in the Mac too and both need to be connected directly or by a switch supporting that speed/connection

in your case the Mac (and your switch between them) is now limiting the speed as it only allows 1Gbit max

  • Like 1
  • Thanks 1
Link to post
Share on other sites

Imagined, Understood that, but firstly  I needed to be sure with DSM, now I will buy another thunderbolt adapter for Mac ... step by step, on the mac its easier for me.

thk always IG-88 , are you my Guru!! my Nas working good !

Link to post
Share on other sites
On 10/29/2020 at 6:07 PM, IG-88 said:

yes,  the recent extra.lzma's have the aqc111.ko driver for the Aquantia AQtion AQC111U

after using the extra.lzma and plug in the hardware you could check with lsusb if its detected (bearcats link shows some of that)

Hi IG-88,

1) where I find extra.lzma what are compiled Realtek driver for 2.5gb for my 3617xs? 

2) What we can do , if Realtek lunch a new USB NIC Linux driver for kernel up to 5.6 ? (do you thk its easy to compile it?)

Link to post
Share on other sites
1 hour ago, Mary Andrea said:

1) where I find extra.lzma what are compiled Realtek driver for 2.5gb for my 3617xs?

r8152 v12.12 is already part of the the extra v11.2 version for 6.2.3,

it on the expected/usual place where all the other extra.lzma's are published in the "Additional Compiled Modules" section

https://xpenology.com/forum/topic/28321-driver-extension-jun-103b104b-for-dsm623-for-918-3615xs-3617xs/

 

 

Quote

2) What we can do , if Realtek lunch a new USB NIC Linux driver for kernel up to 5.6 ? (do you thk its easy to compile it?)

the driver is UP TO 5.6 not exclusive to 5.x like the intel igc driver (intels 2.5G nic), the versions before worked and realtek makes sure older kernels can use it too

i already downloaded that version in october and it will be part of the next extra driver but apart from that, just because there is new driver it does not means we need it, if it supports new hardware like a new chip version then we may need it but in most cases it just for new developments in newer kernels that are in development or bugfixes and even bugfixes are not so often needed by the majority, the driver is already out for a while and is working fine for most people

 

Edited by IG-88
  • Like 1
Link to post
Share on other sites

Report >> for xpeno on gigabyte B365, 1 NIC ethernet Realtek

1) After Upgrade from DSM3617xs 24922 (6.2.2) to 25426 (DSM 6.2.3) USB2.5gb NIC became missing .

2) Replace extra.lzma (Version 2019/2020) working ok on 24922, with original old extra.lzma (1/8/18) and USB2.5 NIC Works again on 3617xs >

3) Two LAN are running OK (one in intel eth one in usb) 

  • Like 1
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.