installing expenology on baremetal creation


Recommended Posts

I am trying to setup a home server with backup. so far I have created one server using a USB setup with 5.2 from a  set-up that my son setup for me back in 2015 and it runs ok ...I have now created a second server with four new hard-drives and am trying to create a USB for that one... now this what I have done so far:

1.create a usb with 6.1....nothing happened when I tried it in the machine

2.recreated it three further times with no result

3.created a USB with 6.2 ... this time giving an error message: 'this is not a bootable disk. please insert a bootable floppy, press any key to start again'

During all these tries i have tried using the usb from the 5.2 machine and it works ok...giving me a start onto the network though can not be seen on the network..( I havnt tried  to overcome this...I suspect its because there is no DSM yet) ... the machine will also start on a ubuntu USB

 

So , where to next?

 

peterb3780

Link to post
Share on other sites

I see that you had an accidental upgrade from 5.2 in 2016 and that I presume you recovered from.

It doesn't look like you are creating the USB properly.

So here is some reading 😬

Depending on your hardware, your target version of DSM would be 6.1.7 with the 1.02b loader or 6.2.3 with the 1.03b loader.

These options are outlined here:

 

You can look through the updates reporting section  - the one for 6.2.3 is here:

to see if anyone has reported success or failure in updating your hardware. There is also a corresponding one for 6.1.7.

Having selected your target release, then the general method for creating a USB and installing DSM is here:

 

although it is for 6.1. it is the same method for 6.2.3 but with the different loader.

 

If you get stuck - or find it all just too much information, post details of your hardware and someone should be able to have a look at where you've got to and what you can do.

 

 

 

Link to post
Share on other sites

It seems that I have stumbled on the answer....I put the usb  (the one that I had set up for 6.2)in the other machine and it has worked so...I think that the trouble has been in the old machine which ran on 5.2 and has issues with hardware  ( old celeron) I am thinking that upgrading the motherboard and CPU will fix it

what are your thoughts, do you have any recommendations

Peter

Link to post
Share on other sites

No budget is fine. We just need to spend a little time looking at the problem. There are a number of different scenarios that could be causing your problem.

But you need to supply more information.

But first a random suggestion. What mode is your new box booting in? It needs to boot in csm/legacy mode not UEFI mode for the "6.2" loader to boot. Look at that first.

If it only boots in UEFI mode then you need the 1.02b loader and DSM 6.1.7

If that doesn't get you anywhere then you need to come back with

 

1. Version of the bootloader you are using - I am looking for both the version (1.02b / 1.03b) and the machine type (DS3615xs etc)

2. The hardware you are using. I am looking for CPU model and chipset - but motherboard model will do.

3. What does "work" mean when you put your USB into another machine. Does synology assistant or find.synology.com locate it?

4. Same for when you put your 5.2 loader into the target machine.

Link to post
Share on other sites

Hi to billat29

I have had some progression... so far I have two machines ....one I have had for 5 years   the other was a newer  computer withi7 capabilities  after losing all my data on the ol machine (ASUS H8IM-E with a celeron cpu) ...I lost all  after almost simutaneously  two Hdd Failures) ... I had the original data that I started with in 2015 on a couple of old Hdds ... so I purchased a couple of new drives and set up on the i7 machine....originally starting up synology on the old usb drive...then set up all I had of the old data....and all this works ok... then I started rebuilding the old asus machine...I purchased 4 new 2TB drives and installed them  .. I tried (several times -starting again each time)error messages I kept getting were saying that the disk could not be read....arggh.. I then experimented by putting the drive into the i7 machine... and... it worked ....I followed the steps and upgraded to 6.2 -23739 and it is working great...doesnt seem to be any issues.

that leaves me with the original machine.... currently  loaded with 5.2.5644. It starts up and allows me into the remote access on my desktop but has stalled at the part where I try to put a 'volume' in place. :error message read; Connection failed. Please check your network system>...Ive tried a couple of different things  like selecting quick setup versus custom.... no difference ... It still fails

Link to post
Share on other sites

Let me summarise where I think we are.

You have an i7 based machine that is now on 6.2 and it works.

What you are now trying to do is to get a system up on the old ASUS with new disks and that is the machine that you are having problems with.

I looked at the product page for the ASUS and it clearly says that it is a UEFI machine. The loader that you have created for 6.2 will not boot unless you can put the ASUS into legacy BIOS mode.

On that basis, what I would do now is to put the 5.2 USB stick aside and create a new stick with the 1.02b DS3615xs loader, following the tutorial. I would clearly mark the new stick to make sure that there is no possibility of putting it in the i7 machine by mistake and then download and install DSM 6.1.7.

If it doesn't boot this stick, check and check again that you have vid and pid of the new stick set correctly along with the mac address of the ASUS.

If the installation process gets stuck again, take a screenshot and post that up here with a description of what you were doing at the time.

 

 

Link to post
Share on other sites

wow...its working...the only issue I have is in the bios....It wont keep the changes that I make.and revert6s every time its switched off, however i can cope with this manually ... its the least of the problems...big thing is that its working...thank you so much...you're the best

 

thanks again 

 

Peter

Link to post
Share on other sites

I changed the battery and its now locked in! ... yay.

A new problem has developed overnight...both servers went offline  the one that I was working on yesterday re appeared with a new ip address (even though  a static address had been setup   the other machine has disappeared altogether  ... searching using arp -a doesn't  list it and I cant find it using find.synology.com and thats end of my knowledge...one thing I looked at was the PID/VID on each of the USBs and they are both the same?????

Link to post
Share on other sites

Well, that's all very interesting.

Back to first principles.

1. Check the physical network. All switches up and with lights where you expect them? Is there anything to suggest that you had a power outage overnight?

2. Connect a monitor to each box in turn. Do you get all the loader boot messages when you reboot it?

3. Boot each box in turn with your ubuntu USB. Ping it from your PC. Obtain the hardware address of its network card. Plug the loader USB in as well and list its vid and pid.

4. Mount the loader USB under your OS of choice and examine the config file to make sure that it matches.

5. Do the same for the other machine and loader.

 

I predict that one of the loaders has the wrong MAC address set. I suspect the other may have tried to auto update itself.

 

Link to post
Share on other sites
15 hours ago, peter.b3780 said:

PID/VID on each of the USBs and they are both the same

 

If the make and model of the 2 USBs are the same, so will the VID/PID.

In some cases, even if they are not the same make/model, they might have been "branded" with the same VID/PID

(often the case with cheap no-name items).

 

What is important, is that the USB's have unique MAC adresses listed for the nic's.

Link to post
Share on other sites

progress so far : 

Changed Usbs so now no longer an issue of same PID/VID   

I    isolated the Asus  machine and re did the whole process...I now have this one operating ok

The other machine i7 gigabyte one is however most perplexing it is only  intermittently coming on  I have tried going back to the beginning and it still wont start...however I have now noticed that there is no activity on the network (that is the lights dont flash at either end of the cable).

Trouble checking; I find that when i start the machine on an ubuntu USB   the lights flash ok...Hmmmmmm!

I would like to get it going so at least I could transfer the data to the other machine because then I could reformate all the drives (four on raid 5) and start all over I seem to remember that this old machine was giving trouble when it was being used as my desktop  so maybe the motherboard is faulty

 

Anyway thats my dilemma...(who said computing is easy??)

Anbody??????

peter.b

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.