stanthewizzzard

DSM 5.2 is available

Recommended Posts

The 5.1 bootloader is not tested with or designed to support DSM 5.2. Please refrain from upgrading until a bootloader is released for DSM 5.2, or (if you are insistent on upgrading) realize that you upgrade at your own risk. There is also a risk of broken features due to the Xpenoboot Patch Engine potentially replacing unpatchable files with older patched versions from DSM 5.1. Whether these older versions are compatible with DSM 5.2 is entirely untested.

 

I personally do not recommend upgrading at this time! There are some new security features that came out with the full release that the team is addressing before releasing the 5.2 bootloader.

 

Although I have not tested it myself, anyone who has upgraded to DSM 5.2 should be able to downgrade by re-installing and keeping their data & settings. If you run into downgrade restrictions you can use some of the steps on this page to trick DSM into letting you downgrade: http://forum.synology.com/wiki/index.ph ... s_firmware . Again, this is not tested and is done at your own risk.

Share this post


Link to post
Share on other sites

ok then, services run, i don't have any access by web or ssh cause ssh is disable, and i don't want to loose all my datas so i'm going to wait for an xpenoboot update supporting 5.2

Share this post


Link to post
Share on other sites

Well don't I feel stupid, saw the upgrade and without thinking just hit go. Was on autopilot.

 

If anyone manages to downgrade back to 5.1 update 5 then please please post how here.

 

Thanks.

Share this post


Link to post
Share on other sites

SynoBios.ko

 

-------------------------------------------------

 

mov rdx, rbp

.text:00000000000006EE mov rsi, (offset scSynoBios+0A08h)

.text:00000000000006F5 mov rdi, r12

.text:00000000000006F8 call rax

.text:00000000000006FA

.text:00000000000006FA loc_6FA: ; CODE XREF: synobios_poll+49j

.text:00000000000006FA ; synobios_poll+59j ...

.text:00000000000006FA mov eax, ebx

.text:00000000000006FC mov rbp, [rsp+28h+var_10]

.text:0000000000000701 mov rbx, [rsp+28h+var_19+1]

.text:0000000000000706 mov r12, [rsp+28h+var_8]

.text:000000000000070B add rsp, 28h

.text:000000000000070F retn

.text:0000000000000710 ; ---------------------------------------------------------------------------

.text:0000000000000710

.text:0000000000000710 loc_710: ; CODE XREF: synobios_poll+3Aj

.text:0000000000000710 cmp byte ptr [rsp+28h+var_19], 0

.text:0000000000000715 jz short loc_6CC

.text:0000000000000717 mov esi, 224h

.text:000000000000071C mov rdi, offset scSynoBios

.text:0000000000000723 call synobios_record_event

.text:0000000000000728 mov rdi, offset aSynobiosBuzzer ; "synobios: buzzer stop button pressed\n"

.text:000000000000072F xor eax, eax

.text:0000000000000731 call printk

.text:0000000000000736 jmp short loc_6CC

.text:0000000000000736 ; ---------------------------------------------------------------------------

.text:0000000000000738 dq 841F0Fh

 

 

------------------------

 

$

.text:0000000000002D10 public SetMicropId

.text:0000000000002D10 SetMicropId proc near ; DATA XREF: .data:synobios_ops_0o

.text:0000000000002D10

.text:0000000000002D10 var_8 = qword ptr -8

.text:0000000000002D10

.text:0000000000002D10 push rbx

.text:0000000000002D11 sub rsp, 10h

.text:0000000000002D15 cmp cs:syno_module+8, 0FFh

.text:0000000000002D1C mov [rsp+10h+var_8], 0

.text:0000000000002D25 jz short loc_2D77

.text:0000000000002D27 xor ebx, ebx

.text:0000000000002D29 cmp cs:MpId_18012, 0FFh

.text:0000000000002D33 jz short loc_2D40

.text:0000000000002D35

.text:0000000000002D35 loc_2D35: ; CODE XREF: SetMicropId+65j

.text:0000000000002D35 ; SetMicropId+78j

.text:0000000000002D35 add rsp, 10h

.text:0000000000002D39 mov eax, ebx

.text:0000000000002D3B pop rbx

.text:0000000000002D3C retn

.text:0000000000002D3C ; ---------------------------------------------------------------------------

.text:0000000000002D3D db 0Fh, 1Fh, 0

.text:0000000000002D40 ; ---------------------------------------------------------------------------

.text:0000000000002D40

.text:0000000000002D40 loc_2D40: ; CODE XREF: SetMicropId+23j

.text:0000000000002D40 mov rsi, offset aR ; "R"

.text:0000000000002D47 lea rdx, [rsp+10h+var_8]

.text:0000000000002D4C mov ecx, 8

Share this post


Link to post
Share on other sites

whew glad i updated my legit syno box.. ill wait till the ok is given.. hold off from updating your xpen boxes. unless your testing.. thanks devs :smile:

Share this post


Link to post
Share on other sites

Yes , please do a write up on how to downgrade correctly , would help allot of people including me :smile:

Share this post


Link to post
Share on other sites

Question, now there are 10 new packet version, as someone tried to put update from them on DSM5.1 update 5 ?

Share this post


Link to post
Share on other sites

I updated the app packages, no issue whatsoever.

Did not try the update of the Syno, thanks to you guys.

Share this post


Link to post
Share on other sites
downgrade is possible

I've done it

 

Care to share your wisdom? or are you just going to troll us?

Share this post


Link to post
Share on other sites

downgrade stap:

1、login by console use root

69b8bc7agw1es2t8h52ssj20nu0oxjvt.jpg

2、input

1、"cd /etc.defaults" press key "ENTER"

2、"vi VERSION" press key "ENTER"

69b8bc7agw1es2tejvrnwj20gy0ntmxr.jpg

3、press key "i" then change minorversion="1" and buildunumber="5021" <--not "5022"

then input ":w" press key "ENTER" an input ":q" press key "ENTER"

4、reboot the synology

5、select install/upgrade

69b8bc7agw1es2tj0d0h7j20n70cy3zo.jpg

6、open Synology Assistant to install the DSM-5.1-5022

7、after this stap,you now can view web gui

8、now you can find the smb is broken

9、to repair the smb is easy ,just open the web gui and open the console

69b8bc7agw1es2tmkg6aqj20y50hxn1k.jpg

1、uncheck the windows file service then press apply

2、check the windows file service and press apply again,to restart windows file service

after this you synology is downgrade to 5022.

 

I just come from China,so my English is not will,thanks.

Share this post


Link to post
Share on other sites

Thanks for your step-by-step!!

 

Question: Did you lose all of your installed apps?

 

I suspect if you use Download Station, that all of it's data/directory would be lost, if a backup isn't done first. :eek:

 

Did you experience this?

Share this post


Link to post
Share on other sites

Anyone Downgraded Yet ?

Do we lose configuration with this ? apps lost ? map rights ?

 

kind regards

Share this post


Link to post
Share on other sites

I managed to downgrade just before this was posted with a slightly different method.

 

I tried an install using the Synology Assistant, that didn't work, rebooted and whereas before I could still connect to the drives I couldn't after that.

 

Tried a reinstall of Xpenoboot, no joy.

 

I used Synology Assistant again and selected Connect instead of Install, this bought up the Web Assistant. From there I did a manual install and it worked. THIS FORMATS YOUR SYSTEM PARTIION and reinstalls the DSM software, which is why I lost my config and apps etc. Fortunately I had a config backup, whilst this doesn't re-install you apps it does restore a fair bit of the config (users, shares, some settings etc).

 

The data was all there, and after the config restore everything appears to be normal, had to reinstall the apps though.

 

So, I'm not sure if the post procedure loses anything, but the way I did it loses your config and apps but not anything on my data partition.

Share this post


Link to post
Share on other sites
I managed to downgrade just before this was posted with a slightly different method.

 

I tried an install using the Synology Assistant, that didn't work, rebooted and whereas before I could still connect to the drives I couldn't after that.

 

Tried a reinstall of Xpenoboot, no joy.

 

I used Synology Assistant again and selected Connect instead of Install, this bought up the Web Assistant. From there I did a manual install and it worked. THIS FORMATS YOUR SYSTEM PARTIION and reinstalls the DSM software, which is why I lost my config and apps etc. Fortunately I had a config backup, whilst this doesn't re-install you apps it does restore a fair bit of the config (users, shares, some settings etc).

 

The data was all there, and after the config restore everything appears to be normal, had to reinstall the apps though.

 

So, I'm not sure if the post procedure loses anything, but the way I did it loses your config and apps but not anything on my data partition.

just see my last method,you must restart windows file service,if you havn't,you can't access the drives.

Share this post


Link to post
Share on other sites
I managed to downgrade just before this was posted with a slightly different method.

 

I tried an install using the Synology Assistant, that didn't work, rebooted and whereas before I could still connect to the drives I couldn't after that.

 

Tried a reinstall of Xpenoboot, no joy.

 

I used Synology Assistant again and selected Connect instead of Install, this bought up the Web Assistant. From there I did a manual install and it worked. THIS FORMATS YOUR SYSTEM PARTIION and reinstalls the DSM software, which is why I lost my config and apps etc. Fortunately I had a config backup, whilst this doesn't re-install you apps it does restore a fair bit of the config (users, shares, some settings etc).

 

The data was all there, and after the config restore everything appears to be normal, had to reinstall the apps though.

 

So, I'm not sure if the post procedure loses anything, but the way I did it loses your config and apps but not anything on my data partition.

just see my last method,you must restart windows file service,if you havn't,you can't access the drives.

 

After I tried the install from the Synology Assistant, I couldn't access anything. The Install failed saying that the version was wrong etc. If I had seen your post first I would have changed the VERSION file.

 

All is working ok now though.

Share this post


Link to post
Share on other sites

It would be nice to get an update from a developer at this point on the status of an Xpenoboot for 5.2

Share this post


Link to post
Share on other sites
Thanks for your step-by-step!!

 

Question: Did you lose all of your installed apps?

 

I suspect if you use Download Station, that all of it's data/directory would be lost, if a backup isn't done first. :eek:

 

Did you experience this?

 

Upgrade the APP with di XPEnoboot 5.1 and work fine!!!!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.