Has anyone used a dual-port-NIC with Virtual Machine Manager


Recommended Posts

I have an onboard NIC (Dell Optiplex 3010 PC) and an Intel Pro-1000 dual-port PCI NIC, making a total of three available LAN interfaces.

 

In DSM 6.2.3's Netowk Control Panel all three NICs are visible, I can ping their manually assigned IPs and their connection status is determined OK when I plug and unplug their cables. All good so far.

 

However when I visit Virtual Machine Manager > Virtual Switch I'm only offered  the on-board NIC and ONE of the dual-port LAN interfaces.  I'd expected to have a choice of the on-board one and the two interfaces from the dual-port-card?   The mac addresses for both of the dual-port interfaces (together with the on-board port) are present in the grub.cfg and as I say, all interfaces functiom as expected in the DSM Control Panel - just not when I try to use all of them in Virtual Machine Manager. 

I'm using Jun's 1.0.3b loader and the DS3617xs firmware (DSM 6.2.3-25426 Update 2)

Does anyone have any thoughts?

Thanks,

Steve

dsm.png

Link to post
Share on other sites
  • 5 weeks later...
On 10/16/2020 at 10:53 AM, steveharman said:

Virtual Machine Manager > Virtual Switch I'm only offered  the on-board NIC and ONE of the dual-port LAN interfaces. I'm using Jun's 1.0.3b loader and the DS3617xs firmware (DSM 6.2.3-25426 Update 2)
 

 

I'm confirming impossible to make BOND (dual LAN) under Synology Virtual Machine with the same soft as you (DSM 6.2.3-25426 Update 2) >> (by cause only ONE Virtual vSwitch free, maybe pay VMM can do it) .. 

 

"Zerotier" app (open source free) could be possible make a BOND or use easily several LAN together , but Zerotier driver Synology reach now up to 6.2.0 , so you should downgrade. 

could you see there

http://download.zerotier.com/PRERELEASES/1.4.0pre/synology/

Edited by Mary Andrea
Link to post
Share on other sites
2 hours ago, Mary Andrea said:

"Zerotier" app (open source free) could be possible make a BOND or use easily several LAN together , but Zerotier driver Synology reach now up to 6.2.0 , so you should downgrade. 

could you see there

http://download.zerotier.com/PRERELEASES/1.4.0pre/synology/

just in case you want to mess around with that

 

there is a "zerotier_broadwellnk-6.2_1.4.0.spk" and that "broadwellnk" is a x64 dsm 6.2.x system the same as 3615/17 and 918+ are, the package seem not to contains a driver that would be bound to a kernel, it looks like a normal software and if its for 6.2 and x64 it should run on all x64 versions

when replacing the file "INFO" inside the package with one that contains

arch="x86_64" instead of the arch="broadwellnk" the it would install an all the tree dsm's we have

the installer of the package references to tun.ko and that driver is part of the normal drivers dsm comes with (there is no *.ko file in that installer,so no danger of overwriting a kernel file you might need)

 

  • Thanks 1
Link to post
Share on other sites
1 hour ago, IG-88 said:

just in case you want to mess around with that

Ahhh, thk for this wide information ! I'll try again on a DSM 6.2.3 and I'll test it. best >>

 

Certainly as IG-88 said, Zerotier its a normal soft capable to instal into 3617xs (and other Syno models) . In this case "zerotier_broadwell-6.1_1.4.0.spk" into  DSM 6.2.3-25426 Update 2 works perfectly .(What do yo could do with Zerotier "its another virtual world to discover)

 

Captura de Pantalla 2020-11-15 a la(s) 16.01.10.jpg

Edited by Mary Andrea
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.