Sign in to follow this  
ioan

Mover DSM a una maquina Virtual en ESXi

Recommended Posts

Ahora mismo tengo el DSM en un N54L. Quiero poner ESXi y mover el actual DSM a una maquina virtual.

Sabeis de algun tutorial por ahi, no quiero hacerlo todo desde cero y sin un guía básica por lo que pueda surgir.

 

Una consulta off topic, sabeis si la licencia de Esxi 6 sirve para la version 6 empaquetada para HP?

 

Gracias.

Share this post


Link to post
Share on other sites

Hay un paquete en el centro de paquetes de dsm para hacer recovery de un synology en otro identico. Tendrias que montar uno nuevo en la maquina virtual , descargar el mismo paquete y configurarlo como recovery del que ya tenes. Cuando esta ok puedes apagar el xpenology fisico. Saludos!

 

Enviado desde mi GT-I8200L mediante Tapatalk

Share this post


Link to post
Share on other sites

Se me ocurre que luego de hacer un backup de la configuracion y rotular los discos para mantener el orden. Podrias montar con otro disco o par de discos el esxi. Preparar la VM. Presentarle el xpenoboot con el soporte que prefieras para que bootee. Y presentarle los cuantro discos a la vez a ver si los toma asi como asi. Siempre utilizando el mismo xpenoboot y los discos en el mismo orden.

 

Enviado desde mi GT-I8200L mediante Tapatalk

Share this post


Link to post
Share on other sites

Por si a alguien le interesa, yo he estado haciendo pruebas con esto.

Actualmente lo tengo montado en HP Gen8 Baremetal con dos discos en mirror (los discos están configurados en la BIOS como AHCI) y funciona pefecto sin problemas, pero como le añadí más memoria me interesaba montarlo sobre un hipervisor y poder trastear con otras máquinas virtuales.

Como no quería migrar la información la información de los discos e intentado montarlos tan cual --en el mismo orden--.

 

He usado:

 

VMware-ESXi-6.0.0-Update1-3073146-HP-600.9.4.34-Nov2015.iso

XPEnoboot_DS3615xs_5.2-5644.4.img

Driver alternativo por problema de performace en el último: scsi-hpvsa-5.5.0-88OEM.550.0.0.1331820.x86_64.vib

Vsphere: VMware-viclient-all-6.0.0.exe

 

El procedimiento resumido es:

 

1- Montar ISO del installer de ESXi e instalarla en un USB de unos 8GB

2- Editar IMG de Xpenology y poner nuestro SERIAL y MAC (se usa OSFMOUNT o WINIMAGE)

3- Convertir IMG de Xpenology en VMDK (se usa StarWindConverter)

4- Conectar un disco adicional para instalar el ESXI (se puede usar el conector del lector de CD)

5- Arrancar ESXI desde el USB

6- Activar consola SSH de ESXI

7- Conectar a la consola SSH del ESXI

7.1- Sustituir el driver hpvsa por la versión antigua nº 88

8- Conectar mediante Vsphere a ESXI y hacer los siguiente puntos

8.1- Crear datastore con el nuevo disco añadido

8.2- Crear máquina virtual para Xpenology en el datastore

8.3- Subir a la carpeta de la máquina virtual los dos ficheros generados por StarWindConverter

8.4- Montar el VMDK subido en la unidad de CD de la máquina virtual

8.5- Crear carpeta vacia RDM en el Datastore

9- Conectar a la consola SSH del ESXI

9.1- Generar ficheros RDM sobre los discos de datos de Synology

10- Conectar mediante Vsphere a ESXI y hacer los siguiente puntos

10.1- Añadir los discos RDM a la máquina virtual

10.2- Iniciar la máquina virtual

 

No he conseguido hacer que funcione, aunque por suerte tampco he perdido los datos y he podido volver a la configuración inicial Baremetal.

 

Los problemas que he encontrado:

 

- Con la configuración incial dejando los discos como AHCI, se cuelga en el punto 9.1 al intentar generar los ficheros RDM y se registran muchos errores de este tipo

2016-01-06T12:53:27.396Z cpu0:32948)<7>ata4: ahci_port_reset, entering...

2016-01-06T12:53:27.396Z cpu0:32948)<6>ata4: reset in progress...

2016-01-06T12:53:29.246Z cpu0:37258)<6>ata4: ahci_port_reset, hard reseting port

 

- Cambiando los discos del modo AHCI a Enable Dynamic HP Smart Array B120i RAID Support y creando un volumen RAID 0 por cada uno de los discos:

Los RDM se generan sin problemas, el Xpenology arranca pero no es capaz de montar el volumen de datos. El mdadm no encuentra el formato que espera en las paticiones de los discos, con mi configuración cada disco de datos tiene 3 particiones -2 pequeñas reservadas para synology y la particion grande del volume1-, reconoce y monta los dos primeros arrays RAID1 pero da un error de formato al intentar montar el tercer array RAID1 que contiene el volume1). He intentado montarlos con un Linux porque pensé que la creación del RAID0 mediante la BIOS había machacado alguna cabecera pero obtuve el mismo error.

 

Volví a poner todo en la configuración original AHCI y con el USB de Xpenology y arrancó sin problemas, confirmándome que la operación de creación de volumenes RAID0 desde la BIOS no modifica nada en los discos.

 

Seguramente si se hace una reinstalación de Xpenology sobre los discos en modo HP Smart Array --creando nuevo volumen y machacando todo-- funcioná perfectamente.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this