• 0

Memory leak/usage


Question

I have DSM 6.1.7 15284 installed with Jun 1.02b in an ESXi 6.5 VM. It's been running for over 1.5 years with little issue.

 

One time in the past, I was not able to access the shared folders in Windows. I found the DSM GUI to be unresponsive and noticed that my memory utilization was >90%. (I use Grafana/Telegraf to gather stats on my network). After restarting DSM everything worked normally and memory utilization was back to "normal" (<10%). At the time I had allocated 8GB of RAM to the VM so I decided to double the allocation to 16GB.

 

Fast forward to this week and I noticed that the memory utilization was increasing over time. I only capture a 30 day window of data, but you can see in the following graph that it went from around 15% to 45% in 30 days. I decided to restart DSM and the utilization dropped to 5%. 

 

https://i.imgur.com/SJMIagJh.png

 

Has anyone else experienced memory usage creep like this?

 

I have the following packages running in DSM: DDSM in docker, Active Backup for Business, Drive, Hyper Backup, Hyper Backup Vault, Log Center, Moments, Replication Service, Snapshot Replication, Universal Search, VMware Tools, and VPN Server.

 

In the future as the memory usage continues to go up, is there a command I can run (CLI) that will tell me what's using the memory? I've tried htop and top but it wasn't obvious what was using the memory as the top users were only in the 100s of MB range.

 

At the end of the day I can always manually reboot as memory usage rises, but it sure would be nice to find the root cause to prevent it from occurring in the first place.

 

 

 

Link to post
Share on other sites

2 answers to this question

Recommended Posts

  • 0
8 hours ago, jensmander said:

Does DSM indicate „real“ RAM usage or is this buffered/reserved? Did you check the resource monitor within DSM?

 

The numbers match the "Utilization" figure in Resource Monitor. I did look in Task Manager at the top memory users in the Services and Processes tab and I didn't see any one thing that was using up gigabytes of memory. The highest users were VMware Tools and snmpd, and they still are after restart. For future debug, I've saved screenshots of the Services and Processes tab for comparison later when the memory usage creeps up.

 

FWIW, here the metric I'm using (that precisely matches the utilization per Resource Monitor):

SELECT ((last("memTotalReal") -last("memAvailReal")-last("memBuffer")-last("memCached"))/last("memTotalReal"))

 

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.