Can't install Eynio Server on Xpenology


Recommended Posts

Hello I can't install package Eynio Server on my xpenology, it says DSM can't find package NODE JS on package center. I don't know what can be the problem. Any help please??

Could you try to install Eynio server from package center to see if it works for others?

 

Thnak you

Link to post
Share on other sites

https://archive.synology.com/download/Package/spk/

look for "node..."

 

you could use a search engine with "NODE JS synology package"

 

you can also open the spk file with 7zip and have a look at the file INFO

there should be a listed depedency like this

install_dep_packages="xxx:yyy:zzz"

 

Eynio seems to be from 4/2017 (DSM 5.x)  and not maintained anymore, so you might want to test a older package from the link above dating back to that time

you could also dig deeper in the spk file like opening "package.tgz" or the install scripts to see what node.js version might be used initially

v4 or v6 seemed to be used at this time, maybe eve v0.10

 

when downloading a spk manually you need to look for the platform of you installed dsm version (in the file name of the spk)

x86_64 is for all three

bromolow is 3615

braswell is 3617

apollolake is 918+

 

Link to post
Share on other sites
1 hour ago, IG-88 said:

https://archive.synology.com/download/Package/spk/

look for "node..."

 

you could use a search engine with "NODE JS synology package"

 

you can also open the spk file with 7zip and have a look at the file INFO

there should be a listed depedency like this

install_dep_packages="xxx:yyy:zzz"

 

Eynio seems to be from 4/2017 (DSM 5.x)  and not maintained anymore, so you might want to test a older package from the link above dating back to that time

you could also dig deeper in the spk file like opening "package.tgz" or the install scripts to see what node.js version might be used initially

v4 or v6 seemed to be used at this time, maybe eve v0.10

 

when downloading a spk manually you need to look for the platform of you installed dsm version (in the file name of the spk)

x86_64 is for all three

bromolow is 3615

braswell is 3617

apollolake is 918+

 

Thank you for your help, I have just extracted it with 7zip and looked info file, it show node js so I found the package node js and install the last version, now is working perfectly, why this versions of node js are not showing on package center??

 

Thanks.

Link to post
Share on other sites
9 hours ago, viktortrass said:

why this versions of node js are not showing on package center??

in don't know, i theory that dependency field should work in a way where the missing package is automatically installed (dsm should ask to install the missing package)

on 918+ i don't see "Eynio" but "Node.js" v8 and v12 (and a "Node.js" from Community as beta, containing a 10.x version)

if looking to the syno server with the skp files then Eynio is not availible as x86_64, its just some older platforms including with bromolow and braswell, no apollolake (918+)

btw. that can be "fixed" by manually updating the INFO ether containing apollolake or making it x86_64 at all (extract, edit file, repack into spk with 7zip)

 

 

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.