Sign in to follow this  
kilik

Can't shutdown NAS

Recommended Posts

I intalled DSM on my Gigabyte Z87x-UD3H. My DSM is 5.1 update 4. I can't shutdown my Nas because right after it shutdown, it restart automatically. I connect my Nas to an UPS but i don't think that's the reason becasue I tried both enable UPS support or not but it's the same! Any one know how to solve it? Thank you!

Share this post


Link to post
Share on other sites

Maybe i'm wrong but check if you have wake on lan. This may cause the restart. It is just like some device want to access your nas and this provoke the restart.

 

This is the first think that came to my mind. Check this both on dsm and bios settings and then we'll see next step!

 

Good luck!

Share this post


Link to post
Share on other sites
Maybe i'm wrong but check if you have wake on lan. This may cause the restart. It is just like some device want to access your nas and this provoke the restart.

 

This is the first think that came to my mind. Check this both on dsm and bios settings and then we'll see next step!

 

Good luck!

Thanks for your advice, I turned off WOL in bios and i can shutdown my nas. Now i have a new problem. When WOL was enabled, I setup for my hdd and my Nas hibernate and it worked fine( hdd hibernate after 10 minute and 10 minute after that my Nas entered standby or shutdown mode, something like that, and it restart right after that ). Now I can't make it work anymore with the same settings. I don't know why. And could you show me how fix the WOL problem? When nas is shutting down, I saw this message on screen:

"syslog-ng stop/wating

System is not in ups safe mode

unmount root [1]

/proc/self/fd/9: line 17: can't create /.unmount_root__failed: Read-only file system"

I connect my nas with an Eaton UPS by the way!

Share this post


Link to post
Share on other sites

I found the problem. It's the Couchpotato and sickbeard , python, git packages. I have to disable or uninstall them to make my hdd to hibernate!

Share this post


Link to post
Share on other sites

Maybe the settings that you had in these applications caused the problem.

 

Both couchpotato and sickbeard need python (as i remember, if i am wrong please forgive me) and both of them execute something like cron job that do not allow your diskstation to hibernate.

Share this post


Link to post
Share on other sites
Sign in to follow this