• 0
istofast4you

perte de paramétrage réseau

Question

Tout d'abord Bonjour a tous ! 🙋‍♂️

 

je suis nouveau et novice dans le domaine des machines virtuel et de l’Émulation du nas synology 

 

j'ai monter ma machine avec virtual box et xpenoboot 3615xs jusqu’à aujourd’hui tout aller bien 

 

et du jour au lendemain plus moyen de lancer ma machine il me parler de mon paramétrage réseau qui n’était pas valide en énumérant le nom de ma carte reseau 

  (comme un con j'ai pas fait de screen du message   🙄  )

 

je suspecte mon vpn de me foutre la pagaille ( betternet ) que j'ai eteint bien sur

 

si vous voulez j'ai changer j'ai du changer de "acces par pont " a "NAT" pour pouvoir redémarrer mon Nas mais je ne peux plus y accéder

 

ma question est pourquoi ne trouve t'il plus ma carte réseau dans virtual box ( voir photo ) 

 

tout conseil est bon a prendre MERCI !

Sans titre 2.jpg

Share this post


Link to post
Share on other sites

15 answers to this question

Recommended Posts

  • 1

Déjà il faut etre sur que ton NAS n'avait pas d'IP statique car si tu bascules sur NAT, la plage d'adresse IP n'est pas la même que lorsque tu étais sur "accès par pont". Donc si c'est le cas, il te suffit de checker quelle IP a pu prendre ta VM dans ce mode, dans le cas contraire hélas tu ne le verras jamais. En gos il faut que la config réseau matche le mode d'accès réseau que tu paramètres à la VM.

Si en plus tu avais configuré un client VPN au sein de la VM c'est possible que la route par défaut de DSM est sautée mais dans ce cas précis comment la remettre je n'en sais rien car il te faut un accès au minimum ssh pour faire la modif et qui dit ssh dit réseau 😕 A part réinstaller DSM, je ne vois pas 

Share this post


Link to post
Share on other sites
  • 1

ah oui ok!

Ton pb n'est pas lié à ta VM, mais ta carte réseau physique de ton PC semble avoir un petit souci! Soit elle a été renommée, soit elle n'est plus activée au niveau de Windows.

Dans le doute une résintallation de Virtual Box devrait corriger le tir. Si ce n'est pas le cas, il faut vérifier que l'interface RJ45 est bien activée dans le centre.

 

image.thumb.png.690c94ce5c9bb26a933268a60e780917.png

Share this post


Link to post
Share on other sites
  • 0

j'ai enfin réussi a retrouver l'imprim écran qu'a réussi a faire ma femme avant de changer les réglages réseau çà sera peux être plus parlant ? non ? 

Share this post


Link to post
Share on other sites
  • 0

salut nicoueron 

je n'est pas paramétrer de VPN via la vm c'est un vpn avec un logiciel que je fais tourner sur windows et non synology

 

en ce qui concerne les ip je n'est pas rentrer d'ip statiques j'ai laisser faire l'installation et synology assistant ma donner l'ip du nas après lancement de la VM

 

mais ma deuxième impression écran que j'ai retrouver devrait plus te parler non ?

 

Share this post


Link to post
Share on other sites
  • 0

Salut et merci pour ton aide mais mes connexions sont bien actives 

j'ai même essayer de désactiver réactiver mais ça na rien changer 

 

pour la réinstallation de DSM pour tout t'avouez je me chie un peu jai sur le nas 6 ans de photos et jai peur de tout perdre .... peux tu m'indiquer la marche a suivre si tu pense que c'est la seul solutions possible 

 

j'ai également trouver ça a force de fouiller je sais pas si ça peux marcher 

https://www.laintimes.com/reparer-une-erreur-nonexistent-host-networking-interface-name-virtualbox/

 

merci pour tout 

Sans titre 1.jpg

Share this post


Link to post
Share on other sites
  • 0

Oui effectivement ton lien correspond à ton erreur. Il est possible que le nom de l'interface se soit perdu ^^ 

 

Pour réinstaller DSM (en dernier recours on est d'accord!), il aurait fallu que la VM démarre pour cela, sinon il faut en recréer une autre et lui réaffecter tes disques de données et le loader. Il est possible que cela suffise mais si ce n'est pas le cas il faut forcer la réinstallation lorsque le laoder affiche l'invite de commande et choisir "Reinstall". Si tous les disques sont bien réaffectés l'assistant d'installation de DSM va les voir et proposer de se réparer.

Share this post


Link to post
Share on other sites
  • 0

je peux lancer le loader mais en réseau NAT et il n'est pas fonctionnel car je n'y est pas accès

 

et j'ai déjà essayer de recréer une autre machine virtuel mais les disque ne sont pas accepter et la carte réseau n'est toujours pas détecter en accès par pont 

 

mon dieux j'ai la boule au ventre de savoir mes photos perdu 😫 

Sans titre 2.jpg

Share this post


Link to post
Share on other sites
  • 0

pardon j'ai réussi a rentrer les disques mais les problèmes réseau persiste dois-je désinstaller oracle VM virtualbox complètement du pc et réinstaller pour retrouver cette fichu carte ? Ni ya til pas un autre moyen ?

 

si oui quelle fichier sauvegarder avant ?

 

Help je suis dans la menthe 😭

Share this post


Link to post
Share on other sites
  • 0

NAS FONCTIONNEL ! BRAVO ET MERCI 🤗

 

effectivement j'ai réinstallez ou plutôt mis a jour mon logiciel oracle virtualbox et cela a solutionner le problème j'ai retrouver ma carte réseau

 

la question est maintenant ....comment faire pour ne pas refaire la même bêtise avec mon vpn ?

ne pas lancer le vpn machine virtuel éteinte ?

Share this post


Link to post
Share on other sites
  • 0

Tiens c'est marrant mon dernier message où je disais de réinstaller VirtualBox à disparu 😕

En tout cas je me doutais bien au vu du message d'erreur que cela allait solutionner ton pb.

 

Utiliser un client VPN directement depuis Windows implique des "dommages collatéraux" si on ne sait pas comment celui-ci fonctionne techniquement. Il y a fort à parier que ton client VPN modifie la configuration de ta carte réseau, tu vois quoi dans les propriétés de celle-ci ? :

image.png.fd665fe6902b4b3c0ac259fc61148502.png

Je suis sûr qu'il ajoute un "driver" spécifique qui la rend ensuite incompatible avec VirtualBox.

 

Honnêtement je ne suis pas trop partisan pour utiliser une VM DSM dans un PC mutualisé avec Windows. Pour moi c'est plus pour du test que pour un usage en production. Mais si il te venait à l'idée d'installer ton client VPN dans DSM (ce qui est tout à fait possible) il faut toujours savoir ce que l'on fait car si tu te plantes, tu risques là aussi de planter la configuration réseau du NAS et bloquer totalement l'accès. A configurer à ses risques et périls!

 

 

Share this post


Link to post
Share on other sites
  • 0

je vais me renseigner sur le fonctionnement de betternet mais je suis quasiment sur que c'est de çà faute tout ça 🙄

 

bon au pire maintenant je sais quoi faire si cela ce reproduit ...enfin je suppose que je pourrais pas faire la même manip vu que la j'ai mis a jour virtual box donc je devrais faire quoi ?

 

supprimer virtual box des soft de mon pc et le réinstaller ? çà va pas me perdre le paramétrage ?ou pire me supprimer mes disque virtuel ?

 

en tout cas merci mille fois pour l'aide 😉

Share this post


Link to post
Share on other sites
  • 0
Il y a 13 heures, istofast4you a dit :

je pourrais pas faire la même manip vu que la j'ai mis a jour virtual box donc je devrais faire quoi ?

si, de toute façon tu ne risque pas grand chose avec une VM vu que les données sont bien dissociées dans un fichier à part.

 

Il y a 13 heures, istofast4you a dit :

supprimer virtual box des soft de mon pc et le réinstaller ?

Si ça se reproduit tu peux directement le réinstaller sans te poser de question.

 

Il y a 13 heures, istofast4you a dit :

çà va pas me perdre le paramétrage ?ou pire me supprimer mes disque virtuel ?

Non, car la configuration de ta VM est stockée dans un fichier xml propre à celle-ci. Par si effectivement tu supprimes à la main le répertoire de ta VM, là oui!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.