Sign in to follow this  
holybabel

WD Green idle3 Timer

Recommended Posts

Hi everyone,

 

i read about this in another thread. Can someone explain to me what i have to do?

 

I get the following for each drive i have installed:

 

DiskStation> syno_disk_ctl --wd-idle -g /dev/sda

Get /dev/sda WD idle3 timer [0] successfully

 

Does this mean that the idle3 timer is disabled? Is there something i have to do?

 

When i change the timer to 255 and then shutdown and start again the system shows [0] again.

 

Greetings holybabel

Share this post


Link to post
Share on other sites

I believe [0] = disabled.

 

You can see the options for the syno_disk_ctl command by typing it without additional arguements. It should look something like this:

 

Copyright (c) 2003-2014 Synology Inc. All rights reserved.

Usage: synology disk control
device: something like /dev/hda or /dev/sda
options:
?: print this message
--ncq-off: turn off ncq
	ex: syno_disk_ctl  --ncq-off /dev/sda
--wcache-off: turn off write cache and tell kernel don't allow open it anymore
	ex: syno_disk_ctl --wcache-off /dev/sda
--wd-idle: Read, Set or disable the idle3 timer of Western Digital drives
	-d: disable wd idle3 timer ex: syno_disk_ctl --wd-idle -d /dev/sda
	-g: get wd disk idle3 timer ex: syno_disk_ctl --wd-idle -g /dev/sda
	-s: set wd disk idle3 timer ex: syno_disk_ctl --wd-idle -s80 /dev/sda
fail iRet -1

 

If you notice the options for the --wd-idle arguement, you will find '-d' is an option - to disable the timer. After issuing the command 'syno_disk_ctl -d /dev/sd?' - where '?' is each WD drive in your system, it they should all be disabled. If it was already disabled, you should get a message like this:

 

/dev/sdf already disable WD idle3 timer

 

When you issue 'syno_disk_ctl -g /dev/sd?' - where '?' is each WD drive in your system, it should return output of:

 

Get /dev/sdf WD idle3 timer [0] successfully

Share this post


Link to post
Share on other sites
Sign in to follow this