Mokai

Troubleshooting log of XPenology boot loader?

Recommended Posts

Posted (edited)

Hello,

 

I am unable to get access to DSM from the network with the following Baremetal config:

Intel DH77DF motherboard

Processor intel core i5 2500K

RAM ddr3 balistix 1600mhz, 2x8G

with a LSI MegaRaid 9260-8i card.

 

The DSM info is:

  • DSM file: DSM_DS3615xs_25426.pat
  • Loader: jun v1.03b ds3615xs

 

There is no error displayed in the console (I have the usual text mentioning "Happy hacking"), I am pretty sure I am not facing a cid/vid or mac issue, considering the number of tests and checks done. 

When booting from Jun's loader, my machine is not accessible, no IP address has been granted by the DHCP, although the network card link light is blinking.

It is really like the onboard network card is basically not recognized...

 

I have tried:

  • Testing access from Synology Assistant or find.synology.com
  • 2 different USB keys on various USB ports
  • Various versions of Jun's loaders available, for different DSM versions
  • Updating the drivers (extra.lzma) with various versions of packages available
  • Playing with BIOS boot options (Legacy, UEFI)

 

If I boot Ubuntu or ESXi from an USB on the same machine, the network works fine.

 

I need to get logs to better understand what could be wrong.

 

In such context, how can I access to the dmesg output?

Some posts are referring to the serial, but I have no serial port but an usual screen :)

I have tried to play with the loglevel kernel option in the grub.cfg, without any change.

 

FYI: I already used ESXi on that system to run DSM: no network problem.

 

Thank you

Edited by Mokai

Share this post


Link to post
Share on other sites
Posted (edited)

Serial port is the only option. They are cheap and USB-connectable and generally work even when other things aren't.

 

That said, you are facing some standard problems and there may be more expedient/simpler ways to solve them.  When asking for help, stating your CPU type, loader used and the DSM version and platform are required.  Not knowing the details of what you were trying, here are some specific combinations for your hardware that are very likely to work:

 

1. Loader 1.02b, DSM 6.1.7 DS3615xs, any boot mode

2. Loader 1.03b, DSM 6.2.3 DS3615xs, CSM/Legacy boot mode

 

If neither of these work, you probably have a VID/PID problem despite your efforts and should try another USB key.

Edited by flyride

Share this post


Link to post
Share on other sites

Thanks @flyridefor your prompt answer.

I have edited the topic to add more information.

I am currently in the 2nd combination you are listing.

I will make new tests with a 3rd USB key and look at getting an USB-serial connector.

Share this post


Link to post
Share on other sites

I finally fixed my problem in two steps:

 

  1. With another USB key (not a cheap one as in my previous tests) and then the DSM was accessible on the network when booting manually from the USB key from the boot bios menu.
  2. Applied the solution from this post by using the loader with MBR partition table: Thanks to @Genesis and @wimmetje for their contributions 👏

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.