Open-vm-tools v9.4.6 for XPEnology

Recommended Posts

Hi guys...interesting read - i too have ESXi 6.0 with Xpenology running and have been looking for a way to use a UPS to gracefully shut the VMs and host down if required...looks like i have sourced a UPS, however need VM tools to be working.


Did anyone succeed in getting open vm tools working on esxi 6 with Xpenology?


Thanks in advance


open-vm-tools works fine on ESXi 6.0, tried it myself.


Please see following article on how to install open-vm-tools on XPEnology: ... xpenology/

Link to post
Share on other sites

Hi, thanks for the post.


Can you just confirm the version of open vm tools you're running successfully with ESXi 6.0 please? Just to make sure i get the right one.


Also, i read somewhere that people had volumes crashing, upon startup of xpenology, post "graceful" shutdown via vm tools - have you experienced this at all?


I'm only really looking to use this in an emergency, as i'm looking to configure a Cyberpower UPS which when on battery can gracefully shut the VMs and eventually the host down too. But ideally, i'd like the volumes to be intact one reboot! lol


To confirm - I'm running DSM DS3615xs_5592 with the latest update - currently not moved to the 5644 version yet.


Thanks again,



Link to post
Share on other sites

FYI for anyone else interested in this feature...


I just bit the bullet and installed the package ...onto my DSM 5.2-5592 running on esxi 6.0 and am pleased to say from the first test, a Guest Shutdown, worked perfectly and booted back up afterwards with no issues.


Hopefully, if i ever need to shut it down in this way, it will work as well again.

Link to post
Share on other sites
  • 1 year later...



Would it be possible for you to compile a open-vm-tools version that works with DSM 6.1? I installed DSM 6.1-15047 on a 6.0 ESXi. Unfortunately the open-vm-tools_bromolow-6.0_10.0.7-1.spk doesn't install. I get the error message: "This package is not supported on the platform of diskstation or is incompatible with the current DSM version."

Link to post
Share on other sites
  • 2 weeks later...


I also using DSM 6.1 and search the vm tools. IS there one available? I get same error "not supported on that platform".

I'm on DSM 6.1-15047 under ESXI6.5 now and open-vm-tools_bromolow-5.1_9.10.0-2476743-1.spk works fine for me.

Link to post
Share on other sites


I test it again and get same error. I use DSM 6.1-15047 Update 1 and open-vm-tools_bromolow-5.1_9.10.0-2476743-1.spk.


Error is:

This package is not supported on the platform of DiskStation or is incompatible with the current DSM version.


Looks like its Update 1.

Link to post
Share on other sites
  • 2 weeks later...
  • 3 weeks later...
  • 1 month later...
  • 1 month later...
  • Polanskiman changed the title to Open-vm-tools v9.4.6 for XPEnology
  • 4 weeks later...
  • 9 months later...
  • 6 months later...
  • 1 month later...
On 4/9/2015 at 5:38 PM, sancome said:


the "open-vm-tools_bromolow-5.1_9.10.0-2476743-1.spk" has been released, you can download it from here: ... p4gaJAfiTa

Hi Sancome
I tried to compile the latest open-vm-tools 10.3.10 by myself by using the Synology Package Creation Tool with an Ubuntu system for x86 apollolake architecture but I had no success. I was at the point when it successfully created a package after a lot of struggle and I thought that was it but the package itself was empty and I did not found out why. My knowledge is too limited I guess but I am really willing to learn.
Any chance you would help me out with this? Maybe you already have a step-by-step instruction what to do?
Thanks a lot in advance.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.