sancome

Open-vm-tools v9.4.6 for XPEnology

Recommended Posts

Hi guys...interesting read - i too have ESXi 6.0 with Xpenology running and have been looking for a way to use a UPS to gracefully shut the VMs and host down if required...looks like i have sourced a UPS, however need VM tools to be working.

 

Did anyone succeed in getting open vm tools working on esxi 6 with Xpenology?

 

Thanks in advance

 

open-vm-tools works fine on ESXi 6.0, tried it myself.

 

Please see following article on how to install open-vm-tools on XPEnology:

https://idmedia.no/projects/xpenology/i ... xpenology/

Share this post


Link to post
Share on other sites

Hi, thanks for the post.

 

Can you just confirm the version of open vm tools you're running successfully with ESXi 6.0 please? Just to make sure i get the right one.

 

Also, i read somewhere that people had volumes crashing, upon startup of xpenology, post "graceful" shutdown via vm tools - have you experienced this at all?

 

I'm only really looking to use this in an emergency, as i'm looking to configure a Cyberpower UPS which when on battery can gracefully shut the VMs and eventually the host down too. But ideally, i'd like the volumes to be intact one reboot! lol

 

To confirm - I'm running DSM DS3615xs_5592 with the latest update - currently not moved to the 5644 version yet.

 

Thanks again,

 

Dave

Share this post


Link to post
Share on other sites

Is anyone able to confirm what VM Tools version works with ESXi 6.0? Tested working? I really don't want to brick my XPEnology server but using the tools...

 

thanks in advance

Share this post


Link to post
Share on other sites

FYI for anyone else interested in this feature...

 

I just bit the bullet and installed the package https://download.xpenology.fr/XPEnology/565e27e7cbd9cb0d97819f126887b64d/56c0f347/open-vm-tools_bromolow-5.1_9.10.0-2476743-1.spk ...onto my DSM 5.2-5592 running on esxi 6.0 and am pleased to say from the first test, a Guest Shutdown, worked perfectly and booted back up afterwards with no issues.

 

Hopefully, if i ever need to shut it down in this way, it will work as well again.

Share this post


Link to post
Share on other sites

@sancome:

 

Would it be possible for you to compile a open-vm-tools version that works with DSM 6.1? I installed DSM 6.1-15047 on a 6.0 ESXi. Unfortunately the open-vm-tools_bromolow-6.0_10.0.7-1.spk doesn't install. I get the error message: "This package is not supported on the platform of diskstation or is incompatible with the current DSM version."

Share this post


Link to post
Share on other sites

HI,

 

I also using DSM 6.1 and search the vm tools. IS there one available? I get same error "not supported on that platform".

Share this post


Link to post
Share on other sites
HI,

 

I also using DSM 6.1 and search the vm tools. IS there one available? I get same error "not supported on that platform".

I'm on DSM 6.1-15047 under ESXI6.5 now and open-vm-tools_bromolow-5.1_9.10.0-2476743-1.spk works fine for me.

Share this post


Link to post
Share on other sites

Hi,

I test it again and get same error. I use DSM 6.1-15047 Update 1 and open-vm-tools_bromolow-5.1_9.10.0-2476743-1.spk.

 

Error is:

This package is not supported on the platform of DiskStation or is incompatible with the current DSM version.

 

Looks like its Update 1.

Share this post


Link to post
Share on other sites

Hi,

reading some posts and found that DSM need a change in the INFO file included inside SPK. Add arch="x86_64" in INFO file of my open-vm-tools_bromolow-6.0_10.0.7-1.spk

 

That works now fine...:smile:

 

Here for somebody that need this file:

http://ul.to/n4r9zr4q

Share this post


Link to post
Share on other sites
Hi,

reading some posts and found that DSM need a change in the INFO file included inside SPK. Add arch="x86_64" in INFO file of my open-vm-tools_bromolow-6.0_10.0.7-1.spk

 

That works now fine...:smile:

 

Here for somebody that need this file:

http://ul.to/n4r9zr4q

 

Thanks a lot... works fine for me too!

Share this post


Link to post
Share on other sites

Just download it and install it over synology package center.

 

Gesendet von meinem SM-G930F mit Tapatalk

Share this post


Link to post
Share on other sites
Hi,

reading some posts and found that DSM need a change in the INFO file included inside SPK. Add arch="x86_64" in INFO file of my open-vm-tools_bromolow-6.0_10.0.7-1.spk

 

That works now fine...:smile:

 

Here for somebody that need this file:

http://ul.to/n4r9zr4q

 

Thanks man!

Installed it on my 6.1@ESX6.5

Share this post


Link to post
Share on other sites

which hardware version are u running your vm on esxi 6.5? so the hardware version specified in the vm config?

 

Share this post


Link to post
Share on other sites
9 часов назад, Ikyo сказал:

Are you going to build a version for 6.2?

works on 6.2

  • Like 1

Share this post


Link to post
Share on other sites

DO you have a direct link to the one that I should be using?  The one I tried had an error and had to uninstall it.

Share this post


Link to post
Share on other sites

I downloaded the version that I found and it works for 6.2.  I must have had an older version.  Thank you for updating it.

Share this post


Link to post
Share on other sites
Posted (edited)

Does somewhere exist a tutorial of how to compile open-vm-tools?

I want to try that on my own so that I can always have the latest version for my xpenology system.

Edited by Tattoofreak

Share this post


Link to post
Share on other sites
On 4/9/2015 at 5:38 PM, sancome said:

 

the "open-vm-tools_bromolow-5.1_9.10.0-2476743-1.spk" has been released, you can download it from here:

https://www.dropbox.com/sh/nr8d24zqchzs ... p4gaJAfiTa

Hi Sancome
I tried to compile the latest open-vm-tools 10.3.10 by myself by using the Synology Package Creation Tool with an Ubuntu system for x86 apollolake architecture but I had no success. I was at the point when it successfully created a package after a lot of struggle and I thought that was it but the package itself was empty and I did not found out why. My knowledge is too limited I guess but I am really willing to learn.
Any chance you would help me out with this? Maybe you already have a step-by-step instruction what to do?
Thanks a lot in advance.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.