Sign in to follow this  
geoah

netif_num=4 issue on installation on h81m-p33 (rtl nic)

Recommended Posts

Hello, I learnt about XPEnology couple of days ago and decided to give it a shot.

I did a trial installation on vmware and everything worked perfectly on first try.

 

I then tried to install it on a custom box on an msi h81m-p33. (it seems the nic is a Realtek® RTL8111 G)

Using either "XPEnoboot_ DS3615xs_5.1-5022.1" or "Nano Boat 5.0.3.2 DSM 5.0-4528" I get the same error when trying to boot install/upgrade.

The error is "error internal nic devices 1 does not equal to internal nic number 4" and is before DHCP attempt.

After this, eth0 info is shown without an ip address (mac address is shown) -- as there is no ip address I cannot connect to it to install DSM.

 

After searching around I tried editing grub to change "netif_num=4" to "netif_num=1".

This causes a different error to appear and still no ip address.

The new error is "internal nic number 1 does not match the number of items in netif_seq" (might not be exactly this, but this is the point.)

I tried adding "netif_seq=0" and some other values such as 10 (not sure why) but without luck.

 

Am I doing something wrong or is it just that my nic is not compatible?

 

Thank you very much in advance. Any help would be greatly appreciated.

ps. I have also tried booting with "rmmod=r8168,r8169_new insmod=r8169" just in case it is a driver issue. Again with no luck and same error.

Share this post


Link to post
Share on other sites
Sign in to follow this