XPEnology on a HP ProLiant DL380e Gen8 Server


Recommended Posts

Hello All,

 

First of all, thank you all the effort what you put to this project.

 

I bought a HP ProLiant DL380e Gen8 Server for NAS. This version can hold 14pcs of 3,5" drives and has a HP Smart Array P420 Controller. My original plan was to create a HW level Raid 5 array from 3TB disks and install the DSM on it.

 

...but unfortunately the DSM installer does not find the array during the installation.

 

Is there any trick, tip or workaround to make it happen?

 

Thank you in advance!

 

Link to post
Share on other sites

for one you would need additional driver as extra.lzma (you can open this with 7zip, the file that needs to be there is hpsa.ko)

also its best to set the p420 in non-raid or hba mode

afair that can be done in the ssa utility, reset raid configuration and then choose hba mode, you can google it or look on youtube, there should be detailed information

i can't remember that we had someone doing it and using the hpsa.ko driver successfully

most people go with a cheap 9211-8i (reflashed oem clone) with IT firmware, it has two sas connectors so you should be able to connect the backplane of the server

 

i guess you used 3617? (918+ needs 4th gen intel and that model seems to have only ivy bridge)

you can use this extra.lzma for 3615/3617 for testing

https://xpenology.com/forum/topic/28321-driver-extension-jun-103b104b-for-dsm623-for-918-3615xs-3617xs/

 

  • Like 1
Link to post
Share on other sites
On 5/25/2020 at 11:50 PM, IG-88 said:

for one you would need additional driver as extra.lzma (you can open this with 7zip, the file that needs to be there is hpsa.ko)

also its best to set the p420 in non-raid or hba mode

afair that can be done in the ssa utility, reset raid configuration and then choose hba mode, you can google it or look on youtube, there should be detailed information

i can't remember that we had someone doing it and using the hpsa.ko driver successfully

most people go with a cheap 9211-8i (reflashed oem clone) with IT firmware, it has two sas connectors so you should be able to connect the backplane of the server

 

i guess you used 3617? (918+ needs 4th gen intel and that model seems to have only ivy bridge)

you can use this extra.lzma for 3615/3617 for testing

https://xpenology.com/forum/topic/28321-driver-extension-jun-103b104b-for-dsm623-for-918-3615xs-3617xs/

 

 

Thank you for your reply!

I'm an absolute beginner so I'm not fully understand what should I do.

 

My friend already created the necessary USB stick for me, how can I add this extra driver package to it?

I'll solve to switch to HBA mode - already checked it

Link to post
Share on other sites

Put in your boot stick into your Windows PC and check, if the second partition of it gets a drive letter. If yes - you can simply rename the extra.lzma (for example: extra.lzma.bak) and copy @IG-88‘s modified extra.lzma on it. If the partition doesn’t show up, check this tutorial for assigning drive letters to your stick:

 

 

  • Like 1
Link to post
Share on other sites
  • 5 months later...
8 hours ago, Zsolo said:

is there any refreshed driver pack or something what I have to consider?

no dsm 6.2.3 would be and the drivers from the thread above would be still the way to go

id suggest reading a little before starting

 

https://xpenology.com/forum/forum/83-faq-start-here/

https://xpenology.com/forum/topic/13333-tutorialreference-6x-loaders-and-platforms/

https://xpenology.com/forum/topic/29872-tutorial-mount-boot-stick-partitions-in-windows-edit-grubcfg-add-extralzma/https://xpenology.com/forum/topic/12422-xpenology-tool-for-windows-x64/

 

https://xpenology.com/forum/topic/7973-tutorial-installmigrate-dsm-52-to-61x-juns-loader/

Link to post
Share on other sites

我已经测试过惠普DL380p Gen8,将阵列卡更换成LSI 9205-8i有助于解决这个问题,但是不幸的是,Loader 1.03无法支持这台服务器的CPU,所以要使用裸机安装只能使用1.02引导,这意味着裸机安装只能使用DSM6.1,或者如果不计性能损失你也可以用ESXi直通阵列卡来解决这个问题。

I already tested HP DL380p Gen8. Changing the array card to LSI 9205-8i could help to solve this problem, but unfortunately, Loader 1.03 cannot support the CPU of this server, that means you can only use Loader 1.02 with DSM6.1 in bare metal installation. Or if you don't care about the performance loss, ESXi pass-through could be a good solution.

Link to post
Share on other sites
On 11/6/2020 at 7:19 AM, ChristianSwift said:

Loader 1.03 cannot support the CPU of this server

no that not the problem for sure, it might be about CSM mode in UEFI bios, it needs to be switched on and you are supposed to use the non uefi usb boot device

the base drivers on 1.03b from the loader are more or less the same so if its working with 1.02b then my guess is CSM

On 11/6/2020 at 7:21 AM, ChristianSwift said:

替换extra.lzma是无效的!该阵列卡的驱动并不在其中

 

also please keep non english to the appropriate section of the forum

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.