jurgenautt

asrock rack c3558D4I-4L problem with xpenology

Recommended Posts

hello, good afternoon, yesterday I was all day and today Sunday also trying to install xpenology on this miniitx board

it is a denverton atom cpu, 4cpu i have installed 8ram DDR4 ECC, it has 4 1gb cards, a bmc network card, and 9sata

looking at the cpu requirements, i downloaded version 918+ jun loader 1.04b, i did all the steps, added the network cards with your mac, etc.

I generated the usb and put it on the computer, well, it did not detect a network card in any way with the synology assistant.

 

IMG_20200510_194807660.thumb.jpg.23cca18caca61431ac5e66bb7ee298e9.jpg

asrockrack1.thumb.png.64881636f5f4c38cfdbd28fc3d74ffea.png

 

today already thinking that maybe with a 3617 charger, it could work, I carry out the same process and nothing the same problem

 

asrockrack2.thumb.png.7a589301886429baf3ae979657daced2.png

 

I have been looking at the network cards and on the asrock rack website, this model says that it has 4 Marvell 88E1543 (4L) cards, and from what I know it is compatible with xpenology, but entering service mode I see something that does not block attached capture, appear intel cards?
Do I have to do anything special?

Thanks

 

Share this post


Link to post
Share on other sites
36 minutes ago, jurgenautt said:

4 Marvell 88E1543 (4L) cards

these are just phy's, for the hardware layer, the network chip aka driver used will be intel

if you look in the driver list for download there will be intel lan drivers for windows

i'd suggest using newer drivers as extra.lzma's

depending on the type and version of dsm you need different files

maybe try 6.2.2, in this version tere are latest drivers for all three types

6.2.3 would only be possible for 918+ atm

 

https://xpenology.com/forum/topic/21663-driver-extension-jun-103b104b-for-dsm622-for-3615xs-3617xs-918/

start with 3615 or 3617 and if that works try 918+

to find it in network you dont have to mess around with grub.cfg, vid/pid is only important for really installing DSM

so for just trying to find out whats working you only need to copy the new kernel files and the extra's to the 2nd partition of the loader and boot it

if you got over that and got 918+ working you can try the same with 6.2.3 918+, same procedure as copy kernel files and extra's to loader

dont try to install the *.pat file without a propper vid/pid in grub.cfg, it it does not fit you will see error 13

so if you know waht loader is working and what you want to install you can mod the grub.cfg the way you need it, mac address is only needed when using wol but its nice to see the real mac's on the dhcp server and in network, so i always put that in too (beside vid/pid)

also keep in mind that 918+ has a build in limit of 2 notwork ports and when booting up you might only see a reaction on two ports and depending where you plugged in your nic cable it might be a dead one, is you can connect all 4 ports to network , "worst case is you will see 4 or 2 dsm IP's with the assistant but you wont miss if all 4 are connected

Share this post


Link to post
Share on other sites

Hello, thank you very much for answering.
I have been looking at the link that indicates the extension of the drivers, but I get lost, is it possible to install version 3617 ?, in this cpu because I am the one I want.
Sorry if I ask these questions but I do not understand very well the steps you indicate in the link, I do not master the Linux topic very much.
What are the steps one after another that I should follow? like I'm a fool
very grateful for your help

Share this post


Link to post
Share on other sites

sorry i won't give you any step by step help

i expected that, with 46 posts and a account running for years you would know the basics about installing xpenology

if you don't know how to use the bootloader and install dsm with it you should start with faq and the base tutorial

https://xpenology.com/forum/forum/83-faq-start-here/

https://xpenology.com/forum/topic/7973-tutorial-installmigrate-dsm-52-to-61x-juns-loader/

and maybe watch one or two youtube videos about it

 

its nothing that will be done in less the a hour from, i have no clue to done, especially when it comes to running a recent version (newer then in the tutorial), it might get better with the latest 6.2.3 but there is no recent tutorial for this and i guess it will stay this way for at least 4 weeks

 

if you look for a easy ti install system you might have a look at open media vault

Share this post


Link to post
Share on other sites
Posted (edited)

Hello, I have mounted on different usb disks, charger version of both 918+ with version 1.04, and 3617 with version 1.03 and when I enter usb devices in the screen menu, both the keyboard and the usb disk are blocked and that is why xpenology does not start, I have tried to rule out usb hardware failure, a usb disk with windows installation and another with linux, and they both boot perfectly, therefore I discard the failure of the usb connectors on the motherboard .
It's a startup thing, what could I do?

Edited by jurgenautt
error

Share this post


Link to post
Share on other sites

Do you have USB 2.0 ports (internal or external)?  Try those.  If there is BIOS options to put USB in legacy mode, try that as well.

Share this post


Link to post
Share on other sites

It has a usb 2.0 option and it does the same, I have also tried a pciex card with usb 2.0 and the same thing happens, could it be that the board was incompatible?

Share this post


Link to post
Share on other sites

It's an unusual board yes, but it should be able to make work. I'm not convinced about your USB issues. I think you may have a problem with Intel drivers that needs to be addressed by IG-88's extra.lzma.  If you want to try and troubleshoot without, get an Intel CT PCIe LAN card and see if that gets you working initially.

Share this post


Link to post
Share on other sites

hi i have tried with a pciex intel network card
And the same thing happens, when I select an option and press enter in the xpenology boot menu, it crashes and does not load the xpenology. The error is when you are going to load from the usb disk
It is very strange because there are synology devices with this processor, and I have been looking at the internal network cards of the motherboard and they are Marvell 88E1543 (4L) and they are also compatible
Attached screenshot of the bios.

 

image.thumb.png.afa6b7dbabf5e3130e733caa6762298b.pngimage.thumb.png.c8e6431c5410e3dfa3117a05475ca593.pngimage.thumb.png.29bf57948cb4c10d135d89487a1b02f1.pngimage.thumb.png.c253d51b11f66d7aeaa00743494de057.png

 

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.