Nested Virtualization - Synology not getting an IP


Recommended Posts

Following is my setup 

Core i5-4250u running windows and then VMWorkstation 15.5 Pro.

Inside VMWorkstation, running 1.04(b) loader DS918+  - Lets say SYN-A

Now inside SYN-A running two virtual machines (Windows 10 Lite and another Synology SYN-B)

SYN A has two NICs, One is bridged to local LAN and other is Natted (VMWorkstation NAT)

Issue is that Windows Lite is getting the IP on both NICs but SYN-B is booting but not getting an IP on boot

I have already checked Virtualiz Intel VT-x/EPT or AMD-V/RVI inside the SYN-A properties of CPU for SYN-A in VMWorkstation.

Does anyone know why I am not able to get the IP for the SYN-B (Nested virtualization - SYN B is nested inside SYN A)?

Read some posts that it is Ubuntu issue with NIC not enabled for promiscuous mode in nested situation. Any other clues or thoughts?

Link to post
Share on other sites

cant see why doing a overcompensated approach like this, just run syn-b and win10-lite as vm in vmware workstation

if isolation is needed then use virtual nic's or vlan

 

 

Link to post
Share on other sites

Thanks for the reply. what you just suggested is a plan b. For now the main reason for this approach is manageability. Vmworkstation is behind the CGNAT and it is much easier to control one VM machine with remote access than multiple machines. For some reason SYN-B not getting an IP even though same .img file is running as basis of SYN-A. 

I tried following but no luck

1. Turn off promiscuous mode for Ethernet

2. Update the drivers (latest) for 1.04(b) loader.

3. Change NIC to e1000 in vmx for Syn-A.

 

Strange thing is that the issue happening only on nested Xpenolgy and not on WinLite or Linux machine.

 

 

Link to post
Share on other sites
1 hour ago, DemoGeek said:

SYN-B not getting an IP even though same .img file is running as basis of SYN-A. 

that might be the problem, the mac address is set in grub.cfg and it should be unique, also in virtualbox the mac of the grub.cfg and the one set for the vm's nic need to be the same

 

Edited by IG-88
Link to post
Share on other sites
  • 2 weeks later...

I found this issue consistent with following flavors of nested installation

1. VMWorkStation(Win10) ==> Syn(A1) ==>Syn(B).Nested VM. 

2. ESXi==> Vmworkstation (Win2016)==>Syn(A2). Nested VM

but no ip in both cases. Tried everything like changing Mac from grub.cnf but no ip taken by nested VM

Interestingly if I do nested VM inside actual physical synology, same boot loaders etc, it WORKS.... 

What am I missing in Case#1/2 here?

Any help is greatly appreciated....

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.