Driver extension jun 1.03b/1.04b for DSM6.2.3 for 918+ / 3615xs / 3617xs


Recommended Posts

Posted (edited)

Thank you very much @IG-88 for your essential work, updated my DSM 6.2.2 24922 u5 running on an Asrock B250M-HDV / i5 7500T with a crossflashed Dell Perc H200 to LSI 9211-8i.

 

Did a "rm -rf /usr/lib/modules/update/*" just before manually updating to 6.2.3. After reboot, dev/dri is missing (didn't look for smart infos) so I replaced extra and extra2 with the ones of your 0.11 release by mounting synoboot2 through ssh, then did another "rm -rf /usr/lib/modules/update/*" and rebooted.
dev/dri is back, smart tests of disks connected to the LSI 9211-8i looks OK too. Much obliged.
Video Station HW transcode works, with Jellyfin too.
 

Edited by pmchan
Link to post
Share on other sites
3 hours ago, lotusd said:

We look forward to hearing on this

looks like i will do it this weekend, today i got my two JMB585 based, pcie 3.0, 5port ahci controllers (one pcie 4x, one M.2)

Link to post
Share on other sites
4 часа назад, IG-88 сказал:

looks like i will do it this weekend, today i got my two JMB585 based, pcie 3.0, 5port ahci controllers (one pcie 4x, one M.2)

🤞

Link to post
Share on other sites
Posted (edited)
2 hours ago, chamurai said:

how to : delete content of /usr/lib/modules/update ?

Run this command in terminal:

rm -rf /usr/lib/modules/update/*

Edited by cosmindnl
Link to post
Share on other sites
Posted (edited)

I think i need some help here. I've updated to DSM 6.2.3 and lost the hardware transcoding feature.

 

Hardware Setup :

ESXI 6.7U3 with Intel(R) Pentium(R) Gold G5400
LSI SAS9220-8i Controller IT Mode (Passthrough)

Intel VGA (Passthrough)

I've never used driver extensions on 6.2.2 so i thought the instructions said just replace the extra & extra2.lzma on the 2nd Partition in synoboot.img. 
I did that, but this way DSM doesn't see any of the Drives attached to the LSI Controller. 
What did i do wrong?

Edited by Leroy
Link to post
Share on other sites
Il y a 15 heures, Leroy a dit :

What did i do wrong?

Did your erase /usr/lib/modules/update/ folder content after replacing extra/extra2? 

rm -rf /usr/lib/modules/update/* in ssh

Link to post
Share on other sites
7 minutes ago, pmchan said:

Did your erase /usr/lib/modules/update/ folder content after replacing extra/extra2? 

rm -rf /usr/lib/modules/update/* in ssh


How to do that? DSM boots up as it was never installed before, so my admin credentials do not work. Are there default credentials?

Link to post
Share on other sites
Posted (edited)

I'm a barematal user so I don't want to mislead you by giving wrong directions to a VM user,  but did you try to rollback to previews extra/extra2 versions instead of those 0.11 ones? Another user reported doing so to make it works on his esxi setup.

Edited by pmchan
Link to post
Share on other sites
17 minutes ago, pmchan said:

I'm a barematal user so I don't want to mislead you by giving wrong directions to a VM user,  but did you try to rollback to previews extra/extra2 versions instead of those 0.11 ones? Another user reported doing so to make it work on his esxi setup.


THANK YOU !  This was the solution! Boots successfully and HW Transcoding is working : /dev/dri/ is there and Emby correctly detects its encoding capabilities and uses them as the following log shows:

>>>>>>  FindVideoEncoder - Media: h264, UseHardwareCodecs: True, Mode: Custom
Info    Checking: 'VAAPI Intel Corporation Device 16016 [1] - H.264 (AVC)'
Info    Check successful - selecting 'VAAPI Intel Corporation Device 16016 [1] - H.264 (AVC)'

 

Link to post
Share on other sites
Posted (edited)

Intell G5400 

6.2.2 HW - work with stock synoboot (only change mac sn to real)

 

after update 6.2.3 /dev/dri  disappeared and hw don't work

clear install do not help. i don't have dev/dri and have maaany error dmesg |grep i915

 

after change extra/extra2 /dev/dri appeared (and after clear install dev/dri appeared too)  , but  HW don't work (after clear install don't work too)

i try to clear /usr/lib/modules/update - nothing change

 

Error

 

dantesia@home-data:/$ dmesg | grep i915
[   19.153463] i915 0000:0b:00.0: BAR 6: can't assign [??? 0x00000000 flags 0x20000000] (bogus alignment)
[   19.153552] [drm:gen9_set_dc_state [i915]] *ERROR* DC state mismatch (0x0 -> 0x2)
[   19.154597] [drm] Finished loading DMC firmware i915/kbl_dmc_ver1_04.bin (v1.4)
[   19.159286] [drm] Initialized i915 1.6.0 20171222 for 0000:0b:00.0 on minor 0
[   19.738374] i915 0000:0b:00.0: fb0: inteldrmfb frame buffer device
dantesia@home-data:/$ dmesg | grep drm
[   19.153457] [drm] Supports vblank timestamp caching Rev 2 (21.10.2013).
[   19.153459] [drm] Driver supports precise vblank timestamp query.
[   19.153464] [drm] Failed to find VBIOS tables (VBT)
[   19.153552] [drm:gen9_set_dc_state [i915]] *ERROR* DC state mismatch (0x0 -> 0x2)
[   19.154597] [drm] Finished loading DMC firmware i915/kbl_dmc_ver1_04.bin (v1.4)
[   19.159286] [drm] Initialized i915 1.6.0 20171222 for 0000:0b:00.0 on minor 0
[   19.709455] [drm] Cannot find any crtc or sizes
[   19.738374] i915 0000:0b:00.0: fb0: inteldrmfb frame buffer device

when try videostation:

sudo cat /var/log/messages 
----

2020-05-04T15:27:52+03:00 home-data synoscgi_SYNO.VideoStation2.Streaming_1_stream[15066]: vte/adapt_streamer.cpp:48 Failed to hls transcoding
2020-05-04T15:27:56+03:00 home-data synoscgi_SYNO.VideoStation2.Streaming_1_stream[15078]: vte/adapt_streamer.cpp:48 Failed to hls transcoding
2020-05-04T15:28:02+03:00 home-data synoscgi_SYNO.VideoStation2.Streaming_1_stream[15099]: vte/adapt_streamer.cpp:48 Failed to hls transcoding
home-data synoscgi_SYNO.VideoStation2.Streaming_2_open[15108]: json_utils.cpp:147 Failed to parse json file [/tmp/VideoStation/enabled]

can anybody help ?... 

Edited by dantesian
Link to post
Share on other sites
On 5/1/2020 at 2:09 AM, IG-88 said:

 

what are your plans on how to use it?

synology loads cpufreq* modules by itself but how are you intent to use the new module?

I intrend to insmod the option and then modify the cpu governers to switch to them and test their effectiveness in boosting on demand cpu frequency, then idling back down to low voltage low frequency at low demand. I'll test on both Pentium anniversary and Intel i3-9100 cpu baremetal. I see you have added it into 0.11 - thankyou - I'll test in the next couple of days and report.  Cheers, DeadS

Link to post
Share on other sites
Posted (edited)

for all with newer coffeelake cpu's like i3 9100 having problems using hardware transcoding in video station and /dev/dri persent

 

looks like the problem it within video station 2.4.7 and below

synology has a newer version 2.4.9 that came out after dsm 6.2.3 (and its new i915 driver mainly for geminilake x20+ systems)

https://archive.synology.com/download/Package/spk/VideoStation/2.4.9-1626/VideoStation-x86_64-2.4.9-1626.spk

 

the patcher for codecs and transcoding (https://xpenology.com/forum/topic/24864-transcoding-without-a-valid-serial-number/) still works with this version

 

to get dts/truehd audio to work it needs a wrapper, external ffmpeg and patching the libsynovte.so from video station

the steps (including the patch above for serial number problem) need to repeated when a new video station version is installed

a description for the dts/truehd audio fix is here:

https://gist.github.com/BenjaminPoncet/bbef9edc1d0800528813e75c1669e57e#gistcomment-3119240

this is the ffmpeg i used

https://synocommunity.com/package/ffmpeg or newer version https://github.com/th0ma7/synology/tree/master/packages

 

BUT: if the external ffmepg is used with the wrapper the hardware transcoding fails, might be a problem with the wrapper or the ffmpeg

so you need to decide between dts/truehd or hardware transcoding (at least for now)

 

just in case the link gets invalid here is the text and i will attach the wrapper file that is downloaded

Spoiler

# Save VideoStation's ffmpeg
mv -n /var/packages/VideoStation/target/bin/ffmpeg /var/packages/VideoStation/target/bin/ffmpeg.orig

 

# Injecting the script (last revision aka 12)
wget -O - https://gist.githubusercontent.com/BenjaminPoncet/bbef9edc1d0800528813e75c1669e57e/raw/ffmpeg-wrapper > /var/packages/VideoStation/target/bin/ffmpeg

 

# Change ownership and mode of the script
chown root:VideoStation /var/packages/VideoStation/target/bin/ffmpeg
chmod 750 /var/packages/VideoStation/target/bin/ffmpeg
chmod u+s /var/packages/VideoStation/target/bin/ffmpeg

 

# Save VideoStation's libsynovte.so
cp -n /var/packages/VideoStation/target/lib/libsynovte.so /var/packages/VideoStation/target/lib/libsynovte.so.orig
chown VideoStation:VideoStation /var/packages/VideoStation/target/lib/libsynovte.so.orig

 

# Patch libsynovte.so to authorize DTS, EAC3 and TrueHD
sed -i -e 's/eac3/3cae/' -e 's/dts/std/' -e 's/truehd/dheurt/' /var/packages/VideoStation/target/lib/libsynovte.so

 

ffmpeg-wrapper

Edited by IG-88
  • Thanks 3
Link to post
Share on other sites
5 часов назад, IG-88 сказал:

looks like the problem it within video station 2.4.7 and below

Thank you, great job!

So do I understand correctly, what I need to do is install the new version of the Video Station with appropriate corrections and then can update DSM to 6.2.3 without extra lzma just plain image, and have the HW transcoding functional?

Link to post
Share on other sites
19 minutes ago, lotusd said:

So do I understand correctly, what I need to do is install the new version of the Video Station with appropriate corrections and then can update DSM to 6.2.3 without extra lzma just plain image, and have the HW transcoding functional?

no, the 1.04b plain image contains jun's extra/extra2 and the i915 drivers in it (jun's own backport) will fail to load with kernel from dsm 6.2.3 and prevent the use of synology's own new i915 driver that is needed

you will need the 0.10 or 0.11 extra/extra2 for 918+ to make use of hardware transcoding, it will remove jun's old driver when booting up (it will also copy the firmware files but there is just one unimportant difference to the firmware jun used in his slightly newer driver - thats mainly needed when doing a fresh install with 6.2.3)

Link to post
Share on other sites
Posted (edited)
16 minutes ago, lotusd said:

Noted, just one morу thing - shall be the VS 2.4.8 installed before upgrade to DSM 6.2.3 or after?

i guess it does not matter, i did after installing 6.2.3 (and tried installing and uninstalling at least 3 different versions)

if you read th 1st post carefilly the statement about 6.2.3 revocation from synology (change log info), you should install synology's universal search 1.5 before installing 6.2.3

https://archive.synology.com/download/Package/spk/SynologyUniversalSearch/1.5.0-0305/SynologyUniversalSearch-x86_64-1.5.0-0305.spk

 

Edited by IG-88
  • Thanks 1
Link to post
Share on other sites
Posted (edited)
10 hours ago, IG-88 said:

for all with newer coffeelake cpu's like i3 9100 having problems using hardware transcoding in video station and /dev/dri persent

 

looks like the problem it within video station 2.4.7 and below

synology has a newer version 2.4.8 that came out with/after dsm 6.2.3 (and its newe i915 driver mainly for geminilake x20+ systems)

its only offered in the package center to new x20+ systems that are geminilake based

can be downloaded manually

https://archive.synology.com/download/Package/spk/VideoStation/2.4.8-1611/VideoStation-x86_64-2.4.8-1611.spk

to install it on other system then geminilake a liittle tweaking is needed but its easy to do

open the spk with a tool like 7zip extrackt the file "INFO", edit it with notepad++ (or any other editor that is not not as ignorant as the windows notepad)

change


arch="geminilake"

to


arch="apollolake"

("x86_64" should work too and would make it installable on all x64 systems like 3615/17 but that's not necessary in this case)

 

save the file, put it back in the spk replacing the old one and then you can install on 918+

 

the patcher (https://xpenology.com/forum/topic/24864-transcoding-without-a-valid-serial-number/) still works with this version, i could not get dts/truehd audio to work with external ffmpeg and patching the libsynovte.so like here https://github.com/SynoCommunity/spksrc/issues/2952, might be solved when there is a wider release of this new version of video station and more people having problems getting it to work

 

i guess when they will do a general release of this or a new version later, so who is lazy can just wait, no worry's hardware transcoding is working for 8th/9th gen cpu's, just a minor problem within video station

 

 

Wow, that's great!!

 

I5-8500t  ,  ASUS H370i gaming , DSM6.2.3

 

->  dev/dri/ exists  ,   DS video  H/W transcoding SUCCESSFUL

->  Jellyfin   H/W transcoding SUCCESSFUL

 

Thanks IG-88

Edited by dolbycat
Link to post
Share on other sites

I've got a Problem with the driver extensions. 
Im using v0.10 because v0.11 wont recognize any drive on my hardware SAS controller, v0.10 does recognize them but doesn't display SMART Values and disabled TRIM for the SSD Drives.
With the stock driver set of DSM 6.2.3 the SAS controller works and reports SMART Values. Modell is LSI SAS9220-8i (patched to IT Mode) set to PCI-E Passthrough in VMWare ESXI.
Any Advice what to do or additional information i should provide?

Link to post
Share on other sites
10 hours ago, Leroy said:

Any Advice what to do or additional information i should provide?

any log (serial console) or dmesg so that we can see whats happening when 0.11 driver fails?

Link to post
Share on other sites
8 minutes ago, IG-88 said:

any log (serial console) or dmesg so that we can see whats happening when 0.11 driver fails?


I haven't found out anything xpenology specific for dmesg or how to set it up.
I haven't set up serial console, but found instructions on how to do that and will report back when i gathered the log.

As i'm currently running on 0.10 : Is it enough to just replace the 0.10 files with 0.11, or anything additional required for upgrading from 0.10 to 0.11?  

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.