Driver extension jun 1.03b/1.04b for DSM6.2.3 for 918+ / 3615xs / 3617xs


Recommended Posts

hello, I ask for your help.

I was using dsm 6.2.2 until two days ago and the hw decoding worked perfectly. Yesterday I upgraded to 6.2.3 and lost the decryption.

dev / dri / not present

 

root@Razer23:~# more /usr/syno/etc/codec/activation.conf

{"success":true,"activated_codec":["h264_dec","h264_enc","mpeg4part2_dec","aac_dec","aac_enc","hevc_dec","vc1_dec","vc1_enc","ac3_dec","mpeg4part2_enc"],"token":"a686af0830fd070xxxxxxxxxxxxx"}

 

What do I have to do to get it back? Should I add extra.lzma / extra2.lzma?

 

i5-4690T

Asus Q87M-E

NIC Intel I217LM

 

sorry for my bad english

Edited by 123gas
Link to post
Share on other sites
15 hours ago, 123gas said:

What do I have to do to get it back? Should I add extra.lzma / extra2.lzma?

yes, you need them to get the devices back

just copy the new ones (0.13.3) to your loader

and reading the first post of the thread would explain why ("... basically synology reverted the kernel ... i completely removed jun's i915 drivers ...)

Link to post
Share on other sites
6 hours ago, 123gas said:

Hi, how do I load these files exactly? Where can I find a guide?

there is a section "Tutorials and Guides" in the forum

https://xpenology.com/forum/forum/36-tutorials-and-guides/

 

the normal howto for installing references to extra.lzma and its the same for 6.2, with 1.04b 918+ its extra.lzma AND extra2.lzma you need to replace

https://xpenology.com/forum/topic/7973-tutorial-installmigrate-dsm-52-to-61x-juns-loader/

 

accessing the partitions got a little more complicated with newer win10 versions (but maybe use the method i added at the end of the thread)

https://xpenology.com/forum/topic/29872-tutorial-mount-boot-stick-partitions-in-windows-edit-grubcfg-add-extralzma/

 

 

Link to post
Share on other sites

hello

 

i5 8600k and asrock z370 pro4

 

I made a clean install with loader 1.04b used v0.13.3 for 6.2.3 by IG-88   and zImage, rd.gd files from the DSM_DS918+_25426.pat ... all 4 files.

 

After restarting on install process it loaded with DSM 6.2.3-25426 Update 3 directly. 

 

All good ... but is an ERROR:  

"System internal service [D-Bus, firewall:firewall_service_opt_bonjour, Quota helper daemon] failed to start.

Please contact Synology support for assistance."

 

SOLUTION ??

 

P.S.

-ls /dev/dri command responded ok (card0 renderD128)

-grep "MHz" /proc/cpuinfo command show all 6 cores

-cat /usr/syno/etc/codec/activation.conf command no good ... {"success":false,"msg":"SN format is wrong."}

 

 

Edited by mbarac
Link to post
Share on other sites

Good Morning,
still not quite clear with the installation.
Got a clean installation of version 6.2.3-25426-3.
If I want to have the new driver package now, is it enough to replace the two files extra.lzma and extra2.lzma on the boot stick, or does something else have to be done?

Greetings

Link to post
Share on other sites
On 4/17/2021 at 6:44 AM, Anatoly xVM said:

I've tried to reinstall DSM and create new usb-stick after last update (my mistake).

But cannot use last loader v 1.03b for 3617xs and other. Except v 1.02b.

It looks like usb-stick disconnects from system after initial starting of loading by system BIOS.

 

I've checked via COM-port. 

Really reason (more detail in attached log, tried loader v 1.04/1.03 (dsm 6.2.3), but beginning looks like the same but it loads successfully on v 1.02b):

Booting in blind mode
[    0.000000] CPU: vendor_id 'AuthenticAMD' unknown, using generic init.
[    0.000000] CPU: Your system may be unstable.
[    0.000000] NX (Execute Disable) protection: active
[    0.000000] CPU: 0 PID: 0 Comm: swapper Not tainted 3.10.105 #23739
[    0.000000]  ffffffff814c0c1f ffffffff818831a1 0000000000000001 0000000000000001
[    0.000000]  00000000364d7000 0000000001b29000 0000000000000bff fffffffefa71c000
[    0.000000]  0000000100000000 0000000000000000 0000000000000000 000000000000000e
[    0.000000] Call Trace:
[    0.000000]  [<ffffffff814c0c1f>] ? dump_stack+0xc/0x15
[    0.000000]  [<ffffffff818831a1>] ? early_idt_handler_common+0x81/0xa8
[    0.000000]  [<ffffffff818940b3>] ? efi_init+0x238/0x476
[    0.000000]  [<ffffffff818940a0>] ? efi_init+0x225/0x476
[    0.000000]  [<ffffffff81887091>] ? setup_arch+0x43d/0xc44
[    0.000000]  [<ffffffff814bff92>] ? printk+0x4a/0x52
[    0.000000]  [<ffffffff81883957>] ? start_kernel+0x7b/0x3b0
[    0.000000] RIP 0xfffffffefa71c000

 

die.txt

Link to post
Share on other sites
On 4/18/2021 at 9:55 AM, Mario0708 said:

If I want to have the new driver package now, is it enough to replace the two files extra.lzma and extra2.lzma on the boot stick

yes

 

38 minutes ago, Anatoly xVM said:

've checked via COM-port. 

Really reason (more detail in attached log, tried loader v 1.04/1.03 (dsm 6.2.3), but beginning looks like the same but it loads successfully on v 1.02b):

On 4/14/2021 at 8:19 AM, Anatoly xVM said:

AMD-8320E with MB Gygabite-970A-UD3P

...

RTL8118AS GbE

 

this hardware is ~2014 and piledriver, in theory it should/might work with 1.04b 918+ but i have a hp desktop amd on that cpu level and it does not so ...

1.03b should work, and my A8 does

with 1.04b it crashes when there is a message about unusable ram, try less like 8GB or 16GB

with 1.03b there is IDT in the errors, thats interupt hadler table

in generela check bios for any cpu realted settings

there a also kernel paramters you can add to grub so the synology kernel gets them when loaded like "disable_mtrr_trim"

you can look up that on the internet, that would be one possible source

http://redsymbol.net/linux-kernel-boot-parameters/

 

maybe there are parameters that fix your problem, or there are bios settings you can use (from the manual "Advanced CPU Core Features", first replex would be C1E disable as this is know to make problems on HPE microserver with AMD)

in bios periperals there is also iommu enable/disable, also worth a shot

you can also try to use esxi and see if a dsm vm does work

 

 

 

 

Link to post
Share on other sites
On 4/17/2021 at 1:05 AM, mbarac said:

All good ... but is an ERROR:  

"System internal service [D-Bus, firewall:firewall_service_opt_bonjour, Quota helper daemon] failed to start.

Please contact Synology support for assistance."

 

SOLUTION ??

 

does not ring a bell, never seen this, where do you se the error

/var/log/...

there might be indicators before that error that could be a clue

maybe try a different usb and disk to make sure its not storage realted, the cpu and board are pretty normal (also run memtest)

Link to post
Share on other sites
6 hours ago, IG-88 said:

there a also kernel paramters you can add to grub so the synology kernel gets them when loaded like "disable_mtrr_trim"

you can look up that on the internet, that would be one possible source

http://redsymbol.net/linux-kernel-boot-parameters/

 

Thank you for you explanations. 🤩

 

Disabled C1E (2 days ago)

Found and Disabled IOMMU (just now)

Removed RAM, my minimum 8GB

Doneset common_args_xxxx='disable_mtrr_trim ..." (in each test)

at 1st time tested With original extra.lzma and exteded extra.lzma in addition (there is no difference).

 

And no success at all.

 

Strange... Before this reinstall there was successful installation via v1.03b DSM 6.2.3-3 without any modifications. Just plugged in and it went on. 😇

Maybe this is my fate now to live with v 1.02b DSM 6.1.7.

 

die_disable_mtrr_trim_916plus.txt die_disable_mtrr_trim_3617xs.txt ok_boot_3615_v102.txt

Edited by Anatoly xVM
Link to post
Share on other sites
17 hours ago, Anatoly xVM said:

at 1st time tested With original extra.lzma and exteded extra.lzma in addition (there is no difference).

as to expect, the kernel crashes and the difference with the extended extra are drivers (that would be loaded after the kernel)

17 hours ago, Anatoly xVM said:

Strange... Before this reinstall there was successful installation via v1.03b DSM 6.2.3-3

there are two way to install 6.2.3

you can start with loader 1.03b as it comes (there is kernel 6.2.0 on the loader) so you basically start with dsm 6.2.0 when booting 1st time and when installing 6.2.3 *.pat file the kernel on the loader is updated to 6.2.3 and the next boot is with 6.2.3 (or would be if it does not boot you cant install 6.2.3)

2nd way would be to take zImage and rd.gz from 6.2.3 *.pat file and copy that to the loader (overwriting the 6.2.0 files) and the boot

its possible that it makes a difference

Link to post
Share on other sites
9 hours ago, Anatoly xVM said:

Sorry! 🤗 I've forgot one simple IMPORTANT rule - run booting of loader via BIOS/CSM non UEFI. 🤕

All working now. 🤩 6.2.3-3 - up and ready. 

on my systems on dont see a kernel crash when booting uefi with 3615/17 there is nothing on the serial console

at least it work now within expectations, 3615/17 should work with amd

Link to post
Share on other sites

Maybe amount of RAM is the reason (over 4GB)?

Anyway I have second PC (newer AMD, newer MB Gigabyte too) and something same is happen (cannot view console here).

CSM booting of Loader - fine, UEFI - it stucks like 1st case.

Link to post
Share on other sites
Posted (edited)
On 4/22/2021 at 6:00 AM, Anatoly xVM said:

Anyway I have second PC (newer AMD, newer MB Gigabyte too) and something same is happen (cannot view console here).

CSM booting of Loader - fine, UEFI - it stucks like 1st case.

 

is documented that 3615/17 loader 1.03b dont work with uefi

https://xpenology.com/forum/topic/13333-tutorialreference-6x-loaders-and-platforms/

 

the little snag here is that if the 3615/17 loader is in GPT that makes uefi boot possible in the 1st place even if its not woeking, and if you dont select the non-uefi boot device the csm mode will nor be used

the better solution might be to only offer then3615/17 in MBR version, MBR cant be used in uefi mode and CSM has to be used, kind of ride on rails that way, you you try a MBR loader with out CSM active you bios will tell you its not working this way and you will be steered to CSM mode

if CSM is not active you usually dont see the non-uefi boot device and even when activating CSM in bios you usually need to save and reboot to see the non-uefi boot device in the selection list ("older" often have csm on by default but newer system come with csm disabled or even dont have csm anymore)

Edited by IG-88
Link to post
Share on other sites

DS918+ failed to install the file. the file is probably corrupted. (13)

 

I just got a PowerEdge R430 and I’m trying to install DSM_DS918 it doesn't matter how I try to install it I get this error. I've confirmed the 16Gb SanDisk VID and PID.

Also, I’ve tried different USB thumb drives brand names.

Any help will greatly be appreciated

--------------------------------------------------------------------------------------------------------

Baremetal / Jun 1.04b DS918+ /

Tried: extra918plus_v0.13.3, extra918plus_v0.12.1

DSM_DS918+_23739.pat

DSM_DS918+_25426.pat

DSM6.2.3 and DSM6.2.3

--------------------------------------------------------------------------------------------------------

Dell PowerEdge R430 Specs

CPU: one  E5-2630L v3 @ 1.80GHz

RAM: 8GB

NIC: Broadcom Gigabit Ethernet BCM5720 4 ports 

RAID Controller: PERC H330 Mini (Embedded)

Tank you in advance to this matter!

Link to post
Share on other sites
22 hours ago, smartire said:

RAID Controller: PERC H330 Mini (Embedded)

not in IT-mode?

if you go into the controllers bios there can be IR mode or IT mode, if its IR (R like Raid) the it should be reflashed to IT mode

you can look for guides on the internet (and even youtube)

https://forums.servethehome.com/index.php?threads/flash-crossflash-dell-h330-raid-card-to-hba330-12gbps-hba-it-firmware.25498/

if you want to see disks in IR mode you would need to define a raid set in the controller, but thats not supported by native drivers and brings along other problems, dsm is made for single disks with software raid

 

did the "wrong vid/pid" do anything, like being able to install?

Link to post
Share on other sites

I have R420 running solid with DS3716, I'm not sure if you remember since you help a ton of people, but you helped get it working about a year ago.

 I have tried everything that I know but I was not able to install DS918+, since you said that the 4th gen would work, I'm thing in buy an E5-2630L v4 but they are pricy. 

Link to post
Share on other sites
16 minutes ago, smartire said:

since you said that the 4th gen would work, I'm thing in buy an E5-2630L v4 but they are pricy. 

it does, if it boots and you find it in network its working, if the cpu is not up to it you would not find it in network

if 918+ throws error 13 you can try with a wrong vid/pid, cant get worth  then error 13

but as you cpu does not have gpu there is nothing to gain with 918+, more likely you will have driver problems with the lsi sas controller (-> 1st post, warning about disk hibernation and broken raids)

3617 seem to be the best choice but 3615 woul work too, as the h330 has a older lsi sas chip it should work with 3615 too

 

in theory you could shutdown the r420, take its working usb and boot with it on the r430

before installing with it you should at least save the zImage and rd.gz because when installing the might be overwritten (when installing a newer version of dsm)

that way you know its not the usb (as its working on r420) and just so see if disks are found it should be enough to just boot it and look with the browser on the systems ip address

if its not booting at all or not found in network then check csm settings in bios and usb boot device (non-uefi to get csm mode booting, if you use the uefi usb boot device it will ignore csm mode as its just an option that gets chosen by selecting the right boot device)

Link to post
Share on other sites

The 918+ boots up detects all 4 network ports, gets the IP starts the installation and goes up to 56% and throws the error 13. I've tried to install on the CD-ROM adapter with a 2.5" SDD as well same error.

I have copies of the R420 USB working configuration since I had a hard time to get it working. But unfortunately when I try it on the R430 editing the VID/PID but it won't detect the disks, so I connect a CD-ROM adapter with a 2.5" SDD it detected I was able to install the DS3716, I was doping that after the installation it would detect the disk from the controller but did not. 

Link to post
Share on other sites
1 hour ago, smartire said:

The 918+ boots up detects all 4 network ports, gets the IP starts the installation and goes up to 56% and throws the error 13. I've tried to install on the CD-ROM adapter with a 2.5" SDD as well same error.

try this again but with a mismatch of vid/pid

 

 

1 hour ago, smartire said:

But unfortunately when I try it on the R430 editing the VID/PID but it won't detect the disks, so I connect a CD-ROM adapter with a 2.5" SDD it detected I was able to install the DS3716, I was doping that after the installation it would detect the disk from the controller but did not. 

 

can you copy the /var/log/dmesg from the ssd disk (booted with at least one other disk attached to the lsi sas)

 

 

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.