Пропал второй сетевой интерфейс


Recommended Posts

Вобщем проводил эксперименты с тимингом интерфейсов.

Собирал 2 интерфейса в разных режимах и тестировал нагрузку.

 

На этапе очередной разборки тима, после перезапуска пропал второй интерфейс. 

Кто подскажет куда копать и как поправить, буду благодарен.

Link to post
Share on other sites

Как в старом анекдоте: "Дедушка ковырялся вилкой в ушах, потом принес телевизор в ремонт с словами, что звука нет".

Версия DSM, железо (мать, сетевые адаптеры)?

Link to post
Share on other sites

Версия  DSM  - DS918+_24922

Железо Pentium G5400, 16Gb RAM, MB asrock z390m-itx/ac

Интерфейсы используются встроенные

- 1 x Giga PHY Intel® I219V, 1 x GigaLAN Intel® I211AT

 

DSM развернут на виртуалке VM WorkStation 15 Pro,  дополнительно применены патчи на транскодинг без ключа. 

Link to post
Share on other sites
10 минут назад, t4tune сказал:

DSM развернут на виртуалке VM WorkStation 15 Pro,

Ну если так, то удалите в виртуалке сетевухи и создайте снова, или проверьте, что настройки не слетели.

Link to post
Share on other sites

Это проверял, но не помогает. 

Проводил исследование вопроса - делал копию виртуалки и делал сброс настроек до дефолтных - интерфейс появляется. Т.е проблема именно где-то в настройках DSM,

Но вот поскольку не сильно шарю в линуксах - не понимаю, где именно копать.

 

Делать сброс на рабочем инстансе не хочется. т.к там настроено куча всякого, заново этим заниматься не очень охота

Link to post
Share on other sites

Попробовал следующую схему 

 

1. Клонировал виртуалку. Сделал сброс всех настроек в дефолт. Удалил все диски. Проблемы нет, видны два интерфейса.

2. Подключил диски в эту новую вирутуалку. Сделал миграцию

3. После миграции уже на новой виртуалке проблема повторяется. Т.е она зарыта где-то в системном разделе. Но вот где конкретно? )

Link to post
Share on other sites

Вобщем победил. Может кому-то пригодится

1. Воткнул отдельную сетевую. Пробросил ее в виртуалку.

2. В DSM собрал бонд из рабочего интерфейса и из нового в режиме балансировки (тот же режим что и когда предыдущий раз собирал с пропавшим интерфейсом)

3. После сборки, при просмотре свойств Бонда стало видно все три интерфейса. При разборке - опять два. Что делать?

4. Собираем бонд, переводим его в режим "Только резервирование". Сохраняем. Таким образом мы перезаписываем все настройки по каждому сетевому интерфейсу в ДСМ.

5. Снова разбираем бонд - и вуаля  - все три интерфейса видны!

 

 

Кстати мучал знакомого линуксовода, который админит крупную контору. Он поковырял-поковырял и сказал, что система отличает от знакомых ему дистрибов, типа надо курить , а доков по этому дистру он не нашел.  

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.