Sign in to follow this  
jackherer27

RDM Partition Failulre after DSM 4.3 to 5 migration

Recommended Posts

Hello,

 

I have a big problem.

I tried to migrate from DSM 4.3 to DSM 5 using gnoboot.

The result of migration is ok but I cannot access anymore to my data.

 

I have a Raid 1 volume with 2 3TB disks.

Each disk is mounted as RDM on ESXi.

After migration, the corresponding volume is marked as "crashed" in Syno GUI with no possibility to access.

SMART test on Syno GUI does not work.

 

It seems that partition had been corrupted during migration.

 

My questions :

- is there any way for me to repair my partition using console command line or Ubuntu virtual machine which is installed on ESXi ?

- is it possible to retrieve my data using another virtual machine ?

 

Thanks in advance for any help you would provide me.

Nicolas

Share this post


Link to post
Share on other sites

OK I solved my issue !

Fortunately !!!!!

 

What I performed :

- detach my 2 RDM disks from Xpenology VM

- attach and mount these 2 RDM disks to Ubuntu VM

- try several Unix command line tools (fdisk, e2fsck) : no success

- try testdisk tool : success

 

With testdisk I succeed in rebuilding one (not both) of my 2 RDM disk partitions.

All my data were present and intact !

 

 

As far as I saw, on RAID 1 volume, Synology creates 3 partitions :

- Linux boot

- Linux Swap

- Linux Data partition (the one I retrieved my data from)

 

Even now, I do not understand what I did wrong in my Xpenology update

One thing I am sure now, is that I will invest in one offline backup hard disk (and investigate as well for free storage on cloud like 2Tb at BAIDU) to prevent any problem like that.

 

Nicolas

Share this post


Link to post
Share on other sites
Sign in to follow this