dimem

DSM 5.0-4528 Wake On LAN

Recommended Posts

Hi,

 

I have successfully installed and worked WOL functionality on previous release DSM 5.0 4493 Update 7 but when I upgrade on version DSM 5.0-4528 WOL STOP to work. I have check all files like menu_nano.lst (for my MAC address and SN), menu_install.lst (SN), synoinfo.conf (eth0_wol_options="g" and wol_enabled_options="g" setings) and S99ZZZ_Shutdown.sh and ALL it's OK. Please help me to find the problem!

 

BR, dimem

Edited by Guest

Share this post


Link to post
Share on other sites

Is there are any suggestions what to do? Maybe new installation and recreate the WOL process?

Share this post


Link to post
Share on other sites

Should be

 

eth0_wol_options="g"

wol_enabled_options=""

 

Not

 

eth0_wol_options="g"

wol_enabled_options="g"

Share this post


Link to post
Share on other sites

Hello.

 

I'm trying this tutorial : http://www.xpenology.nl/wake-on-lan/

 

First of all, I've enabled Wake On Lan on my motherboard : http://www.asrock.com/mb/AMD/AM1H-ITX/

 

This is my MAC Address (on Synology Assistant and on router) : F0:50:59:2F:D4:1C

 

On Part 1 in menu_nano.lst (Nanoboot (5.0.3.2) DSM 5.0-4528) :

 

I've added only mac1, no other change

 

kernel /zImage ihd_num=0 netif_num=4 syno_hw_version=DS3612xs sn=B3J4N01003 mac1=F050592FD41C vid=0x0EA0 pid=0x2168 loglevel=0 vga=0x305

 

On part 2 point 9 :

 

With WinSCP (ssh some problem with vi) I've set in : etc/synoinfo.conf like this :

 

wol_enabled_options=""

eth0_wol_options="g"

 

After NAS restart the ' WOL 'status is now "WOL".

 

Now from Synology Assistant :

 

WOL -> Activate ... after 100% -> WOL Status : N/D

 

What I'm doing wrong?

Nas is shutdown but is normally connected to power line and ethernet cable. Do I need other?

 

Thanks!

Share this post


Link to post
Share on other sites

for nanoboot I dont believe you need the mac1= parameter in the menu_nano.lst file

 

nanoboot automatically finds the correct MAC Address (unlike older versions)

 

though you can change the netif_num=4 down to netif_num=1 if you only have one lan port

 

then

if you have edited both

 

/etc.defaults/synoinfo.conf

and

/etc/synoinfo.conf

 

files, with the correct "g" settings (make sure both are the same)

 

double check what MAC address the system is recognising

 

at a command prompt (SSH) run

 

dmesg | grep "eth"

 

should show something like

 

EX490-1> dmesg | grep "eth"
[    8.193093] b44: Unknown symbol phy_ethtool_sset (err 0)
[    8.193178] b44: Unknown symbol phy_ethtool_gset (err 0)
[    8.220657] r8169 0000:03:00.0: eth0: RTL8168c/8111c at 0xffffc900100fe000, 00:26:2d:01:f9:32, XID 1c4000c0 IRQ 44
[    8.220660] r8169 0000:03:00.0: eth0: jumbo features [frames: 6128 bytes, tx checksumming: ko]
[   14.472234] usbcore: registered new interface driver ethub
[   15.436686] r8169 0000:03:00.0: eth0: link down
[   15.436693] r8169 0000:03:00.0: eth0: link down
[   15.437154] ADDRCONF(NETDEV_UP): eth0: link is not ready
[   18.237214] r8169 0000:03:00.0: eth0: link up
[   18.237674] ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready

 

then your wake on lan application should work.

 

Be aware that wake on lan doesn't like to transverse wireless networks.( if your trying to wake the box from a phone etc)

 

.

Share this post


Link to post
Share on other sites

Hello.

 

I've changed netif_num=1 in menu_nano.lst file.

 

I've tryed two times with and without mac1 parameter.

 

Nothings happen. WOL status N/D at last.

 

I have edited both

/etc.defaults/synoinfo.conf and /etc/synoinfo.conf

 

files, with these settings :

eth0_wol_options="g"

wol_enabled_options=""

 

MAC address the system is recognising with ssh command dmesg | grep "eth" is the same I've setted

 

DiskStation> dmesg | grep "eth"
[    3.449861] b44: Unknown symbol phy_ethtool_sset (err 0)
[    3.449993] b44: Unknown symbol phy_ethtool_gset (err 0)
[    3.482366] r8169 0000:02:00.0: eth0: RTL8168b/8111b at 0xffffc9000007e000, f0:50:59:2f:d4:1c, XID 0c000880 IRQ 74
[    3.482370] r8169 0000:02:00.0: eth0: jumbo features [frames: 4080 bytes, tx checksumming: ko]
[   11.855726] usbcore: registered new interface driver ethub
[   13.186736] r8169 0000:02:00.0: eth0: link down
[   13.186770] r8169 0000:02:00.0: eth0: link down
[   13.187411] ADDRCONF(NETDEV_UP): eth0: link is not ready
[   14.768504] r8169 0000:02:00.0: eth0: link up
[   14.769184] ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
[   25.650069] [b]eth0: no IPv6 routers present[/b]

 

1) Last row is an error?!?

 

2) Sorry but I don't understand "Be aware that wake on lan doesn't like to transverse wireless networks.( if your trying to wake the box from a phone etc)"

 

Thanks

Share this post


Link to post
Share on other sites

hi stanza how would you know if wol works? you have almost similar hardware as me the ol trusty mediasmart. im on the synoinfo.conf and noticed a line missing for eth0..

I added the extra line: wol_enabled_options="" . the other lines show eth3_wol_options="d" i switched my eth0 to "g". I hope im on the right path

Share this post


Link to post
Share on other sites

If your BIOS / Lan card are enabled to allow WOL.

 

"Be aware that not all lan cards / computers can be awoken this way."

 

 

Then you can as above, change the settings manually to reflect a working setup eg changing "d" to "g" etc

 

To test shutdown your xpenology box and test if you can wake it back up by sending the "magic packet" to the mac address.

 

eg for me I use Linux, and I use a little program called gwakeonlan (you will have to source one that suits yourself and Operating System)

 

gwake.png

 

then I simply select which Xpenology to boot and press Turn On Button

 

gWakeOnLan.png

 

 

oh and djelusion, not sure about the ex490 having WOL or not.... I believe it does... but on mine I have change the BIOs settings around so much that I don't know what are the original settings anymore :roll:

Share this post


Link to post
Share on other sites

Hi,

I own an HP N54L with DSM 5.0-4528 X64 (update 2) and nanoboot 5.0.3.2. WOL doesn't work, is it a nanoboot bug? When the system is up&running, Syno Assistant recognises the WOL feature active on NAS, but it can't power it up.

Do you have any ideas?

 

Thx a lot

Share this post


Link to post
Share on other sites

I have a couple of N40L's and they both run DSM 5.0 4528/2 and WOL works fine using the Synology Assistant and a custom AutoIt script that wakes all the machines on the network.

 

Have you set everything up in accordance with the guide on xpenology.nl?

 

When you run the Synology Assistant the WOL option maybe greyed out so refresh to see it the option becomes available. Make sure the S99ZZZ_Shutdown script is installed and running.

Share this post


Link to post
Share on other sites