Recommended Posts

Hello fellow enthusiasts, I'm new to the forum, but not to XPenolgy. In this topic, I'd like to propose/discuss the repurposing of my old HTPC parts in an XPenology build.

 

The parts I'm planning to use are here on PCPartPicker: https://pcpartpicker.com/user/Netizen1/saved/#view=bFhmkL

 

(I'll list it out here, in case the link doesn't work)

 

  • ASRock AM1B-ITX Mini ITX AM1 Motherboard

  • AMD 5350 2.05 GHz Quad-Core Processor

  • Crucial Ballistix Sport 8 GB (2 x 4 GB) DDR3-1600 Memory

  • Various hard disks ♻️

 

I've read that people have had success with AMD builds before, so I'm going to try to start with the latest bootloader and see how that works.

 

Wish me luck!

Edited by Netizen1
Link to post
Share on other sites

Hello !

Can we have a review from your install?

I try to upgrade to 1.03b or 1.04b and i don't see the NAS on my network after installing the PAT file from syno assistant. (I tried on 3615/3617/918+)

 

I have the same configuration ( AMD 5350, AM1B-ITX)

 

Regards,

Link to post
Share on other sites

I think whether can discover on syno assistant or not depends on the NIC more than the CPU or the loader version

There were people succeeded on AMD builds before on both 3617 and 918 loaders

Try using 918+ 6.2.1 pat with 1.04b loader first, that's supposed to work easily

AFAIK there was a guy succeeded with 1.04b 918+ loader on a Ryzen machine, RTL8111 NIC

I guess your board has the same NIC too as most consumer boards use RTL8111

Worth trying

If not, try to use IG-88's driver mod

Link to post
Share on other sites

I tried without any driver pack, its why it didn't work. Curently its look fine on 3615xs , exept my admin credential don't work any more ...

I rescue my data from linux and i try again after that.

 

Link to post
Share on other sites

Finally I realized that the SHR was no longer available on 3615xs & 3617 !

 

I had no choice to install the 918+

 

I found the solution on this post :

 

During the PAT file install, it failed at 19% with IG-88 drivers. It's fine with x01015918 drivers.

 

I use the default netword adapter from AM1B-ITX ( Realtek RTL8111GR )

 

Thx !

 

Link to post
Share on other sites

Sorry for the lack of updates. It's been a hectic time with this virus!

 

I've been hitting my head against the desk wondering why I keep getting error 13 for every .pat file I tried. Just came across some info that basically said I wasn't using a good serial number.

 

My question now is, do I just use the S/N that comes in the synoboot.img I downloaded? Or is there another serial number generator for the 918+ lurking around somewhere?

Link to post
Share on other sites
On 3/24/2020 at 8:11 PM, deyko said:

Finally I realized that the SHR was no longer available on 3615xs & 3617 !

you did not read the faq ?

even in default state it will use a existing shr raid, the limitation is that you cant create a new shr, to do that you just need to change the synoinfo.conf and that limit is gone

 

 

On 3/21/2020 at 10:22 AM, deyko said:

I tried without any driver pack, its why it didn't work. Curently its look fine on 3615xs , exept my admin credential don't work any more ...

thats because you did use 6.2.2 pat file, if you use 6.2.(0) you would have been able to use it

6.2.2 needs new drivers (inside the file extra.lzma)

https://xpenology.com/forum/topic/21663-driver-extension-jun-103b104b-for-dsm622-for-3615xs-3617xs-918/

 

Edited by IG-88
Link to post
Share on other sites

It's been a few days of trying, and retrying. Still no dice. I keep getting error 13 in the Web Assistant.

 

I've tried extra918plus_v0.8_syno.zip, extra918plus_v0.8_std.zip and extra918plus_v0.8_recovery.zip

I've even tried the extra.lzma file from 

 

 

 

 

So I switched the the Synology Assistant, and I get a different error:

 

image.thumb.png.040cc66e2232e4fa46e3b6ab4b46ecd1.png

 

I'm really struggling here. I'll go back and do some more research tomorrow, but if anyone wants to offer any suggestions I would be grateful.

 

 

Link to post
Share on other sites
16 hours ago, Netizen1 said:

It's been a few days of trying, and retrying. Still no dice. I keep getting error 13 in the Web Assistant.

 

https://xpenology.com/forum/topic/7973-tutorial-installmigrate-dsm-52-to-61x-juns-loader/

Note 3: Please check you have the right VID/PID prior proceeding. If you get the following error ”Failed to install the file. The file is probably corrupted. (13)" it most certainly means your VID and/or PID is/are wrong. If you still have the same error message after verifying the VID/PID then try another USB drive.

 

as posiible alternative you can try to install on another system and then move usb and disk to your destination computer (already installed dsm on disk)

Link to post
Share on other sites
Posted (edited)

@IG-88 Thanks for the response.

 

I've tried another flash and got the same error. I'm now going over the process of retrying with each on the syno/std/recovery mods once more with the 2nd flash drive.

 

If this fails, I'm going to try going over my BIOS/EUFI settings to see if I missed anything.

Edited by Netizen1
Submitted too quickly
Link to post
Share on other sites

Hi together,

 

I'm having the same build and it's running fine on 6.1.7 and 3615 loader 1.02.

 

I was wanting to upgrade today, but I've also been without luck:

  • I tried 3615 loader 1.03 with and without additional drivers
  • I tried 918+ loader 1.04 with drivers recommended by @deyko and without additional drivers
  • I have tried 2 different 8GB flash drives and formatted a 1TB test drive before attempting to install 3615 or 918+
  • I checked PID/VID multiple times, they are 100% saved in the synoboot.img before flashing. I also added them later in the Grub console manually, to be sure.

I'm running into error code 13 on the webUI and error code 21 on the Assistant UI.

I'm giving up for today but I'll keep an eye on the thread. Hope someone finds a solution!

 

Cheers

Edited by maxxay
add error codes
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.