sliver

WOL DSM 5.0-4528

Recommended Posts

Hi,

 

 

I would like to activate WOL on my NAS Server ( i3-4150, Asrock B85M )

 

Is the following method ok? Found it in the forum

 

1. modify the /etc/synoinfo.conf wol_enabled_options=“” and eth0_wol_options="" to "g"

2. put the attached file ( from the forum ) to /usr/syno/etc/rc.d/ and give the file execuable permission.

Share this post


Link to post
Share on other sites

Thanks for your answer.

 

I also found a guide on your homepage.

 

Which should I choose?

 

Your guide is good, but I dont know where you should put the mac adress in the isolinux.cfg

 

And which mac adress? The mac you find in the dsm console, or the "real" adress which you can find with a live cd?

Share this post


Link to post
Share on other sites

You need to use the real mac address of the device otherwise the magic packet has no valid target to receive the broadcast.

 

You add the mac address after the sn xxxxxxxxxxx entry of the line in the form below (no spaces or colons etc.).

 

kernel /zImage ihd_num=0 netif_num=4 syno_hw_version=DS3612xs sn=B3J4XXXXXX mac1:xxxxxxxxxxxx vid=0x0EA0 pid=0x2168 loglevel=0 vga=0x305

 

In my experience not all WOL software/utils hits the mark for some reason? If you use the Synology assistant make sure you refresh the list by doing a new search if the "Wake Up" option for the server is greyed out. In the set-up enter the mac in this form xx:xx:xx:xx:xx:xx using the real mac address.

Share this post


Link to post
Share on other sites

Ok made now the following steps:

 

- put to file on the nas with the correct permissions

 

- changed synoinfo.conf according to your guide ( xpenology.nl )

 

- found the real mac adress

 

Now i restarted the NAS to try if wol works, but if you activate wol in the webinterface it wont let you save it.

 

I´m sure its because I didnt modify the isolinux.cfg, but I cant find it on the usb stick.

 

Do i have to take the nanoboot image, modify the isolinux.cfg and the upload it to the usb?

Share this post


Link to post
Share on other sites

So made now all 3 steps from your guide ( I had to search the menu_nano.ist )

 

But WOL is still not working.

 

So I checked all 3 steps again and realized that in the synoinfo.conf the value eth0_wol_options=d, but I cant change it to g

 

It wont let me change anything in the .conf, but I´m sure that I changed this.

Share this post


Link to post
Share on other sites