Sign in to follow this  
skodilak

Problem installing DSM to Nanoboot-5.0.2.4 DSM 5.0-4528 X86

Recommended Posts

Hello comunity,

 

I'm having problem installing DSM on a older ITX board. It's a Gigabyte board GA-C7V7-RH taken out of a thin client.

The onboard CPU is a VIA C7 and supports only 32-bit OS. The onboard hdd controler is VIA 8237R Plus.

For this case I used Nanoboot-5.0.2.4 DSM 5.0-4528 X86 which boots fine but ends with Execution error(I dont know if that is a problem).

 

After booting I start Synology Assistant and I see the device with status not inastalled.

I double click the device which takes me to the DSM instalation page. I tell the device to install X86 (DS214play) DSM 5.0-4528

which it does. After 2 reboots, first looks OK, second prior to reboot has trouble unmounting root and it never unmounts but reboots anyway,

I get a device with migratable status.

Strange thing is that after install I see on DSM instalation page that boot image is 5.0-4482 but synology assistant reports 5.0-4528.

 

I tried the same with 2 other Intel ITX boards D945GCLF2D and D945GSEJT with same results. I also tried it with ESXi,

result was the same status migratable.

On D945GCLF2D which is 64-bit capable I used 64-bit version and it worked like a charm so I think HW is OK.

 

Any ideas?

 

Best regards

Share this post


Link to post
Share on other sites

Hello,

 

Thank you for your suggestion. I tried it out and found out that e1000 module isn't the problem because it gets loaded automatically. The problem is in the HDD controller. When I selected IDE in ESXi it installed and started OK. I also tried it on D954GSEJT board with IDE disk and it also installed OK.

 

So I guess the problem are drivers for the SATA . Is there a way to fix this?

 

Best regards

Share this post


Link to post
Share on other sites
Sign in to follow this