djelusion

unable to update to synology 5.0 4528 from 4493

Recommended Posts

hey all so I recently tried to upgrade / update my nas to the 5.0 4528.

 

Did the following.

 

used the following images.

 

1) Nanoboot-5.0.3.2 DSM 5.0-4528 X64 (Since my old version was nanoboot 4493 im sticking with that)

 

2) then the pat file used http://global.download.synology.com/download/DSM/5.0/4528/DSM_DS3612xs_4528.pat

 

3) win32 imager to create the usb key.

 

4) Powered down nas,

 

5) inserted usb key into nas

 

6) ran into installation problems due to the lst files not being edited so...

 

7) edited menu_nano.lst file & menu_install.lst

 

8) tried both migrate & clean install.

 

9) stuck at the lost configuration screen after i power down the nas.

 

10) no clue or what to do next in terms of getting my nas up and running. I cannot see whats on the screen since there is no vga cable or port on my nas.. so I can only guess its serial # related?. or a file im not editing right?. help hints suggestions

 

thanks

Share this post


Link to post
Share on other sites

so as odd as it is.. I gave up on the update and decided to use the old usb key and live with an out of date shellshockable version of xpenology.

 

To my surprise using the old usb key i could not get into my system,

 

before i started to cry. low and behold it was upgraded to 4528 and looks like everything is there except for the data and volumes so as of now i got the prompt to update to update 1. i did and rebooting and then we will attempt to repair my volumes and config.

Share this post


Link to post
Share on other sites
hey all so I recently tried to upgrade / update my nas to the 5.0 4528.

 

Did the following.

 

used the following images.

 

 

 

7) edited menu_nano.lst file & menu_install.lst

 

 

 

Don't know if it helps but I also edited debug.lst too

Share this post


Link to post
Share on other sites

thanks manfriday, I didnt edit the debug.lst as I didnt know what to put. It seems like it had already updated but I have no explanation why everything is working minus the data integrity being rebuilt. and im using the original usb key that contains 4493 and its booting to 4528!. Im just glad to have my data back!!! now I seriously want to have a backup system incase one is un recoverable. these dsm upgrades are a pain and the more we rely on the dsm it can go south really quick.

Share this post


Link to post
Share on other sites

Not sure it helps now but...

 

Did you select the correct menu options during your initial 'boot' from the new USB stick? You have to manually select the 'upgrade' option on one of the boot menus the first time. Thereafter accepting the default (letting it timeout) is fine...

Share this post


Link to post
Share on other sites