VMM Reserving 80% of RAM unable to create VM


Recommended Posts

Not sure what the issue is.  Every time I try to create a VM, VMM puts in reserve 80% of my ram (10gb total) leaving me with less than 2gb (yes i know it should be exactly, but im assuming that system itself is taking up at lease 512mb as well) Which of course leaves me not able to create a VM of any kind.  Please, any help would be appreciate it.

VM Reserve.jpg

Link to post
Share on other sites
6 часов назад, Dvalin21 сказал:

VMM puts in reserve 80% of my ram (10gb total) leaving me with less than 2gb

Not VMM reserves 80% of the memory, it is the memory used by all applications on your DSM. You can see the distribution for each package in the Resource Monitor

Скрытый текст

354617743_.thumb.png.453d841b872ae25c525fbd4f5fb4c9a7.png

 

Link to post
Share on other sites
  • 1 month later...

I'm having the same issue. Even with the VMM uninstalled:

memory.thumb.png.f865bb1af8bb98b2a95947fe2ab40b98.png

This makes the server start swapping and reporting only 3392 avaliable of ram instead of 7xxx

 $free -m
              total        used        free      shared  buff/cache   available
Mem:           3392        1750         211           7        1429        1357
Swap:          4083        1449        2633

Any solution?

Link to post
Share on other sites

I fixed the problem  RESERVED MEMORY 4.7 GB on N54L

 

$ dmesg |grep RAM
[    0.000000] e820: BIOS-provided physical RAM map:
[    0.000000] WARNING: BIOS bug: CPU MTRRs don't cover all of memory, losing 4608MB of RAM.
[    0.000000] e820: modified physical RAM map:

Thanks to "MTRR" error got this sorted out:  

You have to disable mtrr trim, by adding the argument disable_mtrr_trim on grub.cfg

 

1514865904_Screenshot2020-04-0623_14_21.thumb.png.2c4f714ef144e32a40e74655cb60a1f9.png

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.