ma160802

HP n54l esata port coming up as disk 5 in storage manager?

Recommended Posts

Hi is there a way to remove the esata port from showing as disk 5 under DSM 5.0 disk manager , I've recently added a 5th drive in the cd rom bay using the on board spare sata port but its coming up as drive 6. I figured out that the 5th drive slot is reserved for the external esata port , when I plug in a esata external drive it comes up as disk 5.

Untitled.gif.e76f7598fd4551ceee2adc5022b86066.gif

Share this post


Link to post
Share on other sites

You'll need to edit /etc.defaults/synoinfo.conf & set the value of esataportcfg as shown below.

 

esataportcfg="0x0"

 

Save the file & then reboot.

Share this post


Link to post
Share on other sites

the original value in /etc.defaults/synoinfo.conf was set to esataportcfg="0xff000" ,which I changed to esataportcfg="0x0" and after the rebooted I did not see any change . Its doing the same think I even plugged in the external esata drive and its coming up as drive five in storage manager. Is there anything else you can think of?

Share this post


Link to post
Share on other sites

Try adding the following & rebooting again.

 

internalportcfg="0xfffff"

Share this post


Link to post
Share on other sites

Ive just noted that under AHCI setting in bios that port 4 is also is not picking up a hard drive its skipping the port . is this normal ? Im running a mod bios.

ahci.gif.89a4a7955d267d2995be89a2cba7ed83.gif

Share this post


Link to post
Share on other sites

I''ve reflashed the bios with the latest version (10.01.2013) but the bios is still reserving port 4 for the external esata , is this normal?

Share this post


Link to post
Share on other sites
I''ve reflashed the bios with the latest version (10.01.2013) but the bios is still reserving port 4 for the external esata , is this normal?

Yes.

Share this post


Link to post
Share on other sites

ok thx , is there a way to change this within dsm so that it doesn't reserve the port in disk manager for the external esata port?

Share this post


Link to post
Share on other sites
ok thx , is there a way to change this within dsm so that it doesn't reserve the port in disk manager for the external esata port?

Why is matter? It is a pure cosmetic issue and have no performance or functionality penalty.

HP Microserver designers have chosen to use this port numbering, so be it.

Share this post


Link to post
Share on other sites