Olegin

Транскодирование без номерка

Recommended Posts

У кого нет валидного номерка и не воспроизводится видео в Photo и Videostation пробуем патч из буржуйской ветки

 

  • Like 1

Share this post


Link to post
Share on other sites

Этот патч применим к работоспособности QuickConnect или только для заявленных функций ?

Share this post


Link to post
Share on other sites

Ребят, а не подскажите, почему так мало кодеков может быть активно? 

/dev/dri каталог есть, и там 2 файла в нём.

 

После команды cat /usr/syno/etc/codec/activation.conf

вижу что мало активных кодеков, у уважаемого комрада в английской ветке на много больше. 

 

Но почему-то пишет мало активных кодеков, и много чего не воспроспроизводится(в основном пишет не правильная аудио дорожка). 

 

Снимок.JPG

 

 i3-8100 / ASRock H370M-ITX/AC / 8GB / 918+ DSM 6.2.2 U5 

серийник и мак верные, QC работает. 

Edited by bboott

Share this post


Link to post
Share on other sites

Нет, сейчас поищу что за пакет, и как установить :)

 

UPD

 

Вот пакет установил, ничего не изменилось, перезагрузил нас, посмотрел - пакет стоит, ввёл заново команду, и всё равно мало активных кодеков

ffmpeg package is installed (version 4.2.1-23) from SynoCommunity

 

132451736_.JPG.a9ddc9c4ac285d0faf3ed83e096dc5bb.JPG

 

Edited by bboott

Share this post


Link to post
Share on other sites
5 hours ago, bboott said:

Но почему-то пишет мало активных кодеков, и много чего не воспроспроизводится(в основном пишет не правильная аудио дорожка

А командой пробовали активировать кодеки? 

Share this post


Link to post
Share on other sites
2 минуты назад, TeleDDim сказал:

А командой пробовали активировать кодеки? 

не пробовал, а не подскажите что за команда?

Share this post


Link to post
Share on other sites

Как то так по моему, на форуме где то точно есть:

synocodectool --activate_codec mpeg4part2_dec --pkgname mediaserver

Share this post


Link to post
Share on other sites

Тоже ничего не поменялось, всё также активны 4 кодека.

Share this post


Link to post
Share on other sites
3 минуты назад, TeleDDim сказал:

Из под рута команду выполняли?

Да, всё с под рута, даже ребутнул и перепроверил. 

 

Сниуууумок.JPG

 

Edited by bboott

Share this post


Link to post
Share on other sites
В 03.02.2020 в 22:44, TeleDDim сказал:

Как то так по моему, на форуме где то точно есть:

synocodectool --activate_codec mpeg4part2_dec --pkgname mediaserver

Т.к. это команда толку не давала, попробовал изменить чуть команду на 

synocodectool --activate_codec mpeg4part2_dec --pkgname videostation

И добавился 1 кодек, ну всё равно кодеков меньше, чем должно быть.

 

Снимок22.JPG

 

 

 

 

UPD

 

Попробовал команды 

 

synocodectool --activate_codec aac_dec --pkgname mediaserver
synocodectool --activate_codec aac_enc --pkgname mediaserver
synocodectool --activate_codec vc1_dec --pkgname mediaserver
synocodectool --activate_codec vc1_enc --pkgname mediaserver

После данных команд, все кодеки стали активны. 

 

Снимо3333к.JPG

 

 

 Собственно вопрос, правильный ли это вывод команды, при работающем железном, и софтовом транскодинге?

 

cat /sys/kernel/debug/dri/0/i915_frequency_info
Password: 
Video Turbo Mode: yes
HW control enabled: yes
SW control enabled: no
.........

 

?

 

Edited by bboott
  • Thanks 1

Share this post


Link to post
Share on other sites

Изменил SN на флешке, применил патч. На удивление транскодинг работает )

Можно как-то научить Video station проигрывать фильмы со звуковыми дорожками DTS, DTS-HD, Dolby TrueHD? А то в поддержке похоже только самый простой Dolby Digital (AC-3)...

Share this post


Link to post
Share on other sites
8 часов назад, Rezdbic сказал:

Можно как-то научить Video station проигрывать фильмы со звуковыми дорожками DTS, DTS-HD, Dolby TrueHD?

Поставить пакет ffmpeg из http://packages.synocommunity.com

  • Thanks 1

Share this post


Link to post
Share on other sites
Posted (edited)

Судя по всему проца i5-3470 будет маловато для софтового транскодинга... или я до конца не понял как это должно работать )

Пробовал включать bdremux на мобилке через сотовую связь (чисто для эксперимента), загрузка проца на dsm улетела в около 100% и долго там оставалась. Соответственно никакого фильма я так и не увидел ((

Edited by Rezdbic

Share this post


Link to post
Share on other sites

Ребят, кому нужно активировать дополнительные кодеки на xpenology, можете заменить кодер по следующей инструкции. Только установка FFMPEG не помогает решить проблему. У меня после применения патча транскодируется любая аудиодорожка железно. 

 

Ссылка на патч: https://gist.github.com/BenjaminPoncet/bbef9edc1d0800528813e75c1669e57e

 

Инструкция в 1 комментарии

Share this post


Link to post
Share on other sites
Posted (edited)
В 23.05.2020 в 02:45, Keypad74 сказал:

Ребят, кому нужно активировать дополнительные кодеки на xpenology, можете заменить кодер по следующей инструкции. Только установка FFMPEG не помогает решить проблему. У меня после применения патча транскодируется любая аудиодорожка железно. 

Спасибо! Можно коротенькую инструкцию на русском, а то на буржуйском, буковки вижу, а смысл ускользает...

patch установил, пришлось запустить

CODEC=/usr/syno/bin/synocodectool
CODECBACKUP=/usr/syno/bin/synocodectool.bkp
CONF=/usr/syno/etc/codec/activation.conf
CONFBACKUP=/usr/syno/etc/codec/activation..old.conf
CONFDIR=/usr/syno/etc/codec/

кодеки появились

cat /usr/syno/etc/codec/activation.conf
{"success":true,"activated_codec":["hevc_dec","ac3_dec","h264_dec","h264_enc","aac_dec","aac_enc","mpeg4part2_dec","vc1_dec","vc1_enc"],"token":"123456789987654abc"}

Но при попытки воспроизвести видео крутиться колечко бесконечно долго. Что делаю не так?

Edited by JonyBest

Share this post


Link to post
Share on other sites

При первом запуске он спрашивает что нужно патчить. Вроде как для videostation и для photostation пути разные. Вы чем пользуетесь?

Share this post


Link to post
Share on other sites
В 07.06.2020 в 20:51, JonyBest сказал:

......

кодеки появились


cat /usr/syno/etc/codec/activation.conf
{"success":true,"activated_codec":["hevc_dec","ac3_dec","h264_dec","h264_enc","aac_dec","aac_enc","mpeg4part2_dec","vc1_dec","vc1_enc"],"token":"123456789987654abc"}

Но при попытки воспроизвести видео крутиться колечко бесконечно долго. Что делаю не так?

победили? у меня тоже самое.

 

 i3-9100 / ASRock H310cm-hdv / 8GB / 918+ DSM 6.2.3-25426

 QC работает (в акк не вошел).

Share this post


Link to post
Share on other sites
В 15.06.2020 в 10:22, hellion сказал:

При первом запуске он спрашивает что нужно патчить. Вроде как для videostation и для photostation пути разные.

Патчил оба пункта  videostation и photostation 

35 минут назад, Pit0n сказал:

победили? у меня тоже самое.

нет, не победил. Решения так и не нашел...

Share this post


Link to post
Share on other sites

Ребят, то, что я писал, делается вручную. Подключаетесь по SSH к своему хранилищу, логинитесь под собой, а дальше вводите по команде из списка. Никакие патчи не нужно применять. И эта инструкция нужна для активации звуковых дорожек в Videostation, таких, как DTS, EAAC и TRUE HD. 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.