Recommended Posts

Hmn.... but the volume on my DSM51 _IS_ SHR!.... so it _is_ supported!. My 4 md devices are also built from /dev/sdX. I'm just going to try a test, I'll att another 4 disks to the VM and see if they are detected, and what kind of volume it creates. biab

Link to post
Share on other sites
Hmn.... but the volume on my DSM51 _IS_ SHR!.... so it _is_ supported!. My 4 md devices are also built from /dev/sdX. I'm just going to try a test, I'll att another 4 disks to the VM and see if they are detected, and what kind of volume it creates. biab

 

I have re-install my Virtual Box to 4933.

And, I have deleted the original volume (not SHR), and created a new SHR.

 

It's my mdstat: (seems to be synced already)

Personalities : [linear] [raid0] [raid1] [raid10] [raid6] [raid5] [raid4] 
md2 : active raid1 sda5[0]
     5750208 blocks super 1.2 [1/1] [u]

md1 : active raid1 sda2[0]
     2097088 blocks [12/1] [u___________]

md0 : active raid1 sda1[0]
     2490176 blocks [12/1] [u___________]

unused devices: 

 

It's my df:

Filesystem           1K-blocks      Used Available Use% Mounted on
/dev/md0               2451064    570120   1778544  24% /
/tmp                    253628       312    253316   0% /tmp
/dev/vg1000/lv         5656336    195236   5358700   4% /volume1

 

It's the /proc/partitions:

major minor  #blocks  name

  8        0   10485760 sda
  8        1    2490240 sda1
  8        2    2097152 sda2
  8        3          1 sda3
  8        5    5751248 sda5
  9        0    2490176 md0
  9        1    2097088 md1
  9        2    5750208 md2
253        0    5746688 dm-0

 

I dont think it's the un-synced problem. :sad:

I will give it a try again with this DSM 4493 and a SHR.

Wait for my test result.

Link to post
Share on other sites

The test result is the same...

 

After install 4977, df:

Filesystem           1K-blocks      Used Available Use% Mounted on
/dev/md0               2451064    610628   1738036  26% /
/tmp                    253628       144    253484   0% /tmp
/run                    253628      1152    252476   0% /run
/dev/shm                253628         0    253628   0% /dev/shm
/dev/vg1000/lv         5656336    195236   5358700   4% /volume1

 

mdstat:

Personalities : [linear] [raid0] [raid1] [raid10] [raid6] [raid5] [raid4] 
md2 : active raid1 sda5[0]
     5750208 blocks super 1.2 [1/1] [u]

md1 : active raid1 sda2[0]
     2097088 blocks [12/1] [u___________]

md0 : active raid1 sda1[0]
     2490176 blocks [12/1] [u___________]

 

First time reboot, df:

Filesystem           1K-blocks      Used Available Use% Mounted on
/dev/md0               2451064    610628   1738036  26% /
/tmp                    253628       144    253484   0% /tmp
/run                    253628      1152    252476   0% /run
/dev/shm                253628         0    253628   0% /dev/shm

 

mdstat:

Personalities : [linear] [raid0] [raid1] [raid10] [raid6] [raid5] [raid4] 
md1 : active raid1 sda2[0]
     2097088 blocks [12/1] [u___________]

md0 : active raid1 sda1[0]
     2490176 blocks [12/1] [u___________]

unused devices: 

 

md2 is gone. Volume is gone. All /dev/sd* are gone...

There is no disk in Storage Manage for me to create volume.

Link to post
Share on other sites

Chege,

This is a red herring - What the release notes say is:

 

18.Storage Manager (for RS10613xs+, RS3413xs+, RS3614xs, RS3614RPxs, RS3614xs+ only)

•You can now create volumes up to 200 TB large.

•You can create RAID groups and RAID arrays. A RAID Group for Multiple Volumes or iSCSI LUNs (Block-Level) that use RAID 5 or RAID 6 may contain multiple RAID Arrays.

•Synology Hybrid RAID is no longer supported

 

 

As I read it SHR is supported EXCEPT FOR the models listed.

 

With my 3612xs VM I can add disks to the existing SHR, and also create a new seperate volume with RAID.

 

Looking at the release notes I notice that the "Storage Analyzer" is not there on my VM, was the storage analyzer dropped between 4977 and 4977 U1, or did something go wrong during my installation?

 

Andrew

Link to post
Share on other sites

Looking at the release notes I notice that the "Storage Analyzer" is not there on my VM, was the storage analyzer dropped between 4977 and 4977 U1, or did something go wrong during my installation?

Something goes wrong, cause i still have Storage Analyzer on DSM5.1 update 1.

 

Can You upload somewhere upload exported VM in ovf (not ova) format? Maybe its something with VM configuration? W/o hard drives off course :wink:

Link to post
Share on other sites

"

<?xml version="1.0"?>

List of the virtual disks used in the package

Logical networks used in the package

Logical network used by this appliance.

A virtual machine

The kind of installed guest operating system

Other_64

Linux_64

Virtual hardware requirements for a virtual machine

Virtual Hardware Family

0

DEVDSM51

virtualbox-2.2

1 virtual CPU

Number of virtual CPUs

1 virtual CPU

1

3

1

MegaBytes

2048 MB of memory

Memory Size

2048 MB of memory

2

4

2048

0

ideController0

IDE Controller

ideController0

3

PIIX3

5

1

ideController1

IDE Controller

ideController1

4

PIIX3

5

0

sataController0

SATA Controller

sataController0

5

AHCI

20

0

usb

USB Controller

usb

6

23

3

false

sound

Sound Card

sound

7

ensoniq1371

35

0

disk1

Disk Image

disk1

/disk/vmdisk1

8

5

17

1

disk2

Disk Image

disk2

/disk/vmdisk2

9

5

17

2

disk3

Disk Image

disk3

/disk/vmdisk3

10

5

17

3

disk4

Disk Image

disk4

/disk/vmdisk4

11

5

17

true

Ethernet adapter on 'Bridged'

Bridged

Ethernet adapter on 'Bridged'

12

E1000

10

Complete VirtualBox machine configuration in VirtualBox format

"

Link to post
Share on other sites
i figured out the same. in DSM5.0 raid is build on sdX and under DSM5.1 on hdX. i think its related with that:
Synology Hybrid RAID is no longer supported.
its from DSM5.1 release notes. in my case the problem is that after using this procedure cat /proc/mdstat is showing that that md0 and md1 are build on sdX and i dont know how to change it or just delete md0 and md1 manually.

 

Only thing is that the "Synology Hybrid RAID is no longer supported" remark in the release notes are ONLY for these systems. Also in the release notes:

 

Storage Manager (for RS10613xs+, RS3413xs+, RS3614xs, RS3614RPxs, RS3614xs+ only)

-You can now create volumes up to 200 TB large.

-You can create RAID groups and RAID arrays. A RAID Group for Multiple Volumes or iSCSI LUNs (Block-Level) that use RAID 5 or RAID 6 may contain multiple RAID Arrays.

-Synology Hybrid RAID is no longer supported.

 

Full release notes:

https://www.synology.com/en-global/support/beta_dsm_5_1

Link to post
Share on other sites

My bad, i missed that its only about those systems. But i found hack for myself to run VM with DSM5.1 and installed volumes even when system dont see hard disks. only thing i am struggling with atm is that package manager cant connect to internet or there are no packages for DSM5.1-beta. Its not the cleanest way and i still testing it:

 

1. install DSM5.0

2. create volume for installing CMS

3. install CMS and add this server to it

4. create cluster volume (required at least 3 drives for raid5)

5. install DSM5.1-beta

 

ps dont turn off CMS when DSM5.1 is up and running cause it will break volumes

 

 

EDIT restarting VM also break volumes, they disappeared

Link to post
Share on other sites
And the wierd thing is, if you do sfdisk -M /dev/hdx it replies "hdX already is DOS" or words to that effect.

I still think the problem is a latency issue with the md not being ready by the time the GUI tries to write to them.

 

Hi Andrew,

 

Can you provide your method about how you make sure md is ready?

From my post before, I think my md is ready already after install 4977.

However, the problem hinders me now is that, after the first time reboot, md and volume is gone.

There is no way to create volume in GUI because there is no disk in Storage Manager.

Could you provide some screen shots for us? I really hope that I can run DSM 5.1 on my Virtaul Box.

Thank you very much!

Link to post
Share on other sites

I used the procedure as quoted above and managed to get dsm51 with volumes twice, in the meantime I can't repeat those results (not sure why - I am working on it)

 

As to checking the status of the raid:

cat /proc/mdstat

Should show md0, md1, md2 (possibly md3) with no messages about rebuilding or resyncing.

 

raidtool status 0

raidtool status 1

raidtool status 2

raidtool status 3

should show status normal, rebuilding none.

 

I am not certain, but I think the missing volume, invisible disks issue is related to apparmor, but I am not certain. md0 and md1 survive the upgrade so it isn't some driver problem that breaks raid completely.

 

Andrew

Link to post
Share on other sites
  • 2 weeks later...
  • 2 months later...

I've been following this thread for a while now and I want to thank everyone involved for the effort they've put in.

I'm probably moving away from xpenology exactly because of this. I knew the one big risk and used it anyway. It's just not worth waiting while there are known security holes that need patching IMO.

 

I just don't understand why Synology doesn't release proper sources. Aren't they required to? It's not like people buy Synology hardware because they can mess around with it. They buy it because it just works.

 

Anyway good luck!

Link to post
Share on other sites
Guys, Syno just uploaded some 5.1 tools sources on their SourceForge repository.

Might help win this task.

 

 

Sent from my iPhone using Tapatalk

 

The tools sources does not matter! You only need some custom gcc toolchain, if you have some sort of obscure CPU architecture. For the Intel or AMD x86/AMD64 instruction set which all most every XPenology build uses, we do not depend on these toolchains. You can compile and build the kernel with a standard gcc toolchain using if necessary cross compilation for x64 on a x86 machine or something similar. Thats no magic at all :wink:

Link to post
Share on other sites

---Cross Thread Post---

 

A DSM 5.1 boot image is under heavy development behind closed doors with a team of contributors (sancome included). We have had great success and are in the process of working out the last few bugs. Try to be patient and wait for a release announcement.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.