Agent-Orange

Hardware migration-> Neues MB & CPU

Recommended Posts

Hallo

Ich bin gerade daran, mein "NAS" weiter auszubauen. Derzeit habe ich ein auf Intel basiertes NAS (i6700K) in einem UNAS-800 Case. Ich verwenden deinen IBM SAS controller woran 8x8TB angeschlossen und mit DSM zu einem RAID verbunden sind. Dazu kommt noch eine SSD sowie eine M2.SSD welche direkt am Mainboard angeschlossen sind

Jetzt konnte ich günstig neue HW beziehen unter anderem ein AMD TR1950x sowie ein Asus X399 Zenith Extreme. Dazu noch ein Case mit 16 Bays. Der SAS-Controller wird übernommen. Das Mainboard hat einen I211 Netzwerkcontroller, der Treiber dafür ist ein scheinbar im Loader drin.

Jedenfalls möchte ich nun die Migration planen und möchte vorher sicher gehen, dass ich nichts vergesse oder falsch mache. Meine Frage ist nun, spielt die Reihenfolge der Festplatten eine Rolle für das Synology bzw. für DSM? Oder spielt es in diesem Fall keine Rolle, weil alle am gleichen SAS-Controller angeschlossen bleiben?

Wie ihr auf dem attachment seht, ist die Reihenfolge der Platten etwas speziell, keine Ahnung wieso DSM diese so anordnet.

Kann der Umstieg von Intel auf AMD noch Probleme verursachen oder ist das DSM egal?

Bin dankbar für jeden Tipp.

 

Gruss

speichermanager.PNG

Share this post


Link to post
Share on other sites
6 hours ago, Agent-Orange said:

AMD TR1950x sowie ein Asus X399 Zenith Extreme

 

die cpu hat 16 cores, da musst du 3617 nehmen (bzw. beim umstellen "migrieren")

3615 unterstützt nur 8 cores

https://xpenology.com/forum/topic/24377-dell-r520/

 

solltest du 918+ wegen m.2 in betracht gezogen haben dann wird das nichts, da verlierst du die hälfte der cores die dann nicht benutzt werden

 

 

6 hours ago, Agent-Orange said:

Dazu noch ein Case mit 16 Bays. Der SAS-Controller wird übernommen

 

6 ports auf dem board + 8 vom controller -> das sind mehr als die 12 drives die 3615 und 1617 ootb mit juns loader unterstützen

da musst du die synoinfo.conf von hand anpassen und bei einem großen update (200-250MB *.pat file) geht diese änderung verloren und die kiste fährt wieder mit dem drfault von 12 hoch - was dann je nach konfig die redundanz frives kickt (rebuild notwendig) oder das ganze raid geht nicht weil unvollständig

witzigerweise ist letzteres eigentlich besser, wenn man das problem behebt und alle drives wieder da sind muss nichts mit rebuild behoben werden

bei einem 14 drive raid6 dem 2 fehlen started das raid, ist lauffähig man damit haben dann die 12 laufwerke einen anderen stand als die 2 die (noch) nicht verfügbar waren, passt man die synoinfo.conf  wieder an und die laufwerke erscheinen wieder sind sie nicht mehr in sync and müssen neu erzeugt werden (was 1-2 tage dauern kann)

 

 

7 hours ago, Agent-Orange said:

Kann der Umstieg von Intel auf AMD noch Probleme verursachen oder ist das DSM egal?

 

es gibt im synology kernel keinen amd support da sie nur intel bei den x86 boxen einsetzen, aber an sich geht es, ryzen cpus wurden hier auch schon benutzt und meine test/build umgebung läuft auf einem ryzen in virtualbox

 

 

 

 

Share this post


Link to post
Share on other sites
10 hours ago, IG-88 said:

solltest du 918+ wegen m.2 in betracht gezogen haben dann wird das nichts, da verlierst du die hälfte der cores die dann nicht benutzt werden

 

 

hmm,

 

wie viele Cores / Threads kann die 918+ denn max. nutzen ?

Share this post


Link to post
Share on other sites

Wozu eigentlich so ein setup für ein NAS ?

Da macht am Ende ein ESXi doch mehr Sinn. Da dann Xpenology als VM laufen lassen...

Share this post


Link to post
Share on other sites
6 hours ago, ooooooh said:

das heißt,  dass wenn man einen i7 8700 nutzrn wollte, 3617 mit 1.03 nehnen müsste...

 

eigentlich schon, ich weiß nicht ob linux erst mal alle echten cores nimmt and dann hat aber falls nicht wird die performance deutlich gedrückt (4 core + 4 ht) da könnte man gegentesten wenn man ht abstellt, dann rechen nur noch 6 echte cores

aber wenn man man alles an cpu power mitnehmen will sollte es dann schon 3617 sein

  • Like 1

Share this post


Link to post
Share on other sites
22 hours ago, IG-88 said:

 

die cpu hat 16 cores, da musst du 3617 nehmen (bzw. beim umstellen "migrieren")

3615 unterstützt nur 8 cores

https://xpenology.com/forum/topic/24377-dell-r520/

 

solltest du 918+ wegen m.2 in betracht gezogen haben dann wird das nichts, da verlierst du die hälfte der cores die dann nicht benutzt werden

 

 

 

6 ports auf dem board + 8 vom controller -> das sind mehr als die 12 drives die 3615 und 1617 ootb mit juns loader unterstützen

da musst du die synoinfo.conf von hand anpassen und bei einem großen update (200-250MB *.pat file) geht diese änderung verloren und die kiste fährt wieder mit dem drfault von 12 hoch - was dann je nach konfig die redundanz frives kickt (rebuild notwendig) oder das ganze raid geht nicht weil unvollständig

witzigerweise ist letzteres eigentlich besser, wenn man das problem behebt und alle drives wieder da sind muss nichts mit rebuild behoben werden

bei einem 14 drive raid6 dem 2 fehlen started das raid, ist lauffähig man damit haben dann die 12 laufwerke einen anderen stand als die 2 die (noch) nicht verfügbar waren, passt man die synoinfo.conf  wieder an und die laufwerke erscheinen wieder sind sie nicht mehr in sync and müssen neu erzeugt werden (was 1-2 tage dauern kann)

 

 

 

 

 

die synoinfo.conf ist in der ISO drin oder? Vorerst wäre es noch kein Problem, ich nur die 8 HDD sowie die SSD drin lassen würde. Die M2.SSD schmeiss ich raus, die habe ich sowieso nicht gebraucht. Es kommt zwar noch ein zweiter 8-Port SAS-Controller rein, aber bis ich dort neue Platten anschliesse, dauerts noch ein weilchen.


Aber das heisst prinzipiell spielt es keine Rolle, in welchem Slot ich die Platten stecke? Der DSM Assistent sollte ja erkennen, dass auf den Platten schon DSM drauf war, dann müsste er mir doch die Migration vorschlagen oder?

 

7 hours ago, Lexizilla said:

Wozu eigentlich so ein setup für ein NAS ?

Da macht am Ende ein ESXi doch mehr Sinn. Da dann Xpenology als VM laufen lassen...

 

Ich weiss ist etwas OP und ich habe mir auch schon überlegt, ob ich zuerst Vmware auf dem Teil installieren soll und dann eine VM mit Xpenology. Aber würde das überhaupt gehen, ohne dass ich mein Raid formatieren muss? Weil ich müsste ja die Platten zuerst als Datastore auf dem Host anlegen, dann löscht es doch die Platten zuerst?

Share this post


Link to post
Share on other sites
19 minutes ago, Agent-Orange said:

die synoinfo.conf ist in der ISO drin oder?

 

iso? die synoinfo.conf die benutzt wird steckt in dem raid1 arry das auf alle platten verteilt ist /dev/md0 und dort gibt es zwei, eine in "/etc" die ist zur laufzeit aktiv und eine in "/etc.defaults" die wird beim booten als vorlage für die in /etc verwendet (wenn man die in "/etc.defaults" anpasst und neu startet wird die in "/etc" nach dem boot die neue sein)

"iso" kommt eigentlich nirgendwo vor, *.img für das bootloader image das aud usb kommt und *.pat für das DSM file von synology das man installiert

 

25 minutes ago, Agent-Orange said:

Aber das heisst prinzipiell spielt es keine Rolle, in welchem Slot ich die Platten stecke? Der DSM Assistent sollte ja erkennen, dass auf den Platten schon DSM drauf war, dann müsste er mir doch die Migration vorschlagen oder?

 

eigentlich sollte dsm das selbst merken (disk group) aber es schadet nicht sich SN der platten und wie sie im jetzigen system stecken auszuschreiben, als welche am internen sst hängen und die am sas controller (2 kabel mit je 4 sata - idealerweise an jedem kanel 1-4 beschriftet)

 

aber evtl. machst die die migration auf 3617 noch auf der alten hardware die kennst du und hast den boot im griff beim neuen board kannst du da schnell stolpern wenn du mit "klassisch bios booten" nicht klar kommst, also CSM mode in uefi bios aktivieren und dann auch vom richtigen (nicht uefi) boot device booten

 

32 minutes ago, Agent-Orange said:

ch weiss ist etwas OP und ich habe mir auch schon überlegt, ob ich zuerst Vmware auf dem Teil installieren soll und dann eine VM mit Xpenology. Aber würde das überhaupt gehen, ohne dass ich mein Raid formatieren muss?

 

hinge davon ab wie du es machen willst, du kannst den sas controller über vt-d als pcie device pass through an die vm weiter geben dann sind alle 8 disks (ohne die ssd) als raid volume (mit system) vorhanden und das usb image cann man über einen virtuellen sata port reinhängen (theoretisch geth auch usb stick als usb gerät an die vm durchreichen, ist aber zu fehleranfälig), die ssd kannst di für vmware verwenden, den zweiten sas controller kannst du dann auch an die xpenology vm durchreichen

https://xpenology.com/forum/topic/13061-tutorial-install-dsm-62-on-esxi-67/

durch die methode den controller durchzureichen hat man den vorteil das man s.m.a.r.t. infos weiter in dsm hat, habe aber von problemen gehört das einige nicht die plattenteparatur sehen konnten

mach aber nur sinn wenn man sich mit esx auch auskennt bzw. die zeit hat sich damit zu beschäftigen, den auch da muss man zusäzlich zu dsm auch wieder sicherheitsupdate installieren und sich mit configuration beschäftigen - viele optionen aber auch viel das man falsch konfigurieren kann, esx ist kein spielzeug, wenn man nur mal zum testen eine vm braucht tut es auch virtualbox unter windows

 

nachteil einer überzognen hardware ist das mehr an stromverbrauch und damit meist einher gehend auch mehr abwärme und geräuschpegel (da die wärme ja abtransportiert werden muss)

Share this post


Link to post
Share on other sites
On 1/12/2020 at 1:18 AM, IG-88 said:

 

iso? die synoinfo.conf die benutzt wird steckt in dem raid1 arry das auf alle platten verteilt ist /dev/md0 und dort gibt es zwei, eine in "/etc" die ist zur laufzeit aktiv und eine in "/etc.defaults" die wird beim booten als vorlage für die in /etc verwendet (wenn man die in "/etc.defaults" anpasst und neu startet wird die in "/etc" nach dem boot die neue sein)

"iso" kommt eigentlich nirgendwo vor, *.img für das bootloader image das aud usb kommt und *.pat für das DSM file von synology das man installiert

 

 

eigentlich sollte dsm das selbst merken (disk group) aber es schadet nicht sich SN der platten und wie sie im jetzigen system stecken auszuschreiben, als welche am internen sst hängen und die am sas controller (2 kabel mit je 4 sata - idealerweise an jedem kanel 1-4 beschriftet)

 

aber evtl. machst die die migration auf 3617 noch auf der alten hardware die kennst du und hast den boot im griff beim neuen board kannst du da schnell stolpern wenn du mit "klassisch bios booten" nicht klar kommst, also CSM mode in uefi bios aktivieren und dann auch vom richtigen (nicht uefi) boot device booten

 

 

 

 

Ich meinte das synoboot.img, welches ja auch anpassen muss wegen pid&vid. Aber jetzt ist klar, welches File du meinst. Ist ja im Moment noch nicht nötig, da ich nur 9 Laufwerke derzeit benötige. Werde die überflüssigen Sata-Ports auf dem Board deaktivieren.

Was das RAID betrifft, werde ich mir mal anschauen in welcher Reihenfolge die Platten am SAS-Controller dran sind. Dann werde ich sie in der gleichen Reihenfolge wieder anschliessen bzw. in die Slots stecken. Mal schauen wie DSM anschliessend damit klar kommt.

Ja, der Stromverbrauch wird sicher in die Höhe schiessen, wobei wenn das NAS nicht ausgelastet wird, taktet die CPU ja automatisch runter. Abwärme und Lärm spielt in diesem Fall keine Rolle, das Teil kommt in unseren Luftschutzkeller, da stört es niemanden und ein Lan-Anschluss ist auch vorhanden xD

 

Share this post


Link to post
Share on other sites

Ich habe das Upgrade nun gemacht, komischerweise erkennt mir das DSM nur drei Platten, die eine SSD sowie zwei Platten vom Raid-Controller. Die Maxdisks habe ich bereits erhöht in der synoinfo.conf und der Controller sowie das Bios erkennt alle Platten auf dem Controller.

 

Die Platten sind auch kompatibel mit dem 3617, das habe ich bereits geprüft. Was kann denn das sonst noch sein?

 

EDIT: Problem gefunden. Die Platten werden als E-Sata Platten erkannt. Wie geht das denn? In der Synoinfo.conf steht bei esataportcfg 0x0, dann dürfte DSM ja gar keine eSata Ports erkennen, wobei das Board ja sowieso keine hat.

 

Edited by Agent-Orange

Share this post


Link to post
Share on other sites

Hab das Problem gelöst, es werden nun alle Platten erkannt. Das Raid ist auch nicht defekt bzw. DSM hat alles sauber erkannt.

Wie sieht es denn eigentlich mit GPU support aus für das 3617XS? Weil aktuell ist eine Quadro P2000 installiert und wäre cool wenn ich die fürs Plex Transcoding benutzen könnte.

Share this post


Link to post
Share on other sites

 

18 minutes ago, Agent-Orange said:

aktuell ist eine Quadro P2000 installiert und wäre cool wenn ich die fürs Plex Transcoding benutzen

 

imho wird das nichts

https://xpenology.com/forum/topic/13797-tutorial-installing-918-62x-dsm-on-104b-loader-transcoding/?do=findComment&comment=123859

 

und nach dem überoptimistischen kommentar hat man von antec nichts mehr gehört

ich meine es gäbe ein oder zwei modelle mit nvidia als ki rechenknecht aber die sind nicht gehackt und ich vermute nvidia treiber für den alten kernel der 3617 (3.10.105) zu compilieren wird schwer bis geht nicht, 918+ vielleicht eher aber da gibts wieder das 8 core limit - davon abgesehen bis du da allein auf weiter flur, ich habe in der tutorial sektion was geschrieben wie man treiber compiliert/injiziert aber wenn du noch nie was mit kernel compilieren zu tun hattest musst du einige zeit einplanen

imho lohnt das nicht, man kann beii ausreichend netzwerkbandbreite alles direkt an den client streamen ohne transcodieren, viele können auch h.265 und 4k wiedergeben und selbst wenn nicht wäre es wohl einfacher einen 4k replay client für den tv/beamer zu kaufen als das in dsm zu friemeln

außerdem ist plex pass (hardaretranskodierung) kostenplichtig und die synology version unterstützt vielelicht nicht mal nvidia da es (bisher) auf synology keine nvidia treiber gibt

 

wenn das mit p2000 und transcoding wichtig ist dann rate ich von dsm ab, schau dir andere lösungen wie omv wo es keine treiber limits gibt, rein vom nas und der gui her ist omv auch ok, aber es gibt natürlich nicht so hochwertige zusätze wir bei dsm, aber in zeiten von docker ist das eigentlich nicht mehr so das problem

 

wenn du dsm machen willst schmeiß die karte raus, frisst nur unnötig strom

Share this post


Link to post
Share on other sites

Also kurz vorweg, den PlexPass habe ich. Bei meinem alten NAS funktionierte das HW-Transcoding, aber da hatte ich keine dedizierte Graka drin.

Also ich bin nicht auf DSM angewiesen, gab nette Features darin, aber kann prinzipiell auch eine andere Software sein. Die Frage ist halt, kann ich das bestehende RAID importieren wenn ich auf OMV wechseln würde? Weil ich habe derzeit keine Möglichkeit alle Filme irgendwo zwischen zu speichern.

Reintheoretisch könnte ich Plex sogar auf ein Windows system installieren. Wäre es prinzipiell nicht möglich, dass ein ESXi installiere und darauf DSM als VM laufen lassen, so dass ich mein RAID übernehmen kann und eine zweite VM mit Windows, wo ich Plex installieren würde? Mittels HW-Passthrough sollte ich doch die GPU direkt an die Windows VM durchreichen können?

Share this post


Link to post
Share on other sites
1 hour ago, Agent-Orange said:

Die Frage ist halt, kann ich das bestehende RAID importieren wenn ich auf OMV wechseln würde?

 

ja, kannst du aber auch leicht testen, platten abklemmen (nur zur sicherheit) omv installieren (geht auch von usb afair), platten wieder dran und omv hochfahren

ist mein plan B wenn dsm nicht mehr geht und ich über netzwerk an meine daten will

er sollte die daten volumes anzeigen, die raid1 system 2GB) und raid1 swap (2.4GB) wird er evtl. nicht anzeigen, sind aber auch uninteressant

in der konstallation lässt man sich dann auch offen wieder dsm zu benutzen da ja die partitonen noch da sind

 

1 hour ago, Agent-Orange said:

Wäre es prinzipiell nicht möglich, dass ein ESXi installiere und darauf DSM als VM laufen lassen,

 

wäre bei der dicken hardware eine überlegung wert, vor allem wenn man sie mit dsm nicht optimal nutzen kann

wenn man den plattencontroller über vt-d durchreichen kann ist es am einfachsten aber ich kann mich erinneren das bei manchen smart oder temperatur nicht mehr ging (trotz vt-d)

ob das mit der gpu wirklich so schmerfrei geht kannst du mal googlen, bsit du sicher nicht der erste

man sollte aber nicht aus dem auge verlieren was man ursprüglich vor hatte, wenn es ein keep it simple war dann entfernt man sich unter umständen vom ursprungsgedanken (die leute die sich eine echte syno hinstellen wollten es in der regel einfach haben)

obwohl ich beruflich auch vmware nutze bin ich beim nas trotzdem bei baremetal da ich keine permanenten vm's laufen habe und nichts komplexes mache aber würde ich permanent laufende vm's brauchen würde ich wohl auch auf esxi umrüsten (aber manches kann auch mit einem raspi oder ähnliches erledigen)

Share this post


Link to post
Share on other sites

Ja, ich denke, ich werde ESXi installieren und dann mein DSM als VM laufen lassen. So muss ich das bestehende Raid nicht anfassen und kann gewisse Funktionen von DSM trotzdem weiter nutzen.

Die Frage stellt sich nur die Frage, ob ich Plex auf einer Linux oder Windows VM laufen lassen soll. Bei Linux gibt es ja scheinbar noch Einschränkungen, was das HW-Transcoding betrifft in Zusammenspiel mit Nvidia Karten.

Bzgl. GPU Passthrough auf Esxi für Plex, das scheint zu funktionieren -> https://elatov.github.io/2018/04/esxi-65-passthrough-video-card-to-plex-vm/

 

Edited by Agent-Orange

Share this post


Link to post
Share on other sites

@Agent-Orange

 

Ich glaube du verwechselt Plex Media Server (Plex Pass vorausgesetzt) mit Emby Media Server. Plex greift für Hardware Transcoding auf Intel Quick Sync zurück

 

https://support.plex.tv/articles/115002178853-using-hardware-accelerated-streaming/

 

Und das ist in der CPU integriert. Hat also nichts mit der Grafikkarte zu tun.

Emby hingegen braucht für Hardware Transcoding eine Grafikkarte.

 

 

Gesendet von iPhone mit Tapatalk

 

Share this post


Link to post
Share on other sites

Nee, ich meine schon Plex. Also ich habe mehrere Threads im Plex Forum gesehen, welche Nvidia Grakas fürs HW-Transcoding einsetzen.

 

Beim Link den zu geschickt hast, steht ja folgendes:
If your Windows computer also has a dedicated graphics card, such as an NVIDIA or AMD GPU, some functions of Intel Quick Sync Video may become unavailable when the GPU is in use. If your computer has one of these GPUs, please install the latest NVIDIA drivers for Windows or AMD drivers for Windows to make sure that Plex can use your dedicated graphics card when Intel Quick Sync Video becomes unavailable.

 

Hier hat einer HW-Transcoding aktiv mit seiner AMD CPU & GPU -> https://forums.plex.tv/t/amd-for-hw-transcoding-or-intel-nvidia-only/234695/13

Share this post


Link to post
Share on other sites

Also es läuft nun alles wie ich es wollte 😍

Auf dem Server kurzerhand ESXi installiert und DSM als VM eingerichtet. Mein SAS-Controller konnte ich per PCI-Passthrough an die DSM-VM hängen und meine SSD musste ich mittels manuell erstellten RDM-Pointer anbinden. Dauerte ein wenig bis ich schlussendlich alle Platten wieder im DSM hatte. Hatte zuerst mein SAS-Controller in einem 8x PCIe Slot drin, da erkannte DSM nur 4 Platten obwohl der Host alle 8 Platten erkannte :-S

 

Nun habe ich eine zweite VM eingerichtet mit Windows als und die Quardo Karte per PCI-Passthrough durchgereicht. Nvidia Treiber installiert anschliessend die Vmware SVGA deaktiviert und Voila HW En- & Decoding funktioniert perfekt 😎

Obwohl der Esxi Web-Client schon besser geworden ist seit 5.1 aber würde ich immer noch viel lieber mit dem guten, alten vSphere Client arbeiten 🤓

Plex.PNG

Share this post


Link to post
Share on other sites
10 hours ago, Agent-Orange said:

einem 8x PCIe Slot drin, da erkannte DSM nur 4 Platten obwohl der Host alle 8 Platten erkannte :-S

 

und du hast ihn dann in einen 16x slot gesteckt?

war der 8x slot ein echter 8x oder nur ein mechanischer 8x slot mit einem 4x pcie dahinter?

Share this post


Link to post
Share on other sites

Korrekt, habe ihn dann in einen 16x Slot gesteckt. Ich muss mal ins Handbuch schauen, wie die Slots angeschlossen sind.

 

Dachte es wäre ein echter 8x Slot, aber da das Board PCIe bifurcation unterstützt könnte es sein, dass ich den Slot von 8x auf 4x/4x umgestellt habe im Bios. Hab da vorgestern was rumgespielt, als ich DSM direkt auf der Kiste installierte hatte.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.