HumanZ

Droits d'accès Transmission

Recommended Posts

Bonjour à tous !

 

Commençons par une petite présentation ! Je suis l'heureux propriétaire d'un NAS HP Proliant Gen8 depuis 5 ans, jusqu'à très récemment sous DSM 5.2 qui a été migré sous DSM 6.1.7.

 

Je rencontre depuis un problème avec Transmission.

J'ai un dossier sur le volume du NAS pour mes téléchargements, qui a été configuré à l'installation du Package.

Sous DSM 5.2, j'avais rajouté un disque dur externe sur lequel je transférai mes téléchargements terminés pour qu'ils seed sans incidence sur le stockage interne de mon NAS.

 

Sauf que depuis la MàJ sous DSM 6.1.7, Transmission n'accède plus à ce disque dur externe.
J'ai donc (pour le moment) perdu mes téléchargements en seed et les nouveaux téléchargements me bouffent du stockage interne.

 

J'ai vérifié les droits et, théoriquement, ils sont identiques sur le panneau de configuration : L/R pour les mêmes groupes, mêmes droits pour les mêmes users, bref la conf' est la même.

 

En vérifiant les droits directement dans les propriétés des dossiers concernés, l'interface permet une configuration plus fine... Seulement sur le dossier interne au volume du NAS.

Pour la configuration des droits du dossier sur le disque dur externe, seuls les permissions pour les propriétaires, les groupes et les autres sont disponibles.

 

J'ai bien évidemment essayé de mettre tous les droits à tous les groupes sur le DDE, redémarré à plusieurs reprises Transmission et le NAS, rien n'y fait.

J'ai aussi essayé d'utiliser la commande chmod -R 777, ça n'a rien changé.

 

Du coup, j'en appelle à votre aide et à vos expériences !

Merci ! 😁

 

Share this post


Link to post
Share on other sites

Bonjour,

Transmission agit en principe en tant que Daemon, donc il doit (c'est en général la cas pour des raisons de sécurité) un utilisateur nommé transmission, ou utilisé par l'application.

En donnant les droits d'accès à cet utilisateur, ou en le plaçant (plus risqué) dans un groupe ayant des droits admin, cela règlerait peut-être ton problème.

 

Jacques

Share this post


Link to post
Share on other sites

Bonjour,

 

Et bonne année !

J'ai, afin de tester ta solution, mis tous les droits à l'utilisateurs sc-transmission.

 

Après redémarrage du package et du NAS, aucun changement...

Share this post


Link to post
Share on other sites

As-tu essayé de désinstaller Transmission et le réinstaller ?

Sinon essaie avec DownloadStation.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.