Dadoo4492

Problème Ouverture vers l'exterieur

Recommended Posts

Bonjour à tous,

 

Je viens vers vous car j'ai passé le cap de faire un synoloHACK en 3615xs qui marche du feu de dieu.

 

Cependant, comme quick connect ne marche pas sur les "faux" NAS, j'ai prix un nom de domaine chez OVH.

 

J'utilise Radarr, Sonarr, Plex, docker avec Deluge, Jackett et OrganizR.

 

De ce que j'ai réussi à faire, j'arrive à joindre la page d'OrganizR par l'IP en dehors de chez moi, mais pas avec le nom de domaine... Et une fois sur cette page, en interne ou en externe, je n'arrive  pas à accéder aux paquets justement... Il y aurait il quelqu'un qui pourrait m'expliquer comment bien paramétrer OVH, le NAS et ma box surtout... je suis complétement perdu...

 

J'ai déjà créé des sous domaine dans OVH pour chaque application, et j'ai aussi créé des redirections sur mon adresse IP public avec les ports des aplpication (9117 exemple pour jackett)

Dans ma zone DNS par contre, mon domaine de type A, a la bonne adresse IP, mais les sous domaines ne gardent pas la bonne adresse (j'ai essayé de mettre la même que mon domaine)

 

Avec mon NAS, j'ai créé des règles Reverse proxy avec comme source : les adresses des sous domaines, et comme destination : http://localhost:9117 ( pour jackett)

 

Sur ma box, je ne sais pas quelles règles faire. Je voulais faire un 443 vers all avec l'IP de mon NAS, mais le "all" ne passe pas sur ma box (Red by SFR)

 

Rien ne passe de l'extérieur à part la page d'OrganizR mais que en IP.

 

Merci d'avance à tous ( en espérant être au bon endroit).

 

EDIT : sur tout mes sous-domaines, je n'en ai que 2 qui fonctionnes mais au lieu de pointer vers la bonne appli (nas ET organizr) j'arrive sur jackett...

Edited by Dadoo4492

Share this post


Link to post
Share on other sites

Salut,

 

Il nous manque une info essentielle : ton FAI. En effet il faut qu'on sache s'il celui-ci t'attribue une IP publique fixe.

 

Sur le portail OVH :

  • tu dois avoir un type A : ton domaine.fr ---> IP Publique Fixe
  • et autant de sous domaine de type CNAME qui pointe vers ton domaine.fr

 

Sur ta Box "en mode newbie" cad autant de port que de services :

  • tu rediriges chacun des ports de tes services vers l'IP du NAS:port du service. exemple si ton NAS à l'ip 192.168.1.100 sur ton réseau local :
    • Jackett : 9117 ---> 192.168.1.100:9117
    • Plex : 32400 ---> 192.168.1.100:32400
    • WebStation de Synology : 80---> 192.168.1.100:80
    • WebStation de Synology (si tu utilises HTTPS) : 443---> 192.168.1.100:443
    • DSM  : 5000---> 192.168.1.100:5000
    • DSM (si tu utilises HTTPS)  : 5001---> 192.168.1.100:5001
    • etc.
  • Dans ton navigateur tu taperas donc : http://mondomaine.fr:32400/ pour accéder à Plex ou https://mondomaine.fr:5001 pour accéder à DSM en HTTPS

 

Autre solution en mode plus propre (cad en utilisant un reverse proxy) :

  • Dans ta box : une unique redirection du port 80 et 443 de Webstation vers ton NAS 443---> 192.168.1.100:443
  • nativement DSM propose un reverse proxy basé sur Ngnix. Il suffit d'aller dans le panneau de configuration > Portail des applications > Proxy inversé :
  • chez moi cela donne
  • image.thumb.png.3173e669851ae2df5824fa3e835294fe.png

 

 

Share this post


Link to post
Share on other sites

Salut, merci pour ta rréponse. Je suis chez RED by SFR (je l'ai mis mais dans le pavé sa ne se voit pas beaucoup 😛

 

Si je comprend bien, dans OVH il me faut que 1 type A et mes sous domaines seront en CNAME. que dois-je mettre en cible ?

Capture1.PNG.de54199902d8031a575071ab8e8e363e.PNG

 

Ensuite, je met donc dans ma box 2 redirections ? une du 80 vers le 80 et l'autre du 443 vers le 443 ? (avec l’adresse IP interne de mon NAS )

 

Et pour finir, dans mon NAS oui j'ai mis un reverse proxy exactement comme tu m'a montré sur ta photo

 

Edited by Dadoo4492
fautes d'orthographe

Share this post


Link to post
Share on other sites
il y a 21 minutes, Dadoo4492 a dit :

Je suis chez RED by SFR

Oups, je prend rdv chez l'ophtalmo de suite^^

En regardant vite fait sur Google, difficile de confirmer si c'est bien une IP Fixe. Il semblerait que oui si tu est en ADSL ou FFTH mais si tu es en THD alors non.

 

Dans "Cible" il faut que tu saisisses ton nom de domaine avec un point à la fin. Exemple chez moi avec mon nom de domaine niko44.fr :

image.png.a1ba3e0db00dc7fc845742618ea6d35b.png

il y a 20 minutes, Dadoo4492 a dit :

Ensuite, je met donc dans ma box 2 redirections ? une du 80 vers le 80 et l'autre du 443 vers le 443 ? (avec l’adresse IP interne de mon NAS )

Oui. Pour le 443, il te faut un certificat que tu peux obtenir auprès de Let's Encrypt au travers de DSM dans la partie Sécurité.

 

 

Share this post


Link to post
Share on other sites

Ok merci.

 

Du coup, j'ai fait tout les CNAME (deluge, jackett, DSM, organizR, plex, radarr & sonarr)

 

Je ne peux pas faire les redirections de ports pour le moment je ne suis pas chez moi, je fais ça se soir 😉

 

je vais essayer de faire le let's encrypt là.

 

Du coup après ça, quand je taperais https://XXXXX.ovh j'atterrirai sur mon organizr ? ou sur mon nas directement ? OU alor il faudra taper le port ?

 

Share this post


Link to post
Share on other sites
il y a 36 minutes, Dadoo4492 a dit :

Du coup après ça, quand je taperais https://XXXXX.ovh j'atterrirai sur mon organizr ? ou sur mon nas directement ? OU alor il faudra taper le port ?

Euh si avec XXXXX tu sous-entends un sous domaine alors oui, par exemple si tu as nommé plex.mondomaine.ovh, alors dans le navigateur il faudra taper : http://plex.mondomaine.ovh ou https://plex.mondomaine.ovh si tu as préalablement configuré un certificat. C'est le principe du reverse-proxy ici. Ce dernier selon le nom du sous-domaine redirige la requête vers le bon service. Au niveau du routeur il suffit juste de rediriger respectivement les ports 80 et 443 vers les mêmes n° de ports du NAS.

 

Pour info, avec let's encrypt il est possible de demander un unique certificat pour plusieurs sous-domaine d'un même domaine. Pour ce faire il faut juste de les séparer par un point-virgule lors de la génération. Ce qui donne :

image.png.cbd51bf9b10eec80864091fb8e87c9ee.png

 

Honnêtement, dans un premier temps essaie de faire marcher tout ça en HTTP classique. Ce sera déjà pas mal! 

 

Share this post


Link to post
Share on other sites

ok donc des que je rentre chez moi, je fais une redirection du 80 vers le 192.168.1.X port 80 et pareil pour le 443 😁 je te tiens au courant et te remercie déjà pour toutes ces infos 😁

Share this post


Link to post
Share on other sites

Bon voilà j'ai fait mes 2 redirections et du coup :

 

http://organizR.mondomaine.ovh -------------NON
https://organizR.mondomaine.ovh ------------OK mais vers diskstation

 

http://deluge.mondomaine.ovh ------------------NON
https://deluge.mondomaine.ovh -----------------OK mais vers diskstation

 

http://jackett.mondomaine.ovh -----------------NON
https://jackett.mondomaine.ovh ----------------NON

 

http://nas.mondomaine.ovh------------------NON
https://nas.mondomaine.ovh-----------------OK

 

http://plex.mondomaine.ovh-----------------NON
https://plex.mondomaine.ovh----------------NON

 

http://radarr.mondomaine.ovh------------------NON
https://radarr.mondomaine.ovh-----------------NON

 

http://sonarr.mondomaine.ovh-------------------NON
https://sonarr.mondomaine.ovh------------------NON

 

Je ne comprend pas où j'ai pu me planter 😔

Share this post


Link to post
Share on other sites

Envoi nous :

  • une capture de "Panneau de configuration" > Portail des applications > Proxy inversé 
    • pour chaque service
  • une capture de "Panneau de configuration" > "Réseau" > Paramètres DSM
  • une capture de "Panneau de configuration" > Sécurité > Certificat (en mode déplié)

 

Pour info : lorsque tu modifies des entrées DNS chez ton provider de nom de domaine, il y a un temps de diffusion/réplication non négligeable vers les autres serveurs DNS. De plus, ton PC dispose nativement d'un cache DNS qu'il faut aussi purger pour être sûr qu'il requête vers la bonne adresse IP correspondant au nom DNS. Pour ce faire il faut - sous Windows - taper la commande suivante :

 

ipconfig /flushdns

 

 

Je ne vais pas te cacher que quand on clique sur ton lien http://organe.iridium.ovh on est effectivement redirigé vers https://organe.iridium.ovh:1805/. Donc ton serveur Ngnix écoute bien sur le port 80, mais effectue automatiquement une redirection https avec le n° de port... ce qui évidement ne correspond pas à ce que tu veux faire!

De même https://organe.iridium.ovh atterrit sur DSM ce qui indique que ton port 443 (tout comme ton port 80) est correctement redirigé vers ton NAS, mais le serveur Ngnix ne fait pas correctement ce qu'on attend de lui, d'où un mauvais paramétrage au niveau de celui-ci.

==> Au moins niveau routeur/box on est bon!

  • Like 1

Share this post


Link to post
Share on other sites

Salut a vous !

Je prend le topic en cours :)

 

Tu as bien déclaré chacun de tes sous-domaines chez ovh ?

 

Dans ton reverse proxy, tu redirige bien vers le bon port a chaque fois ?

 

Si par exemple le port de organizR est 8181 et que tu y accede en local par 192.168.0.66:8181, alors quand tu configure le reverse proxy, il te faudra entrer la source "organizR.mondomaine.ovh" et la cible "localhost" ainsi que le port 8181.

 

* locahost, si organizR est hebergé sur le NAS, sinon sont adresse ip local

 

Idem pour le reste, si deluge est accessible via la port 8282 en HTTPS voici un exemple :

KQgxMEt.png

 

 

Share this post


Link to post
Share on other sites

Je pense avoir mis les bon ports (sauf peut être jackett et organizR car ils marchent par docker et j'ai un peu de mal avec).

 

Voila les screen :

558706260_proxyinvers.PNG.8565aa7d630a119781c6daa894c2d08d.PNG

 

Jackett.mondomaine.ovh : (sous Docker)

460522894_proxyjackett.PNG.bd55c289ce7e68303c6061d75f8fbb9e.PNG

 

Accès NAS.mondomaine.ovh :

467565571_proxynas.PNG.1eae6a4ca6f654c7520c3dcc1878897f.PNG

 

Deluge.mondomaine.ovh :

709147854_proxydeluge.PNG.e521985a1d5f5c20bba13e485206e613.PNG

 

Plex.mondomaine.ovh :

2081653234_proxyplex.PNG.baaf77de96f693505f58fb532d43434d.PNG

 

OrganizR.mondomaine.ovh :

878653248_proxyorganizr.PNG.707fb038e6a089bcee19ed5556f64add.PNG

 

Radarr.mondomaine.ovh :

1823990959_proxyradarr.PNG.0235829fc8e7f107f216d6015ba203aa.PNG

 

Sonarr.mondomaine.ovh :

693702015_proxysonarr.PNG.5ed55d741fae1ba40dcc1131d71df071.PNG

 

Paramètres DSM :

1103028549_parametredsm.PNG.091f8128490625d0847d33bf48d9eabc.PNG

 

Certificats avec tout mes sous domaines:

certificat.thumb.PNG.719514def90d35934f9c9a4ea3e9611d.PNG

Share this post


Link to post
Share on other sites

Alors :

  • évite de rayer les mentions, tu exposes ton NAS sur internet donc autant assumer et ça facilite la lecture^^
  • La gestion du sous-domaine pour DSM ne se fait pas dans "reverseproxy" mais dans Réseau > Paramètres de DSM > Domaine.
    • tu peux donc enlever la ligne 1805
  • pour tout tes noms d’hôte Source il faut mettre le nom de sous domaine complet, exemple : organe.iridium.ovh et pas le nom de domaine.
  • evite le certificat autosigné, ça provoque une alerte de sécurité dans les navigateurs, génère en un avec Let's encrypt
  • du coté de Docker, le n° de port que tu indiques par exemple 5900 pour Radarr, est-ce bien le port exposer par le conteneur, et non pas celui interne au conteneur, exemple chez moi pour LXDE 

image.png

 

 

Share this post


Link to post
Share on other sites

OK désolé, je ne savais pas si je devais les cacher ou non 🤣

 

- Du coup, dans domaine, j'ai mis la même ligne.

- Pour tout les noms d'hôte, oui ne faisant les screen j'ai vu que j’avais oublié le sous domaine sur deux. 😅

- pour le certificat, OK je vais l'enlever et en ferais un sur let's encrypt

 

- pour les ports, je vais regarder de plus près pour les autres appli les ports sont bon on est d’accord ?

  • Radarr : 8310
  • Deluge : 8112
  • Plex : 32400
  • Sonarr : 8989

- Pour Docker, Voilà un screen de organizR je prend le quel ?

605942709_organizRdocker.PNG.dff1880f157b5e9dd4634d8fa5e51098.PNG

Share this post


Link to post
Share on other sites
il y a 11 minutes, Dadoo4492 a dit :

pour les autres appli les ports sont bon on est d’accord ?

Je ne peux pas le savoir à ta place, c'est toi qui a du les configurer^^ mais si tu n'as pas changé la conf par défaut alors oui ça doit être bon. Typiquement pour Plex effectivement le port par défaut c'est 32400.

 

il y a 11 minutes, Dadoo4492 a dit :

Du coup, dans domaine, j'ai mis la même ligne.

Tu veux dire que dans Réseau > Paramètres de DSM > Domaine tu as mis : nas.iridium.ovh, si oui alors OK. Mais il ne faut plus cette info coté Reverse-proxy.

 

il y a 11 minutes, Dadoo4492 a dit :

Voilà un screen de organizR je prend le quel ?

Ici OrganizR expose 2 ports, l'un en HTTPS (certainement autosigné) et l'autre http. Donc dans ton reverseproxy tu peux mettre ceci :

image.png.420433f14727998f45d6977077724242.png

[EDIT] : essaie dans un premier temps sans cocher "Activer HSTS" et "Activer HTTP/2". Chaque chose en son temps^^

 

Share this post


Link to post
Share on other sites
Il y a 12 heures, Dadoo4492 a dit :

Bon du coup, tout les http se mettent direct en https et toutes les adresses mènent à mon diskstation 😅

Ok dans ce cas je pense que ta redirection dans ta box n’est pas correcte. Tu peux nous envoyer une capture de ce que tu as mis dans ta box RedBy Sfr?

Share this post


Link to post
Share on other sites
Il y a 2 heures, Dadoo4492 a dit :

Bonjour,

 

Déjà joyeux réveillon 😁

 

voila le screen de ma box 😊

 

1810921940_screenbox.thumb.PNG.5203197fab41e559ed71feb3097d75f9.PNG

OK, c'est bien là ton erreur!

 

en port de destination tu mets respectivement 80 et 443 au lieu de 5000 et 1805

ce qui donne :

Nom Protocole Type Port externe IP destination Port de destination
nas http TCP Port 80 192.1681.34 80
nas https TCP Port 443 192.1681.34 443

 

Share this post


Link to post
Share on other sites
il y a 1 minute, nicoueron a dit :

OK, c'est bien là ton erreur!

 

en port de destination tu mets respectivement 80 et 443 au lieu de 5000 et 1805

Oui mais mes port de mon NAS on est daccord que de base c'est 5000 et 5001 (1805 car je l'ai changé) non ?

Share this post


Link to post
Share on other sites
il y a 4 minutes, Dadoo4492 a dit :

Oui mais mes port de mon NAS on est daccord que de base c'est 5000 et 5001 (1805 car je l'ai changé) non ?

Lol tu n'as pas compris l'objectif de la manip. Il faut rediriger les ports vers le serveur nginx du reverseproxy. On se fiche du n° de port de DSM ici puisque tu y accéderas via nas.iridium.ovh au travers du reverseproxy justement.

Fais moi confiance!

Share this post


Link to post
Share on other sites
il y a 9 minutes, Dadoo4492 a dit :

Salut DJR72, oui j'ai vu avec le DDNS on le relie à OVH et il fera le boulot tout seul ;)

si effectivment ton IP Publique change à chaque reboot de ta box, dans ce cas il faut utiliser un service ddns, mais pas celui de Synology trop peu réactif. Il faut qu'il soit initié depuis ta box. Là je ne sais si SFR propose un client DDNS capable de le faire surtout vers OVH. En général c'est plutot dyndns.org ou no-ip.org mais rarement OVH... Ce qui t'obligera à changer de nom de domaine (ie. refaire toute la config du reverse proxy^^)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.