Sign in to follow this  
Vae

[Résolu]Problème ajout de disque (HP Proliant)

Recommended Posts

Bonjour à tous,

 

Après avoir suivi un tuto très détaillé, j'ai pu installer Synology DSM 5 sur mon Microserver HP Proliant acheté pour l'occasion.

Une fois le tuto achevé, je suis ensuite parti en roue libre pour ajouter un second disque de 2To sur le NAS. J'ai pu créer l'image vmdk dans ESXi sans trop de problème, et je l'ai ajouté à la VM. Grâce au SHR, j'ai donc 2To en SHR (Raid 1).

 

Là où ça se corse, c'est qu'au moment de renouveler l'opération pour en ajouter un 3ème (toujours 2To), ça coince. Pas de soucis à la création de l'image vmdk, je l'ajoute à la VM, ESXi me dit bien que j'ai 5.46To dispo sur cette VM... mais une fois dans DSM, le disque n'apparaît pas. Rien à faire, j'ai tenté plusieurs disques, plusieurs emplacements dans les tiroirs, toujours le même problème... Du coup, vu que j'ai testé plusieurs disques / emplacements, j'écarterais le problème matériel au profit d'un problème de paramétrage. C'est là où j'ai besoin de vous :smile:

 

J'espère qu'il y a assez d'infos dans mon message, sinon n'hésitez pas à me demander. Merci d'avance.

Edited by Guest

Share this post


Link to post
Share on other sites

Désolé pour le double post, mais je crois que j'ai trouvé un truc intéressant.

 

Si j’exécute la commande "fdisk -l" depuis SSH sur le Diskstation, j'ai ce résultat :

DiskStation> fdisk -l

Disk /dev/sda: 2000.3 GB, 2000398934016 bytes
255 heads, 63 sectors/track, 243201 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

  Device Boot      Start         End      Blocks  Id System
/dev/sda1               1         311     2490240  fd Linux raid autodetect
Partition 1 does not end on cylinder boundary
/dev/sda2             311         572     2097152  fd Linux raid autodetect
Partition 2 does not end on cylinder boundary
/dev/sda3             588      243201  1948788912   f Win95 Ext'd (LBA)
/dev/sda5             589      243201  1948780864  fd Linux raid autodetect

Disk /dev/sdb: 2000.3 GB, 2000398934016 bytes
255 heads, 63 sectors/track, 243201 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

  Device Boot      Start         End      Blocks  Id System
/dev/sdb1               1         311     2490240  fd Linux raid autodetect
Partition 1 does not end on cylinder boundary
/dev/sdb2             311         572     2097152  fd Linux raid autodetect
Partition 2 does not end on cylinder boundary
/dev/sdb3             588      243201  1948788912   f Win95 Ext'd (LBA)
/dev/sdb5             589      243201  1948780864  fd Linux raid autodetect

Disk /dev/sdc: 2000.3 GB, 2000398934016 bytes
255 heads, 63 sectors/track, 243201 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

  Device Boot      Start         End      Blocks  Id System
/dev/sdc1               1      243201  1953512001   7 HPFS/NTFS
DiskStation>

Donc le troisième disque Esxi est vu par le Syno ! Mais il ne me l'affiche nulle part dans l'interface graphique, j'ignore pourquoi...

Share this post


Link to post
Share on other sites

Bonjour,

je pense qu'il s'agit peut être d'un problème du Bios mal configuré,

il faut tout d'abord flashé le Bios par une autre version si vous le

n'avez pas fait, je ne sais plus le lien mais il est dans le site,

pour le flasher,

 

Dans ce nouveau Bios modifié pour HP,

il faudra modifier donc, les disques durs en AHCI,

puis mettre les options suivantes :

Onship SATA Channel : Enabled

Onship IDE Type : IDE

SATA IDE Combined Mode : Disabled

SATA ESP on all Port : Enabled

SATA Power on all Port : Enabled

 

Ensuite rebootez, et voir si tous vos disques apparaissent,

je n'ai pas d'autres solutions à vous proposer pour le moment,

cordialement

 

0ric

Share this post


Link to post
Share on other sites

Merci pour la réponse, mais le bios est bel est bien déjà flashé, et la configuration et telle que suggéré...

 

Les disques sont bien reconnus dans le bios, dans ESXi, ainsi qu'en faisant fdisk dans DSM. C'est incompréhensible...

Share this post


Link to post
Share on other sites

Bon j'ai trouvé... Le tuto pointait sur le mauvais fichier pour l'installation de DSM et j'ai donc installé DSM pour NAS DS214Play, et c'est un NAS 2 baies...

 

J'ai mis à jour nanoboot et DSM en 5.0 4493 avec le bon fichier .pat, et là je vois tous mes disques.

Share this post


Link to post
Share on other sites
Sign in to follow this