Jump to content
XPEnology Community

Eaton UPS support


Recommended Posts

 (Discaimer : I've already posted in the french section but in a effort to broader my audience, I give it a try here)


I've just purchased a Ellipse ECO 650 USB FR (EL650USBFR) UPS


Unfortunately, I've battled with it for two hours trying to get DSM to detect it without success.


My config

  • HP Proliant Gen 8 Server
  • Xeon e3-1220 V2 
  • 16 GB RAM
  • IBM M1015 (IT mode)
  • ESXI 6.7 - the HP version ("HPE Custom Image for ESXi 6.7 GA").
  • Jun's Loader v1.03b DS3615xs


Basically, I've added a USB controler to my VM and a USB peripheral "EATON Ellipse ECO"

Which gives me nothing in the configuration panel in DSM. "No UPS attached"


Even though, running a "lsusb" give me a USB peripheral "EATON Ellipse Eco". So at least it's somewhere.


By writing these lines I've just realized that DS3615xs doesn't support my UPS. https://www.synology.com/fr-fr/compatibility?search_by=category&category=upses&filter_brand=EATON&p=1

This is unfortunate.


Is it dead or - given that I run xpenology and not really a DS615xs - there is a workaround ?


I've found this thread from 2013



A few things :

  • My "/usr/syno/etc/ups/ups.conf" is by default with "driver = triplite_usb"
  • I believe that my USB UPS supports driver "usbhid-ups" (from NUT website and various terminal commands I ran)


So, I've edited the up.conf file, changing :

  • driver = usbhid-ups
  • productid = the pid of my UPS
  • vendorid = the vid of my UPS (which is "fffff" weird)


Then I've spent 30 minutes finding how to escape vim 🥴


From the thread mentionned above I've run a check :
usbhid-ups -u root -DDD -a ups

But it spits various error among them a "usb descriptor thing". My USB device descriptor appears to be too long. Something something, me no likey


Writing those lines I just realize that I was logged as "admin" but ran the command with "-u root" (I don't know the root pw. my admin account has admin privilege).

So, maybe : usbhid-ups -u admin -DDD -a ups


Among the errors, I sometimes get error saying the USB device cannot be accessed. Elsewhere on the forum I've seen people modifying the chmod of some folder in order to extend the USB device accessibility. Hum.


Any clues ? Am I entirely wrong ?


Last chance would be to create a small headless VM just to run a NUT server in ESXI. But meh.



Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...