• 0
whatever

Let's encrypt cert fails

Question

I have never had a problem with adding a let's encrypt cert on loader 1.04 but I installed a 10gb nic and I had issue's with 1.04 and 1.03 it's been rock solid on 1.02 this is the only issue apart from not being on DSM 6.2.

 

I get the message "The operation failed. Please log in to DSM again and retry"

 

The box is on DSM 6.1.7-15284 Update 3. I have ddns set up in the router I have also tried it under external access in dsm and it returns normal, i have tried with my firewall rules running and with the firewall disabled in dsm,  I have dos protection auto block and account protection all enabled. I have tried it with and without redirect to https. I have also gone with and without http compression, modern and intermediate compatibility for tls/ssl cipher suites. I use a vpn client but I have tried with this enabled and disabled. port 80 and 443 are forwarded.

 

I am able to access my nas using the domain, I am currently using the synology cert but would prefer the lets encrypt. Any ideas how to solve this.

 

Share this post


Link to post
Share on other sites

5 answers to this question

Recommended Posts

  • 0

Same problem here, it worked like a Sharm since a couple of weeks ago but I had to reinstall my dsm and now I cannot request a certificate

Inviato dal mio SM-G950F utilizzando Tapatalk

Share this post


Link to post
Share on other sites
  • 0

Let's encrypt's acme-v01 API is deprecated and they switched to acme-v02. Problem: this is only supported since DSM 6.2.2 24922 Update 3 out of the box.

 

Since I'm on DSM 6.2.2 only I can't test it with DSM 6.1.

 

You could try:

 

/usr/syno/sbin/syno-letsencrypt replace-all

Don't use "renew", choose "replace".

  • Thanks 1

Share this post


Link to post
Share on other sites
  • 0
The question(s) in this topic have been answered and/or the topic author has resolved their issue. This topic is now closed. If you have other questions, please open a new topic.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.